# java.lang.IllegalArgumentException: plugin \[ingest-geoip\] is incompatible with version \[6.0.1\]; was designed for version \[6.0.0\]

**URL:** https://discuss.elastic.co/t/java-lang-illegalargumentexception-plugin-ingest-geoip-is-incompatible-with-version-6-0-1-was-designed-for-version-6-0-0/110727
**Category:** Elasticsearch
**Created:** [December 7, 2017, 6:04pm UTC](https://discuss.elastic.co/t/java-lang-illegalargumentexception-plugin-ingest-geoip-is-incompatible-with-version-6-0-1-was-designed-for-version-6-0-0/110727 "2017-12-07T18:04:21Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![alexus](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alexus/32/12696_2.png) [@alexus](https://discuss.elastic.co/u/alexus)
#### Post date: [December 7, 2017, 6:04pm UTC](https://discuss.elastic.co/t/java-lang-illegalargumentexception-plugin-ingest-geoip-is-incompatible-with-version-6-0-1-was-designed-for-version-6-0-0/110727/1 "2017-12-07T18:04:22Z")

</div>

after I update elasticearch from 6.0 to 6.0.1, elasticsearch.service won't start anymore and I'm getting errors in my error log:

```
# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.4 (Maipo)
# rpm -q elasticsearch
elasticsearch-6.0.1-1.noarch
# systemctl start elasticsearch
# echo $?
0
# systemctl status elasticsearch
● elasticsearch.service - Elasticsearch
   Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Thu 2017-12-07 13:04:41 EST; 44s ago
     Docs: http://www.elastic.co
  Process: 3167 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID_DIR}/elasticsearch.pid --quiet (code=exited, status=1/FAILURE)
 Main PID: 3167 (code=exited, status=1/FAILURE)

Dec 07 13:04:41 XXX systemd[1]: Started Elasticsearch.
Dec 07 13:04:41 XXX systemd[1]: Starting Elasticsearch...
Dec 07 13:04:41 XXX systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE
Dec 07 13:04:41 XXX systemd[1]: Unit elasticsearch.service entered failed state.
Dec 07 13:04:41 XXX systemd[1]: elasticsearch.service failed.
# grep -A1 ERROR /var/log/elasticsearch/elasticsearch.log 
[2017-12-07T12:49:25,842][ERROR][o.e.b.Bootstrap] Exception
java.lang.IllegalArgumentException: plugin [ingest-geoip] is incompatible with version [6.0.1]; was designed for version [6.0.0]
--
[2017-12-07T12:49:34,430][ERROR][o.e.b.Bootstrap] Exception
java.lang.IllegalArgumentException: plugin [ingest-geoip] is incompatible with version [6.0.1]; was designed for version [6.0.0]
--
[2017-12-07T12:51:08,031][ERROR][o.e.b.Bootstrap] Exception
java.lang.IllegalArgumentException: plugin [ingest-geoip] is incompatible with version [6.0.1]; was designed for version [6.0.0]
--
[2017-12-07T12:51:45,255][ERROR][o.e.b.Bootstrap] Exception
java.lang.IllegalArgumentException: plugin [ingest-geoip] is incompatible with version [6.0.1]; was designed for version [6.0.0]
--
[2017-12-07T12:52:45,519][ERROR][o.e.b.Bootstrap] Exception
java.lang.IllegalArgumentException: plugin [ingest-geoip] is incompatible with version [6.0.1]; was designed for version [6.0.0]
--
[2017-12-07T13:00:02,181][ERROR][o.e.b.Bootstrap] Exception
java.lang.IllegalArgumentException: plugin [ingest-geoip] is incompatible with version [6.0.1]; was designed for version [6.0.0]
--
[2017-12-07T13:00:49,457][ERROR][o.e.b.Bootstrap] Exception
java.lang.IllegalArgumentException: plugin [ingest-geoip] is incompatible with version [6.0.1]; was designed for version [6.0.0]
# 

```

needless to say, everything was working fine on 6.0.0

---

<div class="post-metadata">

### Author: ![alexus](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alexus/32/12696_2.png) [@alexus](https://discuss.elastic.co/u/alexus)
#### Post date: [December 7, 2017, 8:07pm UTC](https://discuss.elastic.co/t/java-lang-illegalargumentexception-plugin-ingest-geoip-is-incompatible-with-version-6-0-1-was-designed-for-version-6-0-0/110727/2 "2017-12-07T20:07:39Z")

</div>

not "best", but still solution (for now)

> yum downgrade elasticsearch kibana logstash metricbeat filebeat

---

<div class="post-metadata">

### Author: ![jasontedor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jasontedor/32/66992_2.png) [@jasontedor](https://discuss.elastic.co/u/jasontedor)
#### Post date: [December 8, 2017, 3:59am UTC](https://discuss.elastic.co/t/java-lang-illegalargumentexception-plugin-ingest-geoip-is-incompatible-with-version-6-0-1-was-designed-for-version-6-0-0/110727/3 "2017-12-08T03:59:02Z")

</div>

You need to uninstall ingest-geoip, and then install it on 6.0.1 again.

---

<div class="post-metadata">

### Author: ![alexus](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alexus/32/12696_2.png) [@alexus](https://discuss.elastic.co/u/alexus)
#### Post date: [December 8, 2017, 6:16pm UTC](https://discuss.elastic.co/t/java-lang-illegalargumentexception-plugin-ingest-geoip-is-incompatible-with-version-6-0-1-was-designed-for-version-6-0-0/110727/4 "2017-12-08T18:16:11Z")

</div>

@jasontedor

Thanks, I uninstalled `ingest-geoip`, perform update to elastic stack to 6.0.1 and then installed it back!

Everything worked as it should!

* * *

[Ingest Geoip Processor Plugin | Elasticsearch Plugins and Integrations [6.0] | Elastic](https://www.elastic.co/guide/en/elasticsearch/plugins/6.0/ingest-geoip.html)

---

<div class="post-metadata">

### Author: ![jasontedor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jasontedor/32/66992_2.png) [@jasontedor](https://discuss.elastic.co/u/jasontedor)
#### Post date: [December 8, 2017, 6:53pm UTC](https://discuss.elastic.co/t/java-lang-illegalargumentexception-plugin-ingest-geoip-is-incompatible-with-version-6-0-1-was-designed-for-version-6-0-0/110727/5 "2017-12-08T18:53:10Z")

</div>

You're welcome!

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [January 5, 2018, 6:53pm UTC](https://discuss.elastic.co/t/java-lang-illegalargumentexception-plugin-ingest-geoip-is-incompatible-with-version-6-0-1-was-designed-for-version-6-0-0/110727/6 "2018-01-05T18:53:29Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
