# Java.lang.NoSuchFieldError: LUCENE\_3\_6 After upgrade to ES 1.4.0

**URL:** <https://discuss.elastic.co/t/java-lang-nosuchfielderror-lucene-3-6-after-upgrade-to-es-1-4-0/20890>\
**Category:** Elasticsearch\
**Created:** [November 21, 2014, 3:16pm UTC](https://discuss.elastic.co/t/java-lang-nosuchfielderror-lucene-3-6-after-upgrade-to-es-1-4-0/20890 "2014-11-21T15:16:18Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![thealy](https://avatars.discourse-cdn.com/v4/letter/t/41988e/32.png) [@thealy](https://discuss.elastic.co/u/thealy)\
**Post date:** [November 21, 2014, 3:16pm UTC](https://discuss.elastic.co/t/java-lang-nosuchfielderror-lucene-3-6-after-upgrade-to-es-1-4-0/20890/1 "2014-11-21T15:16:18Z")

</div>

Hello-

Just upgraded ES cluster to 1.4.0 and my existing app fails with "java.lang.NoSuchFieldError: LUCENE\_3\_6". The java project was updated to use elasticsearch-1.4.0.jar, and includes a pile of lucene-\*-4.6.1 jars.

The exception occurs in the ES Transport initialization:

Settings settings = ImmutableSettings.settingsBuilder().put("cluster.name", esClusterName).build();  
client = new TransportClient(settings).addTransportAddress(new InetSocketTransportAddress("1.2.3.4", 9300))

I have removed all old elasticsearch and lucene jars from the environment, but the problem persists.

Any suggestions?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 12:48am UTC](https://discuss.elastic.co/t/java-lang-nosuchfielderror-lucene-3-6-after-upgrade-to-es-1-4-0/20890/2 "2017-07-06T00:48:26Z")

</div>


