# Java::oracle.jdbc.driver.OracleDriver not loaded

**URL:** <https://discuss.elastic.co/t/java-oracle-jdbc-driver-oracledriver-not-loaded/68866>\
**Category:** Logstash\
**Created:** [December 13, 2016, 12:30pm UTC](https://discuss.elastic.co/t/java-oracle-jdbc-driver-oracledriver-not-loaded/68866 "2016-12-13T12:30:46Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Rudolf\_Reddy\_Macejka](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rudolf_reddy_macejka/32/12875_2.png) [@Rudolf\_Reddy\_Macejka](https://discuss.elastic.co/u/Rudolf_Reddy_Macejka)\
**Post date:** [December 13, 2016, 12:30pm UTC](https://discuss.elastic.co/t/java-oracle-jdbc-driver-oracledriver-not-loaded/68866/1 "2016-12-13T12:30:46Z")

</div>

Hello,

since I am trying to use logstash 5 my connection to Oracle stopped to work.  
On 2.1 it works perfectly with this configuration

```
input {
      jdbc { jdbc_driver_library => "/home/tva/prototype/logstash-5.0.2/lib/custom-jars/ojdbc6.jar"
                    jdbc_driver_class => "Java::oracle.jdbc.driver.OracleDriver"
                    jdbc_connection_string => "jdbc:oracle:thin:@//oracle-test.something.com:1521/KUK"
                    jdbc_user => "user"
                    jdbc_password => "user"
                    parameters => { }
                    schedule => "* * * * *"
                    statement => "select sysdate from dual"
    }
}

```

In log I can see following error:

```
[2016-12-13T13:17:36,175][ERROR][logstash.agent] Pipeline aborted due to error {:exception=>#<LogStash::ConfigurationError: Java::oracle.jdbc.driver.OracleDriver not loaded. Are you sure you've included the correct jdbc driver in :jdbc_driver_library?>, :backtrace=>["/home/tva/prototype/logstash-5.0.2/vendor/bundle/jruby/1.9/gems/logstash-input-jdbc-4.1.3/lib/logstash/plugin_mixins/jdbc.rb:157:in `prepare_jdbc_connection'", "/home/tva/prototype/logstash-5.0.2/vendor/bundle/jruby/1.9/gems/logstash-input-jdbc-4.1.3/lib/logstash/inputs/jdbc.rb:191:in `register'", "/home/tva/prototype/logstash-5.0.2/logstash-core/lib/logstash/pipeline.rb:319:in `start_inputs'", "org/jruby/RubyArray.java:1613:in `each'", "/home/tva/prototype/logstash-5.0.2/logstash-core/lib/logstash/pipeline.rb:318:in `start_inputs'", "/home/tva/prototype/logstash-5.0.2/logstash-core/lib/logstash/pipeline.rb:195:in `start_workers'", "/home/tva/prototype/logstash-5.0.2/logstash-core/lib/logstash/pipeline.rb:153:in `run'", "/home/tva/prototype/logstash-5.0.2/logstash-core/lib/logstash/agent.rb:250:in `start_pipeline'"]}
[2016-12-13T13:17:36,203][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=>9601}

```

What have been changed there since 5.0?  
Based on Stackoverflow and other forums it seems that I am not alone with this problem.

Can you please advise?

Thank you  
Reddy

---

<div class="post-metadata">

**Author:** ![Jakub\_Zak](https://avatars.discourse-cdn.com/v4/letter/j/71c47a/32.png) [@Jakub\_Zak](https://discuss.elastic.co/u/Jakub_Zak)\
**Post date:** [December 15, 2016, 10:23am UTC](https://discuss.elastic.co/t/java-oracle-jdbc-driver-oracledriver-not-loaded/68866/2 "2016-12-15T10:23:46Z")

</div>

Problem solved by replacing ojdbc6.jar with ojdbc7.jar

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 12, 2017, 10:23am UTC](https://discuss.elastic.co/t/java-oracle-jdbc-driver-oracledriver-not-loaded/68866/3 "2017-01-12T10:23:46Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
