# Javapipeline unrecoverable error - Logstash

**URL:** <https://discuss.elastic.co/t/javapipeline-unrecoverable-error-logstash/198957>\
**Category:** Logstash\
**Created:** [September 10, 2019, 6:41pm UTC](https://discuss.elastic.co/t/javapipeline-unrecoverable-error-logstash/198957 "2019-09-10T18:41:11Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Matthew\_Graville](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/matthew_graville/32/53743_2.png) [@Matthew\_Graville](https://discuss.elastic.co/u/Matthew_Graville)\
**Post date:** [September 10, 2019, 6:41pm UTC](https://discuss.elastic.co/t/javapipeline-unrecoverable-error-logstash/198957/1 "2019-09-10T18:41:11Z")

</div>

I am unsure what I am doing wrong. Any help is much appreciated:  
Logstash cmd: `[root@logstash bin]# ./logstash -f /etc/logstash/conf.d/rsyslog.conf --config.reload.automatic`  
Logstash Error1:  
`[ERROR] 2019-09-10 13:48:13.716 [[main]<tcp] javapipeline - A plugin had an unrecoverable error. Will restart this plugin. Pipeline_id:main Plugin: <LogStash::Inputs::Tcp host=>"10.10.69.33", codec=><LogStash::Codecs::JSON id=>"json_1a9f0a72-71d8-4fb4-aab8-4428fdc49a80", enable_metric=>true, charset=>"UTF-8">, id=>"c7fdbc85088d3782739655cee941b6eec9998ea10591083aee85553b71bafd8c", type=>"rsyslog", port=>10514, enable_metric=>true, mode=>"server", proxy_protocol=>false, ssl_enable=>false, ssl_verify=>true, ssl_key_passphrase=><password>, tcp_keep_alive=>false, dns_reverse_lookup_enabled=>true> Error: Cannot assign requested address Exception: Java::JavaNet::BindException Stack: sun.nio.ch.Net.bind0(Native Method)`  
Logstash Error2:  
`[ERROR] 2019-09-10 13:48:18.059 [[main]<tcp] rejectedExecution - Failed to submit a listener notification task. Event loop shut down? java.util.concurrent.RejectedExecutionException: event executor terminated at io.netty.util.concurrent.SingleThreadEventExecutor.reject(SingleThreadEventExecutor.java:821) ~[logstash-input-tcp-6.0.3.jar:?]`  
rsyslog.conf:  
`  
# The # character at the beginning of a line indicates a comment. Use  
# comments to describe your configuration.  
input {  
tcp {  
host =\> "10.10.69.33"  
port =\> "10514"  
codec =\> "json"  
type =\> "rsyslog"  
}  
}  
# The filter part of this file is commented out to indicate that it is  
# optional.  
filter {  
# if [type] == "rsyslog" {  
# grok {  
# match =\> { "message" =\> "%{SYSLOGTIMESTAMP:syslog\_timestamp} %{SYSLOGHOST:syslog\_hostname} %{DATA:syslog\_program}(?:[%{POSINT:syslog\_pid}])?: %{GREEDYDATA:syslog\_message}" }  
# add\_field =\> ["received\_at", "%{@timestamp}"]  
# add\_field =\> ["received\_from", "%{host}"]  
# }  
# date {  
# match =\> ["syslog\_timestamp", "MMM d HH:mm:ss", "MMM dd HH:mm:ss"]  
# }  
# }  
}  
output {  
if [type] == "rsyslog" {  
elasticsearch {  
hosts =\> ["10.10.69.20:9200"]  
}  
}  
}

`  
Followed the elastic guide here fine: [Parsing Logs with Logstash](https://www.elastic.co/guide/en/logstash/current/advanced-pipeline.html)  
Having problems with this Elastic Guide: [How To Centralize Logs with Rsyslog, Logstash, and Elasticsearch on Ubuntu 14.04](https://www.elastic.co/blog/how-to-centralize-logs-with-rsyslog-logstash-and-elasticsearch-on-ubuntu-14-04)  
I think my rsyslog is setup fine as I see the dev FW logs flowing in np. I believe I also have disabled the firewalls. These are dev sandboxes. I am using CentOS and the guide is for Ubuntu, but I believe it is fine/Ihave taken it into account.

As for the error, how do I fix Java Plugins? I am using Java 11 and it is installed fine I believe.

---

<div class="post-metadata">

**Author:** ![Matthew\_Graville](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/matthew_graville/32/53743_2.png) [@Matthew\_Graville](https://discuss.elastic.co/u/Matthew_Graville)\
**Post date:** [September 10, 2019, 6:58pm UTC](https://discuss.elastic.co/t/javapipeline-unrecoverable-error-logstash/198957/2 "2019-09-10T18:58:29Z")

</div>

Apologies I think it is somethign with enabling TCP port 10514 on the host...firewalld is off though hmmm.

---

<div class="post-metadata">

**Author:** ![Matthew\_Graville](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/matthew_graville/32/53743_2.png) [@Matthew\_Graville](https://discuss.elastic.co/u/Matthew_Graville)\
**Post date:** [September 10, 2019, 7:31pm UTC](https://discuss.elastic.co/t/javapipeline-unrecoverable-error-logstash/198957/3 "2019-09-10T19:31:18Z")

</div>

I can't figure it out...I have the firewall disabled and port 10514 is in the services file? WHat gives? ANyone?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 8, 2019, 7:31pm UTC](https://discuss.elastic.co/t/javapipeline-unrecoverable-error-logstash/198957/4 "2019-10-08T19:31:25Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
