# JDBC driver library error

**URL:** <https://discuss.elastic.co/t/jdbc-driver-library-error/328705>\
**Category:** Logstash\
**Created:** [March 28, 2023, 10:35am UTC](https://discuss.elastic.co/t/jdbc-driver-library-error/328705 "2023-03-28T10:35:50Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Rakesh\_Mukherjee](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rakesh_mukherjee/32/118164_2.png) [@Rakesh\_Mukherjee](https://discuss.elastic.co/u/Rakesh_Mukherjee)\
**Post date:** [March 28, 2023, 10:35am UTC](https://discuss.elastic.co/t/jdbc-driver-library-error/328705/1 "2023-03-28T10:35:50Z")

</div>

I am using Azure MySql server and trying to ingest logs to logstash using jdbc input plug-in. While running logstash, it is giving me error that

Pipeline error {:pipeline\_id=\>"main", :exception=\>#\<LogStash::PluginLoadingError: unable to load mysql-connector-java-5.1.36-bin.jar from :jdbc\_driver\_library, file not readable (please check user and group permissions for the path)\>

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 25, 2023, 10:36am UTC](https://discuss.elastic.co/t/jdbc-driver-library-error/328705/2 "2023-04-25T10:36:09Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
