# Jdbc for sqlserver

**URL:** <https://discuss.elastic.co/t/jdbc-for-sqlserver/198058>\
**Category:** Logstash\
**Created:** [September 4, 2019, 1:57pm UTC](https://discuss.elastic.co/t/jdbc-for-sqlserver/198058 "2019-09-04T13:57:22Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![elasticforme](https://avatars.discourse-cdn.com/v4/letter/e/f05b48/32.png) [@elasticforme](https://discuss.elastic.co/u/elasticforme)\
**Post date:** [September 4, 2019, 1:57pm UTC](https://discuss.elastic.co/t/jdbc-for-sqlserver/198058/1 "2019-09-04T13:57:22Z")

</div>

I am trying to connect to microsoft sqlserver but no luck  
I can connect to this db using microsoft sqlserver management studio.  
What am I missing here?

```
   input {
        jdbc {
            jdbc_validate_connection => true
            jdbc_driver_library => "/root/sqljdbc_7.4/enu/mssql-jdbc-7.4.1.jre12.jar"
            jdbc_driver_class => "com.microsoft.sqlserver.jdbc.SQLServerDriver"
            jdbc_connection_string => "jdbc:sqlserver://server1:1433;databaseName=h_db"
            jdbc_user => "xyz"
            jdbc_password => "xxx"
            statement => "select * from v_H_view"
            clean_run=>true
           }
    }

```

Getting following error.  
Error: com.microsoft.sqlserver.jdbc.SQLServerDriver not loaded. Are you sure you've included the correct jdbc driver in :jdbc\_driver\_library?  
Exception: LogStash::ConfigurationError  
Stack: /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-input-jdbc-4.3.13/lib/logstash/plugin\_mixins/jdbc/jdbc.rb:163:in `open_jdbc_connection' /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-input-jdbc-4.3.13/lib/logstash/plugin_mixins/jdbc/jdbc.rb:221:in`execute\_statement'  
/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-input-jdbc-4.3.13/lib/logstash/inputs/jdbc.rb:277:in `execute_query' /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-input-jdbc-4.3.13/lib/logstash/inputs/jdbc.rb:263:in`run'  
/usr/share/logstash/logstash-core/lib/logstash/java\_pipeline.rb:309:in `inputworker' /usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:302:in`block in start\_input'  
[ERROR] 2019-09-04 07:58:01.022 [[main]\<jdbc] javapipeline - A plugin had an unrecoverable error. Will restart this plugin.

Pipeline\_id:main  
Plugin: \<LogStash::Inputs::Jdbc jdbc\_user=\>"xyz", jdbc\_validate\_connection=\>true, jdbc\_password=\>, statement=\>"select \* from v\_H\_view", clean\_run=\>true, jdbc\_driver\_library=\>"/root/sqljdbc\_7.4/enu/mssql-jdbc-7.4.1.jre12.jar", jdbc\_connection\_string=\>"jdbc:sqlserver://server1:1433;databaseName=h\_db", id=\>"2dd70d10625903fc97b655f7bde6cca1187a89e8dac5d97a4ca0d8876020fa36", jdbc\_driver\_class=\>"com.microsoft.sqlserver.jdbc.SQLServerDriver", enable\_metric=\>true, codec=\>\<LogStash::Codecs::Plain id=\>"plain\_f7d9a927-b440-453b-b31d-edfc25071e90", enable\_metric=\>true, charset=\>"UTF-8"\>, jdbc\_paging\_enabled=\>false, jdbc\_page\_size=\>100000, jdbc\_validation\_timeout=\>3600, jdbc\_pool\_timeout=\>5, sql\_log\_level=\>"info", connection\_retry\_attempts=\>1, connection\_retry\_attempts\_wait\_time=\>0.5, parameters=\>{"sql\_last\_value"=\>1970-01-01 00:00:00 UTC}, last\_run\_metadata\_path=\>"/root/.logstash\_jdbc\_last\_run", use\_column\_value=\>false, tracking\_column\_type=\>"numeric", record\_last\_run=\>true, lowercase\_column\_names=\>true\>

---

<div class="post-metadata">

**Author:** ![elasticforme](https://avatars.discourse-cdn.com/v4/letter/e/f05b48/32.png) [@elasticforme](https://discuss.elastic.co/u/elasticforme)\
**Post date:** [September 10, 2019, 8:24pm UTC](https://discuss.elastic.co/t/jdbc-for-sqlserver/198058/2 "2019-09-10T20:24:17Z")

</div>

Anyone out there who has done this successfully?

I came across exactly one thread who has done it but didn't work for me  
I am running ELK 7.3.1

[root@elktst01 conf.d]# java -version  
java version "1.8.0\_152"

```
input {
    jdbc {
        jdbc_validate_connection => false
        jdbc_driver_library => "/root/sqljdbc_4.2/enu/jre8/sqljdbc42.jar"
        jdbc_driver_class => "com.microsoft.sqlserver.jdbc.SQLServerDriver"
        jdbc_connection_string => "jdbc:sqlserver://server1:1433;databaseName=db1;integratedSecurity=false;"
        jdbc_user => "user1"
        jdbc_password => "password1"
        statement => "select * from dbo.v_ASSET"
        clean_run=>true
       }
}

```

[ERROR] 2019-09-10 14:54:22.101 [[main]\<jdbc] jdbc - Unable to connect to database. Tried 1 times {:error\_message=\>"Java::ComMicrosoftSqlserverJdbc::SQLServerException: Login failed for user 'user1'. ClientConnectionId:69dffba5-4185-442e-8a33-d3b6e0663019"}

[ERROR] 2019-09-10 15:03:24.015 [[main]\<jdbc] javapipeline - A plugin had an unrecoverable error. Will restart this plugin.

Error: Java::ComMicrosoftSqlserverJdbc::SQLServerException: Login failed for user 'user1'. ClientConnectionId:5f31bdf1-6be8-4b74-aa56-7f4858a7c62d  
Exception: Sequel::DatabaseConnectionError

But I am able to login to database using microsoft sql server management studio. though this user account is AD account.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 8, 2019, 8:24pm UTC](https://discuss.elastic.co/t/jdbc-for-sqlserver/198058/3 "2019-10-08T20:24:20Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
