# Jdbc importer not compaptible with shield/user auth?

**URL:** <https://discuss.elastic.co/t/jdbc-importer-not-compaptible-with-shield-user-auth/59309>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-security\
**Created:** [August 30, 2016, 12:35pm UTC](https://discuss.elastic.co/t/jdbc-importer-not-compaptible-with-shield-user-auth/59309 "2016-08-30T12:35:46Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![pkyt](https://avatars.discourse-cdn.com/v4/letter/p/3da27b/32.png) [@pkyt](https://discuss.elastic.co/u/pkyt)\
**Post date:** [August 30, 2016, 12:35pm UTC](https://discuss.elastic.co/t/jdbc-importer-not-compaptible-with-shield-user-auth/59309/1 "2016-08-30T12:35:46Z")

</div>

Hi guys,

We are experiencing an issue with communication between our program and elastic-search cloud server. We are using jdbc importer to transfer data to elastic-search from local database. Jdbc importer is a Java based program which guarantees a complete transfer of data.

We are unable to establish connection to cloud system. This is due to a failed request of getting a node info, which disconnecting our program from server. More detailed information can be found in Exception #1 below. This results in an error that causes our program to fail. This error is due to availability of nodes. More detailed information about the error can be found in Exception #2.

Exception #1: NodeDisconnectedException

[INFO][org.elasticsearch.org.xbib.elasticsearch.helper.client.TransportClient][pool-3-thread-1] [importer] failed to get node info for {#transport#-1}{50.16.191.15}{[49a470021ebdb61e456ccae825b9adcd.us-east-1.aws.found.io/50.16.191.15:9343](http://49a470021ebdb61e456ccae825b9adcd.us-east-1.aws.found.io/50.16.191.15:9343)}, disconnecting...  
org.elasticsearch.transport.NodeDisconnectedException: [][[49a470021ebdb61e456ccae825b9adcd.us-east-1.aws.found.io/50.16.191.15:9343](http://49a470021ebdb61e456ccae825b9adcd.us-east-1.aws.found.io/50.16.191.15:9343)][cluster:monitor/nodes/liveness] disconnected

Exception #2: NoNodeAvailableException

[ERROR][importer.jdbc][pool-3-thread-1] error while processing request: no cluster nodes available, check settings {autodiscover=false, client.transport.ignore\_cluster\_name=false, client.transport.nodes\_sampler\_interval=5s, client.transport.ping\_timeout=5s, cluster.name=49a470021ebdb61e456ccae825b9adcd, flush\_interval=5s, [host.0=49a470021ebdb61e456ccae825b9adcd.us-east-1.aws.found.io](http://host.0=49a470021ebdb61e456ccae825b9adcd.us-east-1.aws.found.io), max\_actions\_per\_request=10000, max\_concurrent\_requests=16, max\_volume\_per\_request=10mb, name=importer, port=9343, sniff=false}  
org.elasticsearch.client.transport.NoNodeAvailableException: no cluster nodes available, check settings {autodiscover=false, client.transport.ignore\_cluster\_name=false, client.transport.nodes\_sampler\_interval=5s, client.transport.ping\_timeout=5s, cluster.name=49a470021ebdb61e456ccae825b9adcd, flush\_interval=5s, [host.0=49a470021ebdb61e456ccae825b9adcd.us-east-1.aws.found.io](http://host.0=49a470021ebdb61e456ccae825b9adcd.us-east-1.aws.found.io), max\_actions\_per\_request=10000, max\_concurrent\_requests=16, max\_volume\_per\_request=10mb, name=importer, port=9343, sniff=false}

We are wondering how to fix the problem, how to establish a valid connection to the cloud server through using jdbc importer?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 1:42pm UTC](https://discuss.elastic.co/t/jdbc-importer-not-compaptible-with-shield-user-auth/59309/2 "2017-07-06T13:42:04Z")

</div>


