# Jdbc mariadb works in logstash 6.8, but not in logstash 7.5

**URL:** <https://discuss.elastic.co/t/jdbc-mariadb-works-in-logstash-6-8-but-not-in-logstash-7-5/211261>\
**Category:** Logstash\
**Created:** [December 10, 2019, 9:37am UTC](https://discuss.elastic.co/t/jdbc-mariadb-works-in-logstash-6-8-but-not-in-logstash-7-5/211261 "2019-12-10T09:37:32Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![ErikWarming](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/erikwarming/32/39525_2.png) [@ErikWarming](https://discuss.elastic.co/u/ErikWarming)\
**Post date:** [December 10, 2019, 9:37am UTC](https://discuss.elastic.co/t/jdbc-mariadb-works-in-logstash-6-8-but-not-in-logstash-7-5/211261/1 "2019-12-10T09:37:32Z")

</div>

We have updated our ES to 7.5 and therefore I am also updating our logstash'es. I know that Logstash 6.8 works with ES 7.5, so this is not a crisis.

BUT...

When I run these two config files, 6.8 works, but 7.5 don't. The mariadb drivers have been copied from the 6.8 folder to 7.5 folder. I have updated logstash-input-jdbc to 4.3.19 and I am out of ideas.

Logstash config 7.5

```
input {
   jdbc {
    jdbc_driver_library => "C:/Logstash/logstash-7.5.0/plugin/mariadb-java-client-2.4.2.jar"
    jdbc_driver_class => "Java::org.mariadb.jdbc.Driver"
    jdbc_connection_string => "jdbc:mariadb://XX.XX.XXX.X:XXXX/dbname"
    jdbc_user => "MYUSER"
    jdbc_password => "MYPASSWORD"
    statement => "select * from OrganizationFhir limit 10" 
  } 
}

filter {
}

output {
    stdout { codec => rubydebug } 

```

Logstash 6.8

```
input {
   jdbc {
    jdbc_driver_library => "C:/Logstash/logstash-6.8.0/plugin/mariadb-java-client-2.4.2.jar"
    jdbc_driver_class => "Java::org.mariadb.jdbc.Driver"
    jdbc_connection_string => "jdbc:mariadb://XX.XX.XXX.X:XXXX/dbname"
    jdbc_user => "MYUSER"
    jdbc_password => "MYPASSWORD"
    statement => "select * from OrganizationFhir limit 10" 
  } 
}

filter {
}

output {
    stdout { codec => rubydebug } 

```

I'm getting the following error message

> [2019-12-10T10:20:55,437][ERROR][logstash.inputs.jdbc][main] Unable to connect to database. Tried 1 times {:error\_message=\>"Java::JavaSql::SQLException: No suitable driver found for jdbc:mariadb://XX.XX.XXX.X:XXXX/dbname"}  
> [2019-12-10T10:20:55,437][ERROR][logstash.javapipeline][main] A plugin had an unrecoverable error. Will restart this plugin.  
> Pipeline\_id:main  
> Plugin: \<LogStash::Inputs::Jdbc jdbc\_user=\>"MYUSER", jdbc\_password=\>, statement=\>"select \* from OrganizationFhir limit 10", jdbc\_driver\_library=\>"C:/Logstash/logstash-7.5.0/plugin/mariadb-java-client-2.4.2.jar", jdbc\_connection\_string=\>"jdbc:mariadb://XX.XX.XXX.X:XXXX/dbname", id=\>"a525f87a88a4afef35b7feb49deed1486f860dbc6b74947fca66a8c4673ca293", jdbc\_driver\_class=\>"Java::org.mariadb.jdbc.Driver", enable\_metric=\>true, codec=\>\<LogStash::Codecs::Plain id=\>"plain\_e68fd36c-b0fd-4cfa-aa8e-35d8cc723ee7", enable\_metric=\>true, charset=\>"UTF-8"\>, jdbc\_paging\_enabled=\>false, jdbc\_page\_size=\>100000, jdbc\_validate\_connection=\>false, jdbc\_validation\_timeout=\>3600, jdbc\_pool\_timeout=\>5, sql\_log\_level=\>"info", connection\_retry\_attempts=\>1, connection\_retry\_attempts\_wait\_time=\>0.5, plugin\_timezone=\>"utc", last\_run\_metadata\_path=\>"C:\Users\N1XERW/.logstash\_jdbc\_last\_run", use\_column\_value=\>false, tracking\_column\_type=\>"numeric", clean\_run=\>false, record\_last\_run=\>true, lowercase\_column\_names=\>true, use\_prepared\_statements=\>false\>  
> Error: Java::JavaSql::SQLException: No suitable driver found for jdbc:mariadb://XX.XX.XXX.X:XXXX/dbname  
> Exception: Sequel::DatabaseConnectionError  
> Stack: java.sql.DriverManager.getConnection(java/sql/DriverManager.java:689)  
> java.sql.DriverManager.getConnection(java/sql/DriverManager.java:247)  
> java.lang.reflect.Method.invoke(java/lang/reflect/Method.java:498)

---

<div class="post-metadata">

**Author:** ![ErikWarming](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/erikwarming/32/39525_2.png) [@ErikWarming](https://discuss.elastic.co/u/ErikWarming)\
**Post date:** [December 11, 2019, 9:51am UTC](https://discuss.elastic.co/t/jdbc-mariadb-works-in-logstash-6-8-but-not-in-logstash-7-5/211261/2 "2019-12-11T09:51:39Z")

</div>

As suggested in [https://discuss.elastic.co/t/logstash-jdbc-class-cannot-found/209807](https://discuss.elastic.co/t/logstash-jdbc-class-cannot-found/209807) I changed the driver library to

> jdbc\_driver\_library =\> "c:/logstash/logstash-7.5.0/lib/jars/mariadb-java-client-2.4.2.jar"

but my jdbc connection via logstash 7.5 still don't work. Are we looking at a **undokumented breaking feature**?

---

<div class="post-metadata">

**Author:** ![ErikWarming](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/erikwarming/32/39525_2.png) [@ErikWarming](https://discuss.elastic.co/u/ErikWarming)\
**Post date:** [December 13, 2019, 8:48am UTC](https://discuss.elastic.co/t/jdbc-mariadb-works-in-logstash-6-8-but-not-in-logstash-7-5/211261/3 "2019-12-13T08:48:29Z")

</div>

The correct path is `jdbc_driver_library =>{logstash_install_dir}/logstash-core/lib/jars/` and now it works

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 10, 2020, 8:49am UTC](https://discuss.elastic.co/t/jdbc-mariadb-works-in-logstash-6-8-but-not-in-logstash-7-5/211261/4 "2020-01-10T08:49:57Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
