# Jdbc\_static logstash plugin, multiple loaders, Parameter field not found in event

**URL:** <https://discuss.elastic.co/t/jdbc-static-logstash-plugin-multiple-loaders-parameter-field-not-found-in-event/298764>\
**Category:** Logstash\
**Created:** [March 3, 2022, 4:34pm UTC](https://discuss.elastic.co/t/jdbc-static-logstash-plugin-multiple-loaders-parameter-field-not-found-in-event/298764 "2022-03-03T16:34:13Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Q11](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/q11/32/102575_2.png) [@Q11](https://discuss.elastic.co/u/Q11)\
**Post date:** [March 3, 2022, 4:34pm UTC](https://discuss.elastic.co/t/jdbc-static-logstash-plugin-multiple-loaders-parameter-field-not-found-in-event/298764/1 "2022-03-03T16:34:13Z")

</div>

I am using the jdbc\_static logstash plugin, and I want to enrich events with different types of data.

I have multiple loaders set, but not all events have the parameter field for each loader.

This shuts down the entire pipeline when it occurs. I would prefer it fails gracefully as it's normal to reach that point with some events not being able to be enriched. That's okay in my use case.

I can't if statement the loaders in jdbc\_static. What options do I have to run multiple loaders and enrichments where some of the time the fields are not going to be available in one or more loaders?

Error: Parameter field not found in event  
javapipeline - Pipeline worker error, the pipeline will be stopped

---

<div class="post-metadata">

**Author:** ![Q11](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/q11/32/102575_2.png) [@Q11](https://discuss.elastic.co/u/Q11)\
**Post date:** [March 3, 2022, 5:28pm UTC](https://discuss.elastic.co/t/jdbc-static-logstash-plugin-multiple-loaders-parameter-field-not-found-in-event/298764/2 "2022-03-03T17:28:27Z")

</div>

Solved the issue just filling in "unavailable" for the fields that didn't exist.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 31, 2022, 5:29pm UTC](https://discuss.elastic.co/t/jdbc-static-logstash-plugin-multiple-loaders-parameter-field-not-found-in-event/298764/3 "2022-03-31T17:29:02Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
