# JMS Input Plugin for Logstash - Tibco JMS Provider

**URL:** <https://discuss.elastic.co/t/jms-input-plugin-for-logstash-tibco-jms-provider/240151>\
**Category:** Logstash\
**Created:** [July 7, 2020, 11:42am UTC](https://discuss.elastic.co/t/jms-input-plugin-for-logstash-tibco-jms-provider/240151 "2020-07-07T11:42:47Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![rohitdgp](https://avatars.discourse-cdn.com/v4/letter/r/ecc23a/32.png) [@rohitdgp](https://discuss.elastic.co/u/rohitdgp)\
**Post date:** [July 7, 2020, 11:42am UTC](https://discuss.elastic.co/t/jms-input-plugin-for-logstash-tibco-jms-provider/240151/1 "2020-07-07T11:42:47Z")

</div>

I was reading through JMS as input plugin for Logstash.

Post reading the documentation i was trying to setup a Logstash EMS listener for Tibco JMS provider with JNDI configuration.

Although the official elastic-matrix mentions the support of JMS input plugin is only supported for Active MQ, Active MQ Artemis and Solace -\> [https://www.elastic.co/support/matrix#matrix\_logstash\_plugins](https://www.elastic.co/support/matrix#matrix_logstash_plugins)

But digging up more into this i also found a query-solution for the same -\> [https://github.com/logstash-plugins/logstash-input-jms/issues/11](https://github.com/logstash-plugins/logstash-input-jms/issues/11)

The configuration mentioned in the above github issue link states that the jndi\_name =\> ConnectionFactory

While doing the same for my setup it was unable to lookup the destination.  
I figured that the Instance of Tibco JMS is setup such that each connection to the Topic/Queue requires a registered ClientId which in turns takes the place of jndi\_name and this successfully looks up the Subcriber and connects to the broker using the Subscriber password.

Nw the problem that i face is its unable to lookup the destination Topic/Queue.

JMS internally tries to create the Topic/Queue when it cannot locate it and hence throws an error -\>

exception \_message =\> “Method createTopic() not supported for dynamic topic creation — this has to be done with JNDI lookup()”

Unable to find out the exact issue here. (would be great to know if Tibco is actually supported)

For reference, My JMS config

```auto
input {
    jms {
        include_header => true
        include_properties => true
        include_body => true
        use_jms_timestamp => true
        destination => “CM.GLBL.EVENT.T” (The name of my topic)
        pub_sub => true
        yaml_file => “D:/logstash/config/jndiems.yml”
        yaml_section => “ems”
    }
}

output {
    stdout { codec => json }
}

```

// My jndiems.yml file

```auto
ems:
  :username: “subscriber_username”
  :password: “subscriber_password”
  :jndi_name: “CM.GLBL::EVENT.Subscriber.ID1” (client id for the connection to the Topic/Queue)
  :jndi_context:
     java.naming.factory.initial: javax.naming.api.InitialContextFactory
     java.naming.provider.url: “ldap://global.name.com/dc=global,dc=name,dc=com”
     java.naming.security.principal: “CN=adminjms,OU=Users,OU=Global,DC=global,DC=name,DC=com”
     java.naming.security.credentials: “jms@dmin”

  :require_jars:
     - “D:/logstash/config/lib/tibjms-4.4.1.jar”
     - “D:/logstash/config/lib/jms-1.1.jar”
     - “D:/logstash/config/lib/commons-lang-2.6.jar”

```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 4, 2020, 11:42am UTC](https://discuss.elastic.co/t/jms-input-plugin-for-logstash-tibco-jms-provider/240151/2 "2020-08-04T11:42:54Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
