# Job for elasticsearch.service failed because the control process exited with error code

**URL:** https://discuss.elastic.co/t/job-for-elasticsearch-service-failed-because-the-control-process-exited-with-error-code/109831
**Category:** Elasticsearch
**Created:** [November 30, 2017, 8:34pm UTC](https://discuss.elastic.co/t/job-for-elasticsearch-service-failed-because-the-control-process-exited-with-error-code/109831 "2017-11-30T20:34:01Z")
**Posts on this page:** 1
**Showing post:** 5

<div class="post-metadata">

### Author: ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)
#### Post date: [December 1, 2017, 3:19am UTC](https://discuss.elastic.co/t/job-for-elasticsearch-service-failed-because-the-control-process-exited-with-error-code/109831/5 "2017-12-01T03:19:57Z")

</div>

> This file exists in 5.6.1 but after installing 6.0.0 on Ubuntu 16.04 .... it does not exist anymore.

That is correct. We no longer use this file in 6.0.0.  
The core issue you have is that your `elasticsearch.service` file still refers to it (although you've since resolved that).

It is likely that you edited that `elasticsearch.service` at some point in the past, so when you upgraded your elasticsearch install, the package manager was unable to reconcile the changes in the .deb with your local installation.  
Even though you have worked around this issue, you should check the logs from your upgrade because it is possible that you have missed other installation steps that could be important.

Please see the first half of this thread:

> [@Cant start ES after update from 5.6.2 to 6.0](https://discuss.elastic.co/t/cant-start-es-after-update-from-5-6-2-to-6-0/108843/4):
>
> This is the key log line. We do not have an ExecStartPre entry in 6.0.0 yet clearly your unit file still refers to one after the upgrade. This means you still have an old 5.x unit file and the upgrade did not replace the unit file with the 6.0.0 unit file. Maybe you edited the unit file (don’t do that!) and when you upgraded the package installer gave you a .rpmnew. You need to use the 6.0.0 unit file. Try to test changes to your production system in a staging environment first.

---

_[View the full topic](https://discuss.elastic.co/t/job-for-elasticsearch-service-failed-because-the-control-process-exited-with-error-code/109831)._
