# Job for elasticsearch.service failed because the control process exited with error code

**URL:** https://discuss.elastic.co/t/job-for-elasticsearch-service-failed-because-the-control-process-exited-with-error-code/246853
**Category:** Elasticsearch
**Created:** [August 29, 2020, 6:31pm UTC](https://discuss.elastic.co/t/job-for-elasticsearch-service-failed-because-the-control-process-exited-with-error-code/246853 "2020-08-29T18:31:15Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![hamzakarim](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hamzakarim/32/86716_2.png) [@hamzakarim](https://discuss.elastic.co/u/hamzakarim)
#### Post date: [August 29, 2020, 6:31pm UTC](https://discuss.elastic.co/t/job-for-elasticsearch-service-failed-because-the-control-process-exited-with-error-code/246853/1 "2020-08-29T18:31:15Z")

</div>

I have newly installed the Elasticsearch-7.4.2-x86\_64.rpm with rmp from the link

> **[Install Elasticsearch with RPM | Elasticsearch Guide \[7.6\] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/7.6/rpm.html)**

But when i start the service it gives the below error .  
**sudo systemctl start elasticsearch.service**

> Job for elasticsearch.service failed because the control process exited with error code. See "systemctl status elasticsearch.service" and "journalctl -xe" for details.

In journalctl it giving the below error 🙂

Aug 29 06:33:25 [webs101rdns1.pcsservers.com](http://webs101rdns1.pcsservers.com) systemd[1]: Starting Elasticsearch...  
Aug 29 06:33:33 [webs101rdns1.pcsservers.com](http://webs101rdns1.pcsservers.com) systemd-entrypoint[2625]: fatal error in thread [main], exiting  
Aug 29 06:33:33 [webs101rdns1.pcsservers.com](http://webs101rdns1.pcsservers.com) systemd-entrypoint[2625]: java.lang.NoClassDefFoundError: Could not initialize class com.sun.jna.Native  
Aug 29 06:33:33 [webs101rdns1.pcsservers.com](http://webs101rdns1.pcsservers.com) systemd-entrypoint[2625]: at org.elasticsearch.systemd.Libsystemd.lambda$static$0(Libsystemd.java:34)  
Aug 29 06:33:33 [webs101rdns1.pcsservers.com](http://webs101rdns1.pcsservers.com) systemd-entrypoint[2625]: at java.base/java.security.AccessController.doPrivileged(AccessController.java:312)  
Aug 29 06:33:33 [webs101rdns1.pcsservers.com](http://webs101rdns1.pcsservers.com) systemd-entrypoint[2625]: at org.elasticsearch.systemd.Libsystemd.(Libsystemd.java:33)  
Aug 29 06:33:33 [webs101rdns1.pcsservers.com](http://webs101rdns1.pcsservers.com) systemd-entrypoint[2625]: at org.elasticsearch.systemd.SystemdPlugin.sd\_notify(SystemdPlugin.java:126)  
Aug 29 06:33:33 [webs101rdns1.pcsservers.com](http://webs101rdns1.pcsservers.com) systemd-entrypoint[2625]: at org.elasticsearch.systemd.SystemdPlugin.onNodeStarted(SystemdPlugin.java:137)  
Aug 29 06:33:33 [webs101rdns1.pcsservers.com](http://webs101rdns1.pcsservers.com) systemd-entrypoint[2625]: at java.base/java.util.ArrayList.forEach(ArrayList.java:1510)  
Aug 29 06:33:33 [webs101rdns1.pcsservers.com](http://webs101rdns1.pcsservers.com) systemd-entrypoint[2625]: at org.elasticsearch.node.Node.start(Node.java:868)  
Aug 29 06:33:33 [webs101rdns1.pcsservers.com](http://webs101rdns1.pcsservers.com) systemd-entrypoint[2625]: at org.elasticsearch.bootstrap.Bootstrap.start(Bootstrap.java:317)  
Aug 29 06:33:33 [webs101rdns1.pcsservers.com](http://webs101rdns1.pcsservers.com) systemd-entrypoint[2625]: at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:402)  
Aug 29 06:33:33 [webs101rdns1.pcsservers.com](http://webs101rdns1.pcsservers.com) systemd-entrypoint[2625]: at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:170)  
Aug 29 06:33:33 [webs101rdns1.pcsservers.com](http://webs101rdns1.pcsservers.com) systemd-entrypoint[2625]: at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:161)  
Aug 29 06:33:33 [webs101rdns1.pcsservers.com](http://webs101rdns1.pcsservers.com) systemd-entrypoint[2625]: at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86)  
Aug 29 06:33:33 [webs101rdns1.pcsservers.com](http://webs101rdns1.pcsservers.com) systemd-entrypoint[2625]: at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:127)  
Aug 29 06:33:33 [webs101rdns1.pcsservers.com](http://webs101rdns1.pcsservers.com) systemd-entrypoint[2625]: at org.elasticsearch.cli.Command.main(Command.java:90)  
Aug 29 06:33:33 [webs101rdns1.pcsservers.com](http://webs101rdns1.pcsservers.com) systemd-entrypoint[2625]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:126)  
Aug 29 06:33:33 [webs101rdns1.pcsservers.com](http://webs101rdns1.pcsservers.com) systemd-entrypoint[2625]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92)  
Aug 29 06:33:33 [webs101rdns1.pcsservers.com](http://webs101rdns1.pcsservers.com) systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE  
Aug 29 06:33:33 [webs101rdns1.pcsservers.com](http://webs101rdns1.pcsservers.com) systemd[1]: Failed to start Elasticsearch.  
Aug 29 06:33:33 [webs101rdns1.pcsservers.com](http://webs101rdns1.pcsservers.com) systemd[1]: Unit elasticsearch.service entered failed state.  
Aug 29 06:33:33 [webs101rdns1.pcsservers.com](http://webs101rdns1.pcsservers.com) systemd[1]: elasticsearch.service failed.

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [August 31, 2020, 1:54am UTC](https://discuss.elastic.co/t/job-for-elasticsearch-service-failed-because-the-control-process-exited-with-error-code/246853/2 "2020-08-31T01:54:08Z")

</div>

Welcome to our community! 😃

Please check the Elasticsearch logs for more information, you can use `journalctl -u elasticsearch.service` for that, or look at the log file in `/var/log/elasticsearch/.

Please also format your code/logs/config using the `</>` button, or markdown style back ticks. It helps to make things easy to read which helps us help you 🙂

---

<div class="post-metadata">

### Author: ![hamzakarim](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hamzakarim/32/86716_2.png) [@hamzakarim](https://discuss.elastic.co/u/hamzakarim)
#### Post date: [August 31, 2020, 5:03am UTC](https://discuss.elastic.co/t/job-for-elasticsearch-service-failed-because-the-control-process-exited-with-error-code/246853/3 "2020-08-31T05:03:52Z")

</div>

Thank you for your response .

The issue was resolved and it was due to /tmp that was non exec .

I have make the /tmp exec and it start working.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [September 28, 2020, 5:03am UTC](https://discuss.elastic.co/t/job-for-elasticsearch-service-failed-because-the-control-process-exited-with-error-code/246853/4 "2020-09-28T05:03:57Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
