# Kabana pdf reporting error

**URL:** https://discuss.elastic.co/t/kabana-pdf-reporting-error/353820
**Category:** Kibana
**Tags:** elastic-stack-reporting
**Created:** [February 21, 2024, 10:15pm UTC](https://discuss.elastic.co/t/kabana-pdf-reporting-error/353820 "2024-02-21T22:15:05Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![mst3r25](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mst3r25/32/97109_2.png) [@mst3r25](https://discuss.elastic.co/u/mst3r25)
#### Post date: [February 21, 2024, 10:15pm UTC](https://discuss.elastic.co/t/kabana-pdf-reporting-error/353820/1 "2024-02-21T22:15:05Z")

</div>

When I try to export a dashboard to pdf I get a "err\_bad\_ssl\_client\_auth\_cert https://{ip}:5601/s/....."  
This only happens when running pdf reports. All my users and transport connection work fine using SSL. I have a 5 Elastic nodes and 2 Kibana nodes.  
I tried setting: xpack.security.transport.ssl.verification\_mode: certificate adn no luck.

---

<div class="post-metadata">

### Author: ![mst3r25](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mst3r25/32/97109_2.png) [@mst3r25](https://discuss.elastic.co/u/mst3r25)
#### Post date: [February 22, 2024, 7:20pm UTC](https://discuss.elastic.co/t/kabana-pdf-reporting-error/353820/2 "2024-02-22T19:20:27Z")

</div>

I solved this issue. I need to set server.ssl.clientAuthentication: "optional"

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [March 21, 2024, 7:20pm UTC](https://discuss.elastic.co/t/kabana-pdf-reporting-error/353820/3 "2024-03-21T19:20:44Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
