# Kafka output failed in 6.4.0

**URL:** https://discuss.elastic.co/t/kafka-output-failed-in-6-4-0/145868
**Category:** Logstash
**Created:** [August 24, 2018, 8:30am UTC](https://discuss.elastic.co/t/kafka-output-failed-in-6-4-0/145868 "2018-08-24T08:30:07Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![shiloong](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shiloong/32/44625_2.png) [@shiloong](https://discuss.elastic.co/u/shiloong)
#### Post date: [August 24, 2018, 8:30am UTC](https://discuss.elastic.co/t/kafka-output-failed-in-6-4-0/145868/1 "2018-08-24T08:30:07Z")

</div>

In logstash 6.4.0 on MacOS and oracle jdk 1.8.0\_181-b13，use the default setting for kafka output plugin start failed  
`[logstash.outputs.kafka] Unable to create Kafka producer from given configuration {:kafka_error_message=>org.apache.kafka.common.config.ConfigException: Invalid value 32768 for configuration receive.buffer.bytes: Expected value to be a 32-bit integer, but it was a java.lang.Long, :cause=>nil}`

---

<div class="post-metadata">

### Author: ![Leaf](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leaf/32/53337_2.png) [@Leaf](https://discuss.elastic.co/u/Leaf)
#### Post date: [August 28, 2018, 11:35pm UTC](https://discuss.elastic.co/t/kafka-output-failed-in-6-4-0/145868/2 "2018-08-28T23:35:52Z")

</div>

This should be fixed in the latest version (7.1.3) of the plugin

```
bin/logstash-plugin update logstash-output-kafka

```

🙂

---

<div class="post-metadata">

### Author: ![shiloong](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shiloong/32/44625_2.png) [@shiloong](https://discuss.elastic.co/u/shiloong)
#### Post date: [August 29, 2018, 1:20am UTC](https://discuss.elastic.co/t/kafka-output-failed-in-6-4-0/145868/3 "2018-08-29T01:20:42Z")

</div>

Thank you

---

<div class="post-metadata">

### Author: ![ericrichter](https://avatars.discourse-cdn.com/v4/letter/e/898d66/32.png) [@ericrichter](https://discuss.elastic.co/u/ericrichter)
#### Post date: [September 1, 2018, 11:08am UTC](https://discuss.elastic.co/t/kafka-output-failed-in-6-4-0/145868/4 "2018-09-01T11:08:53Z")

</div>

this should be documented as a known bug in the release notes and very soon (next monday) be fixed in logstash 6.4.1.

---

<div class="post-metadata">

### Author: ![eperry](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/eperry/32/551_2.png) [@eperry](https://discuss.elastic.co/u/eperry)
#### Post date: [October 5, 2018, 7:29pm UTC](https://discuss.elastic.co/t/kafka-output-failed-in-6-4-0/145868/6 "2018-10-05T19:29:34Z")

</div>

just ran into this issue too with

#rpm -qa | grep logstash  
logstash-6.4.0-1.noarch

and doing the /usr/share/logstash/bin/logstash-plugin update logstash-output-kafka

fixed it

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [November 2, 2018, 7:29pm UTC](https://discuss.elastic.co/t/kafka-output-failed-in-6-4-0/145868/7 "2018-11-02T19:29:36Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
