# Keep getting error when set watcher email action, elastic 7.5.1 on docker

**URL:** <https://discuss.elastic.co/t/keep-getting-error-when-set-watcher-email-action-elastic-7-5-1-on-docker/231276>\
**Category:** Elasticsearch\
**Created:** [May 6, 2020, 6:34am UTC](https://discuss.elastic.co/t/keep-getting-error-when-set-watcher-email-action-elastic-7-5-1-on-docker/231276 "2020-05-06T06:34:17Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![ElasticLiver](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/elasticliver/32/64869_2.png) [@ElasticLiver](https://discuss.elastic.co/u/ElasticLiver)\
**Post date:** [May 6, 2020, 6:34am UTC](https://discuss.elastic.co/t/keep-getting-error-when-set-watcher-email-action-elastic-7-5-1-on-docker/231276/1 "2020-05-06T06:34:18Z")

</div>

Hi, I have three master nodes of elastic 7.5.1 running on docker, in each elasticsearch.yml, I have added this conf

```auto
xpack.notification.email.account:
    outlook_account:
        profile: outlook
        smtp:
            auth: true
            starttls.enable: true
            host: smtp.office365.com
            port: 587
            user: my@mail.com

```

inside each container of those three nodes I have set the password with this command

```auto
bin/elasticsearch-keystore add xpack.notification.email.account.outlook_account.smtp.secure_password

```

I've tried to set the watcher on kibana interface, but get this error:

```auto
Caused by: javax.mail.AuthenticationFailedException: failed to connect, no password specified?

```

Then I tried via dev tools adding the key/value from, because in another post someone make it work addin "from"

```auto
    "actions": {
        "email_1": {
            "email": {
                "profile": "standard",
                "from": "my@mail.com",
                "to": [
                    "other@gmail.com"
                ],
                "subject": "Watch [{{ctx.metadata.name}}] has exceeded the threshold",
                "body": {
                    "text": "sadasd"
                }
            }
        }
    }

```

Any ideas on what is happening?  
do I need to change some configuration on the office336 mail acount?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 3, 2020, 6:34am UTC](https://discuss.elastic.co/t/keep-getting-error-when-set-watcher-email-action-elastic-7-5-1-on-docker/231276/2 "2020-06-03T06:34:25Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
