Keyword field is missing

Hi all,
I am spinning an ELK stack (6.6.1). Everything worked well, when suddenly all the "keyword" fields vanished from my items (new indexes, but also older ones that for sure did get those fields in the past). I have hard time trying to find documentation on how these fields are calculated. I've checked mappings which are good (it worked before btw, and there were no changes). I don't know where to search clues in logs or anywhere else.

Any help would be appreciated !

without more information this is really hard to tell. Is it possible that you deleted an index template and thus new indices will not have the proper mapping anymore?


Hello Alexander.
Thank you for your reply... Just found out, in fact, the index content comes from serilog, and some config on this side had changed... disabling usage of the "keyword" fields... Thus, I can tell that ES was not to incriminate in that situation. My knowledge on this subject was indeed ending at the mapping step, that I did check, and recheck before posting here.
Thanks again :slight_smile:
Great day !

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.