# Kibana 4.3.1 On Windows XP - Unable to connect to Elasticsearch at http://localhost:9200

**URL:** <https://discuss.elastic.co/t/kibana-4-3-1-on-windows-xp-unable-to-connect-to-elasticsearch-at-http-localhost-9200/37997>\
**Category:** Kibana\
**Created:** [December 27, 2015, 9:54am UTC](https://discuss.elastic.co/t/kibana-4-3-1-on-windows-xp-unable-to-connect-to-elasticsearch-at-http-localhost-9200/37997 "2015-12-27T09:54:54Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![swarnkar](https://avatars.discourse-cdn.com/v4/letter/s/f4b2a3/32.png) [@swarnkar](https://discuss.elastic.co/u/swarnkar)\
**Post date:** [December 27, 2015, 9:54am UTC](https://discuss.elastic.co/t/kibana-4-3-1-on-windows-xp-unable-to-connect-to-elasticsearch-at-http-localhost-9200/37997/1 "2015-12-27T09:54:54Z")

</div>

Hello there.  
I am trying to setup elasticsearch-2.1.1 and kibana-4.3.1 on windows XP SP3:  
I am able to push data to ES and able to access it via Head Plugin. But Kibana is not connecting to ES, it shows:  
Status: Red  
plugin:elasticsearch : Unable to connect to Elasticsearch at [http://localhost:9200](http://localhost:9200). Retrying in 2.5 seconds.

Changes made into elasticsearch.yml:  
network.host: 127.0.0.1  
http.port: 9200

Changes made to kibana.yml:  
server.host: "127.0.0.1"  
elasticsearch.url: "[http://localhost:9200](http://localhost:9200)"  
elasticsearch.ssl.verify: false

I even tried adding ports 9200 and 5601 to firewall exception but no luck. Please suggest.

Kibana Log:  
{"type":"log","@timestamp":"2015-12-27T09:44:26+00:00","tags":["status","plugin:kibana","info"],"pid":2624,"name":"plugin:kibana","state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}  
{"type":"log","@timestamp":"2015-12-27T09:44:26+00:00","tags":["status","plugin:elasticsearch","info"],"pid":2624,"name":"plugin:elasticsearch","state":"yellow","message":"Status changed from uninitialized to yellow - Waiting for Elasticsearch","prevState":"uninitialized","prevMsg":"uninitialized"}  
{"type":"log","@timestamp":"2015-12-27T09:44:26+00:00","tags":["error","elasticsearch"],"pid":2624,"message":"Request error, retrying -- connect UNKNOWN"}  
{"type":"log","@timestamp":"2015-12-27T09:44:26+00:00","tags":["status","plugin:kbn\_vislib\_vis\_types","info"],"pid":2624,"name":"plugin:kbn\_vislib\_vis\_types","state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}  
{"type":"log","@timestamp":"2015-12-27T09:44:26+00:00","tags":["warning","elasticsearch"],"pid":2624,"message":"Unable to revive connection: [http://localhost:9200/](http://localhost:9200/)"}  
{"type":"log","@timestamp":"2015-12-27T09:44:26+00:00","tags":["warning","elasticsearch"],"pid":2624,"message":"No living connections"}  
{"type":"log","@timestamp":"2015-12-27T09:44:26+00:00","tags":["status","plugin:elasticsearch","error"],"pid":2624,"name":"plugin:elasticsearch","state":"red","message":"Status changed from yellow to red - Unable to connect to Elasticsearch at [http://localhost:9200](http://localhost:9200). Retrying in 2.5 seconds.","prevState":"yellow","prevMsg":"Waiting for Elasticsearch"}  
{"type":"log","@timestamp":"2015-12-27T09:44:26+00:00","tags":["status","plugin:markdown\_vis","info"],"pid":2624,"name":"plugin:markdown\_vis","state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}  
{"type":"log","@timestamp":"2015-12-27T09:44:26+00:00","tags":["status","plugin:metric\_vis","info"],"pid":2624,"name":"plugin:metric\_vis","state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}  
{"type":"log","@timestamp":"2015-12-27T09:44:26+00:00","tags":["status","plugin:spyModes","info"],"pid":2624,"name":"plugin:spyModes","state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}  
{"type":"log","@timestamp":"2015-12-27T09:44:26+00:00","tags":["status","plugin:statusPage","info"],"pid":2624,"name":"plugin:statusPage","state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}  
{"type":"log","@timestamp":"2015-12-27T09:44:26+00:00","tags":["status","plugin:table\_vis","info"],"pid":2624,"name":"plugin:table\_vis","state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}  
{"type":"log","@timestamp":"2015-12-27T09:44:26+00:00","tags":["listening","info"],"pid":2624,"message":"Server running at [http://127.0.0.1:5601](http://127.0.0.1:5601)"}  
{"type":"log","@timestamp":"2015-12-27T09:44:29+00:00","tags":["warning","elasticsearch"],"pid":2624,"message":"Unable to revive connection: [http://localhost:9200/](http://localhost:9200/)"}  
{"type":"log","@timestamp":"2015-12-27T09:44:29+00:00","tags":["warning","elasticsearch"],"pid":2624,"message":"No living connections"}  
..  
{"type":"response","@timestamp":"2015-12-27T09:45:43+00:00","tags":[],"pid":2624,"method":"get","statusCode":200,"req":{"url":"/","method":"get","headers":{"host":"localhost:5601","user-agent":"Mozilla/5.0 (Windows NT 5.1; rv:43.0) Gecko/20100101 Firefox/43.0","accept":"text/html,application/xhtml+xml,application/xml;q=0.9,_/_;q=0.8","accept-language":"en-US,en;q=0.5","accept-encoding":"gzip, deflate","connection":"keep-alive"},"remoteAddress":"127.0.0.1","userAgent":"127.0.0.1"},"res":{"statusCode":200,"responseTime":78,"contentLength":9},"message":"GET / 200 78ms - 9.0B"}  
{"type":"log","@timestamp":"2015-12-27T09:45:44+00:00","tags":["warning","elasticsearch"],"pid":2624,"message":"Unable to revive connection: [http://localhost:9200/](http://localhost:9200/)"}  
{"type":"log","@timestamp":"2015-12-27T09:45:44+00:00","tags":["warning","elasticsearch"],"pid":2624,"message":"No living connections"}

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [December 27, 2015, 8:38pm UTC](https://discuss.elastic.co/t/kibana-4-3-1-on-windows-xp-unable-to-connect-to-elasticsearch-at-http-localhost-9200/37997/2 "2015-12-27T20:38:34Z")

</div>

What does `ping localhost` return?

---

<div class="post-metadata">

**Author:** ![swarnkar](https://avatars.discourse-cdn.com/v4/letter/s/f4b2a3/32.png) [@swarnkar](https://discuss.elastic.co/u/swarnkar)\
**Post date:** [December 28, 2015, 4:29pm UTC](https://discuss.elastic.co/t/kibana-4-3-1-on-windows-xp-unable-to-connect-to-elasticsearch-at-http-localhost-9200/37997/3 "2015-12-28T16:29:23Z")

</div>

Here is the output:

C:\Documents and Settings\Swarnkar\>ping localhost

Pinging swarnkarr [127.0.0.1] with 32 bytes of data:

Reply from 127.0.0.1: bytes=32 time\<1ms TTL=64  
Reply from 127.0.0.1: bytes=32 time\<1ms TTL=64  
Reply from 127.0.0.1: bytes=32 time\<1ms TTL=64  
Reply from 127.0.0.1: bytes=32 time\<1ms TTL=64

Ping statistics for 127.0.0.1:  
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),  
Approximate round trip times in milli-seconds:  
Minimum = 0ms, Maximum = 0ms, Average = 0ms

Here swarnkarr is user domain.

Also, I see this when I start kibana.bat

'WHERE' is not recognized as an internal or external command, operable program or batch file.

I tried Commenting bat lines containing WHERE as @KavyaS says [here](https://discuss.elastic.co/t/kibana-showing-where-is-not-an-int-or-ext-command-on-start-up/36544/5).  
No luck.

---

<div class="post-metadata">

**Author:** ![Mark\_van\_der\_Harst](https://avatars.discourse-cdn.com/v4/letter/m/2bfe46/32.png) [@Mark\_van\_der\_Harst](https://discuss.elastic.co/u/Mark_van_der_Harst)\
**Post date:** [January 21, 2016, 3:24pm UTC](https://discuss.elastic.co/t/kibana-4-3-1-on-windows-xp-unable-to-connect-to-elasticsearch-at-http-localhost-9200/37997/4 "2016-01-21T15:24:35Z")

</div>

Hi,

You should bind Elasticsearch to localhost in stead of the ip 127.0.0.1.

Changes made into elasticsearch.yml:  
network.host: localhost  
http.port: 9200

Changes made to kibana.yml:  
elasticsearch.url: "[http://localhost:9200](http://localhost:9200)"  
elasticsearch.ssl.verify: false

Don't use server.host parameter in kibana.yml

---

<div class="post-metadata">

**Author:** ![scvecwf](https://avatars.discourse-cdn.com/v4/letter/s/48db29/32.png) [@scvecwf](https://discuss.elastic.co/u/scvecwf)\
**Post date:** [December 9, 2016, 1:55am UTC](https://discuss.elastic.co/t/kibana-4-3-1-on-windows-xp-unable-to-connect-to-elasticsearch-at-http-localhost-9200/37997/5 "2016-12-09T01:55:46Z")

</div>

System: Windows 8.1  
Kibana:4.6.3  
Elasticsearch:2.4.1

It's a pity that,on my computer,this method doesn't work.

It's strange:  
When I unplug the network cable(and restart Kibana),the error occurs.  
When I plug in the network cable,the error disappears,and everything runs well.

I haven't changed any setting in kibana.yml.  
And I haven't set "network.host" or "http.port" in elasticsearch.yml.

Is it possible to use Kibana without the network cable?

Thank you in advance.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 1:33pm UTC](https://discuss.elastic.co/t/kibana-4-3-1-on-windows-xp-unable-to-connect-to-elasticsearch-at-http-localhost-9200/37997/6 "2017-07-06T13:33:49Z")

</div>


