# Kibana 4.5.1 cannot start because of "permission denied"

**URL:** https://discuss.elastic.co/t/kibana-4-5-1-cannot-start-because-of-permission-denied/50392
**Category:** Kibana
**Created:** [May 19, 2016, 2:42am UTC](https://discuss.elastic.co/t/kibana-4-5-1-cannot-start-because-of-permission-denied/50392 "2016-05-19T02:42:31Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![abcfy2](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/abcfy2/32/453_2.png) [@abcfy2](https://discuss.elastic.co/u/abcfy2)
#### Post date: [May 19, 2016, 2:42am UTC](https://discuss.elastic.co/t/kibana-4-5-1-cannot-start-because-of-permission-denied/50392/1 "2016-05-19T02:42:31Z")

</div>

I install kibana on Ubuntu Server 14.04.4 LTS.

But when I upgrade kibana from 4.5.0 to 4.5.1, it cannot startup any more.

Here is the `/var/log/kibana/kibana.stderr`:

```auto
FATAL { [Error: EACCES: permission denied, open '/opt/kibana/optimize/bundles/kibana.entry.js']
  cause: 
   { [Error: EACCES: permission denied, open '/opt/kibana/optimize/bundles/kibana.entry.js']
     errno: -13,
     code: 'EACCES',
     syscall: 'open',
     path: '/opt/kibana/optimize/bundles/kibana.entry.js' },
  isOperational: true,
  errno: -13,
  code: 'EACCES',
  syscall: 'open',
  path: '/opt/kibana/optimize/bundles/kibana.entry.js' }
FATAL { [Error: EACCES: permission denied, open '/opt/kibana/optimize/bundles/kibana.entry.js']
  cause: 
   { [Error: EACCES: permission denied, open '/opt/kibana/optimize/bundles/kibana.entry.js']
     errno: -13,
     code: 'EACCES',
     syscall: 'open',
     path: '/opt/kibana/optimize/bundles/kibana.entry.js' },
  isOperational: true,
  errno: -13,
  code: 'EACCES',
  syscall: 'open',
  path: '/opt/kibana/optimize/bundles/kibana.entry.js' }

```

I've tried to use `apt-get purge kibana` to uninstall kibana, and use `apt-get install kibana` to install it agent.

---

<div class="post-metadata">

### Author: ![abcfy2](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/abcfy2/32/453_2.png) [@abcfy2](https://discuss.elastic.co/u/abcfy2)
#### Post date: [May 19, 2016, 3:18am UTC](https://discuss.elastic.co/t/kibana-4-5-1-cannot-start-because-of-permission-denied/50392/2 "2016-05-19T03:18:47Z")

</div>

I've downgraded to `4.5.0` by using `apt-get install kibana=4.5.0`. It works well for me.

Hope this issue will be fixed.

---

<div class="post-metadata">

### Author: ![abcfy2](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/abcfy2/32/453_2.png) [@abcfy2](https://discuss.elastic.co/u/abcfy2)
#### Post date: [May 19, 2016, 3:29am UTC](https://discuss.elastic.co/t/kibana-4-5-1-cannot-start-because-of-permission-denied/50392/3 "2016-05-19T03:29:58Z")

</div>

I've fixed by myself.

Just use `chmod -R kibana:kibana /opt/kibana/optimize/`.

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [May 19, 2016, 1:06pm UTC](https://discuss.elastic.co/t/kibana-4-5-1-cannot-start-because-of-permission-denied/50392/4 "2016-05-19T13:06:28Z")

</div>

There's an existing issue on GH for this - [https://github.com/elastic/kibana/issues/6730](https://github.com/elastic/kibana/issues/6730)

---

<div class="post-metadata">

### Author: ![abcfy2](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/abcfy2/32/453_2.png) [@abcfy2](https://discuss.elastic.co/u/abcfy2)
#### Post date: [May 19, 2016, 1:31pm UTC](https://discuss.elastic.co/t/kibana-4-5-1-cannot-start-because-of-permission-denied/50392/5 "2016-05-19T13:31:02Z")

</div>

That's right, same issue. I've compared the packages between `4.5.0` and `4.5.1`. I find that `4.5.0` deb package does not contain `config/kibana.yml` and `optimize/bundles/`. Kibana `4.5.0` will automate create these files and dirs at first startup.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 1:52pm UTC](https://discuss.elastic.co/t/kibana-4-5-1-cannot-start-because-of-permission-denied/50392/6 "2017-07-06T13:52:54Z")

</div>


