# Kibana 4.5 startup error

**URL:** https://discuss.elastic.co/t/kibana-4-5-startup-error/45858
**Category:** Kibana
**Created:** [March 30, 2016, 11:35pm UTC](https://discuss.elastic.co/t/kibana-4-5-startup-error/45858 "2016-03-30T23:35:58Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![krishnamohanpkm](https://avatars.discourse-cdn.com/v4/letter/k/e9a140/32.png) [@krishnamohanpkm](https://discuss.elastic.co/u/krishnamohanpkm)
#### Post date: [March 30, 2016, 11:35pm UTC](https://discuss.elastic.co/t/kibana-4-5-startup-error/45858/1 "2016-03-30T23:35:58Z")

</div>

I installed Kibana 4.5. When i start it it is not picking up the ip address i specified in kibana.yml file.  
It is trying to connect to 0.0.0.1.

[root@ip-10-136-88-228 kibana]# bin/kibana  
log [23:35:19.266] [info][status][plugin:kibana] Status changed from uninitialized to green - Ready  
log [23:35:19.306] [info][status][plugin:elasticsearch] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
log [23:35:19.328] [info][status][plugin:graph] Status changed from uninitialized to green - Ready  
log [23:35:19.335] [error][elasticsearch] Request error, retrying -- connect ECONNREFUSED 127.0.0.1:9200  
log [23:35:19.348] [info][status][plugin:kbn\_vislib\_vis\_types] Status changed from uninitialized to green - Ready  
log [23:35:19.353] [info][status][plugin:markdown\_vis] Status changed from uninitialized to green - Ready  
log [23:35:19.357] [warning][elasticsearch] Unable to revive connection: [http://localhost:9200/](http://localhost:9200/)  
log [23:35:19.358] [warning][elasticsearch] No living connections  
log [23:35:19.361] [error][status][plugin:elasticsearch] Status changed from yellow to red - Unable to connect to Elasticsearch at [http://localhost:9200](http://localhost:9200).  
log [23:35:19.362] [info][status][plugin:metric\_vis] Status changed from uninitialized to green - Ready  
log [23:35:19.366] [info][status][plugin:spyModes] Status changed from uninitialized to green - Ready  
log [23:35:19.370] [info][status][plugin:statusPage] Status changed from uninitialized to green - Ready  
log [23:35:19.373] [info][status][plugin:table\_vis] Status changed from uninitialized to green - Ready  
log [23:35:19.380] [info][listening] Server running at [http://0.0.0.0:5601](http://0.0.0.0:5601)  
log [23:35:21.867] [warning][elasticsearch] Unable to revive connection: [http://localhost:9200/](http://localhost:9200/)  
log [23:35:21.871] [warning][elasticsearch] No living connections  
log [23:35:24.375] [warning][elasticsearch] Unable to revive connection: [http://localhost:9200/](http://localhost:9200/)  
log [23:35:24.376] [warning][elasticsearch] No living connections  
log [23:35:26.881] [warning][elasticsearch] Unable to revive connection: [http://localhost:9200/](http://localhost:9200/)  
log [23:35:26.881] [warning][elasticsearch] No living connections  
log [23:35:29.384] [warning][elasticsearch] Unable to revive connection: [http://localhost:9200/](http://localhost:9200/)  
log [23:35:29.385] [warning][elasticsearch] No living connections  
log [23:35:31.890] [warning][elasticsearch] Unable to revive connection: [http://localhost:9200/](http://localhost:9200/)  
log [23:35:31.891] [warning][elasticsearch] No living connections

# /var/log/kibana/kibana.stderr

fs.js:549  
return binding.open(pathModule.\_makeLong(path), stringToFlags(flags), mode);  
^

Error: EACCES: permission denied, open '/opt/kibana/optimize/.babelcache.json'  
at Error (native)  
at Object.fs.openSync (fs.js:549:18)  
at Object.fs.writeFileSync (fs.js:1156:15)  
at save (/opt/kibana/node\_modules/babel-core/lib/api/register/cache.js:35:19)  
at nextTickCallbackWith0Args (node.js:415:9)  
at process.\_tickDomainCallback (node.js:385:13)  
at Function.Module.runMain (module.js:443:11)  
at startup (node.js:134:18)  
at node.js:962:3  
~

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [March 31, 2016, 1:51am UTC](https://discuss.elastic.co/t/kibana-4-5-startup-error/45858/2 "2016-03-31T01:51:59Z")

</div>

> [@krishnamohanpkm](#):
>
> Error: EACCES: permission denied, open '/opt/kibana/optimize/.babelcache.json'

That's why, check the ownership of that file.

---

<div class="post-metadata">

### Author: ![krishnamohanpkm](https://avatars.discourse-cdn.com/v4/letter/k/e9a140/32.png) [@krishnamohanpkm](https://discuss.elastic.co/u/krishnamohanpkm)
#### Post date: [March 31, 2016, 4:24pm UTC](https://discuss.elastic.co/t/kibana-4-5-startup-error/45858/3 "2016-03-31T16:24:57Z")

</div>

Thanks it worked now. my bad. I didn't un-comment the server.host configuration line. Kibana is pickingup the ip from kibana.yml

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 1:57pm UTC](https://discuss.elastic.co/t/kibana-4-5-startup-error/45858/4 "2017-07-06T13:57:15Z")

</div>


