# Kibana 4.5 status red: unable to connect to elasticsearch

**URL:** https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523
**Category:** Elasticsearch
**Created:** [May 20, 2016, 6:44am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523 "2016-05-20T06:44:15Z")
**Posts on this page:** 20
**Page:** 1

<div class="post-metadata">

### Author: ![sarbjeet](https://avatars.discourse-cdn.com/v4/letter/s/e5b9ba/32.png) [@sarbjeet](https://discuss.elastic.co/u/sarbjeet)
#### Post date: [May 20, 2016, 6:44am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/1 "2016-05-20T06:44:15Z")

</div>

hi... i installed ELK and it works properly but now i upgrade kibana from 4.1 to 4.5 and elasticsearch 1.2 to 2.3 .error is occured  
 ![](https://us1.discourse-cdn.com/elastic/original/2X/9/9a20e791dfe9b3555c23e4ef16053ce87a176b34.jpg)

---

<div class="post-metadata">

### Author: ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)
#### Post date: [May 22, 2016, 2:12pm UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/2 "2016-05-22T14:12:43Z")

</div>

Well, is ES actually running? Can you connect to it from the machine Kibana runs on?

---

<div class="post-metadata">

### Author: ![sarbjeet](https://avatars.discourse-cdn.com/v4/letter/s/e5b9ba/32.png) [@sarbjeet](https://discuss.elastic.co/u/sarbjeet)
#### Post date: [May 23, 2016, 4:08am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/3 "2016-05-23T04:08:36Z")

</div>

i worked on single machine means elasticsearch install locally.

---

<div class="post-metadata">

### Author: ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)
#### Post date: [May 23, 2016, 4:14am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/4 "2016-05-23T04:14:05Z")

</div>

Okay, but that doesn't answer my questions. Is ES actually running? Can you connect to it from the machine Kibana runs on?

---

<div class="post-metadata">

### Author: ![sarbjeet](https://avatars.discourse-cdn.com/v4/letter/s/e5b9ba/32.png) [@sarbjeet](https://discuss.elastic.co/u/sarbjeet)
#### Post date: [May 23, 2016, 4:17am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/5 "2016-05-23T04:17:32Z")

</div>

yes . ES is running .  
when i run  
service ES restart.  
its work properly but when i run on terminal .  
for eg:-root@sab-VirtualBox:/usr/share/elasticsearch/bin# ./elasticsearch  
output is :-  
Exception in thread "main" ElasticsearchException[Failed to load logging configuration]; nested: NoSuchFileException[/usr/share/elasticsearch/config];  
Likely root cause: java.nio.file.NoSuchFileException: /usr/share/elasticsearch/config  
at sun.nio.fs.UnixException.translateToIOException(UnixException.java:86)  
at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:102)  
at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:107)  
at sun.nio.fs.UnixFileAttributeViews$Basic.readAttributes(UnixFileAttributeViews.java:55)  
at sun.nio.fs.UnixFileSystemProvider.readAttributes(UnixFileSystemProvider.java:144)  
at sun.nio.fs.LinuxFileSystemProvider.readAttributes(LinuxFileSystemProvider.java:99)  
at java.nio.file.Files.readAttributes(Files.java:1737)  
at java.nio.file.FileTreeWalker.getAttributes(FileTreeWalker.java:225)  
at java.nio.file.FileTreeWalker.visit(FileTreeWalker.java:276)  
at java.nio.file.FileTreeWalker.walk(FileTreeWalker.java:322)  
at java.nio.file.Files.walkFileTree(Files.java:2662)  
at org.elasticsearch.common.logging.log4j.LogConfigurator.resolveConfig(LogConfigurator.java:142)  
at org.elasticsearch.common.logging.log4j.LogConfigurator.configure(LogConfigurator.java:103)  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:243)  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:35)  
Refer to the log for complete error details.  
root@sab-VirtualBox:/usr/share/elasticsearch/bin# ^C  
root@sab-VirtualBox:/usr/share/elasticsearch/bin#

---

<div class="post-metadata">

### Author: ![sarbjeet](https://avatars.discourse-cdn.com/v4/letter/s/e5b9ba/32.png) [@sarbjeet](https://discuss.elastic.co/u/sarbjeet)
#### Post date: [May 23, 2016, 4:18am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/6 "2016-05-23T04:18:54Z")

</div>

when i open in browswer:-  
[http://localhost:9200/](http://localhost:9200/)  
output is:-  
Unable to connect

Firefox can't establish a connection to the server at localhost:9200.

```
The site could be temporarily unavailable or too busy. Try again in a few moments.
If you are unable to load any pages, check your computer's network connection.
If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.
```

---

<div class="post-metadata">

### Author: ![sarbjeet](https://avatars.discourse-cdn.com/v4/letter/s/e5b9ba/32.png) [@sarbjeet](https://discuss.elastic.co/u/sarbjeet)
#### Post date: [May 23, 2016, 4:42am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/7 "2016-05-23T04:42:04Z")

</div>

when i create config file inn logstash the out put is:-

root@sab-VirtualBox:/etc/logstash/conf.d# /opt/logstash/bin/logstash -e 'input { stdin { } } output { elasticsearch { hosts =\> localhost } }'  
hi how r u?  
Settings: Default pipeline workers: 1  
Connection refused {:class=\>"Manticore::SocketException", :level=\>:error}  
Logstash startup completed  
Attempted to send a bulk request to Elasticsearch configured at '["[http://localhost:9200/](http://localhost:9200/)"]', but Elasticsearch appears to be unreachable or down! {:error\_message=\>"Connection refused", :class=\>"Manticore::SocketException", :client\_config=\>{:hosts=\>["[http://localhost:9200/](http://localhost:9200/)"], :ssl=\>nil, :transport\_options=\>{:socket\_timeout=\>0, :request\_timeout=\>0, :proxy=\>nil, :ssl=\>{}}, :transport\_class=\>Elasticsearch::Transport::Transport::HTTP::Manticore, :logger=\>nil, :tracer=\>nil, :reload\_connections=\>false, :retry\_on\_failure=\>false, :reload\_on\_failure=\>false, :randomize\_hosts=\>false}, :level=\>:error}  
Attempted to send a bulk request to Elasticsearch configured at '["[http://localhost:9200/](http://localhost:9200/)"]', but Elasticsearch appears to be unreachable or down! {:error\_message=\>"Connection refused", :class=\>"Manticore::SocketException", :client\_config=\>{:hosts=\>["[http://localhost:9200/](http://localhost:9200/)"], :ssl=\>nil, :transport\_options=\>{:socket\_timeout=\>0, :request\_timeout=\>0, :proxy=\>nil, :ssl=\>{}}, :transport\_class=\>Elasticsearch::Transport::Transport::HTTP::Manticore, :logger=\>nil, :tracer=\>nil, :reload\_connections=\>false, :retry\_on\_failure=\>false, :reload\_on\_failure=\>false, :randomize\_hosts=\>false}, :level=\>:error}

---

<div class="post-metadata">

### Author: ![sukhada369](https://avatars.discourse-cdn.com/v4/letter/s/ce7236/32.png) [@sukhada369](https://discuss.elastic.co/u/sukhada369)
#### Post date: [May 23, 2016, 5:08am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/8 "2016-05-23T05:08:21Z")

</div>

@sarbjeet your ES isn't working fine. Check the configuration file for same and then try connecting Kibana to it.

---

<div class="post-metadata">

### Author: ![sarbjeet](https://avatars.discourse-cdn.com/v4/letter/s/e5b9ba/32.png) [@sarbjeet](https://discuss.elastic.co/u/sarbjeet)
#### Post date: [May 23, 2016, 5:28am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/9 "2016-05-23T05:28:44Z")

</div>

first i working on older version then it works properly when then i upgrade version from older to latest. then this problem start

---

<div class="post-metadata">

### Author: ![sukhada369](https://avatars.discourse-cdn.com/v4/letter/s/ce7236/32.png) [@sukhada369](https://discuss.elastic.co/u/sukhada369)
#### Post date: [May 23, 2016, 5:32am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/10 "2016-05-23T05:32:02Z")

</div>

Make sure that you shutdown the ES before making any up-gradations. I hope so this might work fine 🙂

---

<div class="post-metadata">

### Author: ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)
#### Post date: [May 23, 2016, 5:33am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/11 "2016-05-23T05:33:07Z")

</div>

> yes . ES is running .  
> when i run  
> service ES restart.  
> its work properly but when i run on terminal .  
> for eg:-root@sab-VirtualBox:/usr/share/elasticsearch/bin# ./elasticsearch  
> output is :-  
> Exception in thread "main" ElasticsearchException[Failed to load logging configuration]; nested: NoSuchFileException[/usr/share/elasticsearch/config];  
> Likely root cause: java.nio.file.NoSuchFileException: /usr/share/elasticsearch/config

Never mind if it works when you run it in a terminal. Focus on getting it working as a service because that's how it's actually going to be running. So `service elasticsearch restart` is successful, yes? Does [http://localhost:9200/](http://localhost:9200/) work then? If not, what's in the Elasticsearch logs in /var/log/elasticsearch?

---

<div class="post-metadata">

### Author: ![sarbjeet](https://avatars.discourse-cdn.com/v4/letter/s/e5b9ba/32.png) [@sarbjeet](https://discuss.elastic.co/u/sarbjeet)
#### Post date: [May 23, 2016, 5:34am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/12 "2016-05-23T05:34:50Z")

</div>

in my ES config file:-  
network.host=localhost.  
ans other lines are commented

---

<div class="post-metadata">

### Author: ![sarbjeet](https://avatars.discourse-cdn.com/v4/letter/s/e5b9ba/32.png) [@sarbjeet](https://discuss.elastic.co/u/sarbjeet)
#### Post date: [May 23, 2016, 5:36am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/13 "2016-05-23T05:36:16Z")

</div>

root@sab-VirtualBox:/var/log/elasticsearch# ls  
elasticsearch\_deprecation.log  
elasticsearch\_index\_indexing\_slowlog.log  
elasticsearch\_index\_search\_slowlog.log  
elasticsearch.log  
elasticsearch.log.2016-04-19  
elasticsearch.log.2016-04-26  
elasticsearch.log.2016-04-27  
elasticsearch.log.2016-04-28  
elasticsearch.log.2016-04-29  
elasticsearch.log.2016-05-03  
elasticsearch.log.2016-05-04  
elasticsearch.log.2016-05-05  
elasticsearch.log.2016-05-06  
elasticsearch.log.2016-05-09  
elasticsearch.log.2016-05-10  
elasticsearch.log.2016-05-11  
elasticsearch.log.2016-05-12  
elasticsearch.log.2016-05-13  
elasticsearch.log.2016-05-14  
elasticsearch.log.2016-05-16  
elasticsearch.log.2016-05-17  
elasticsearch.log.2016-05-18  
elasticsearch.log.2016-05-19  
elasticsearch.log.2016-05-20

---

<div class="post-metadata">

### Author: ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)
#### Post date: [May 23, 2016, 5:39am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/14 "2016-05-23T05:39:21Z")

</div>

Please answer my questions. I will not ask again.

So `service elasticsearch restart` is successful, yes? Does [http://localhost:9200/](http://localhost:9200/) work then?

---

<div class="post-metadata">

### Author: ![sarbjeet](https://avatars.discourse-cdn.com/v4/letter/s/e5b9ba/32.png) [@sarbjeet](https://discuss.elastic.co/u/sarbjeet)
#### Post date: [May 23, 2016, 5:40am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/15 "2016-05-23T05:40:51Z")

</div>

[http://localhost:9200](http://localhost:9200) not working

---

<div class="post-metadata">

### Author: ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)
#### Post date: [May 23, 2016, 5:45am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/16 "2016-05-23T05:45:41Z")

</div>

So is the Elasticsearch process running at all (check with `ps aux | grep elasticsearch`)? If not, check the end of /var/log/elasticsearch/elasticsearch.log for clues.

---

<div class="post-metadata">

### Author: ![sarbjeet](https://avatars.discourse-cdn.com/v4/letter/s/e5b9ba/32.png) [@sarbjeet](https://discuss.elastic.co/u/sarbjeet)
#### Post date: [May 23, 2016, 5:47am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/17 "2016-05-23T05:47:21Z")

</div>

root@sab-VirtualBox:~# ps aux | grep elasticsearch  
root 4291 0.0 0.1 15944 2296 pts/12 S+ 23:46 0:00 grep --color=auto elasticsearch

---

<div class="post-metadata">

### Author: ![sarbjeet](https://avatars.discourse-cdn.com/v4/letter/s/e5b9ba/32.png) [@sarbjeet](https://discuss.elastic.co/u/sarbjeet)
#### Post date: [May 23, 2016, 5:48am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/18 "2016-05-23T05:48:16Z")

</div>

i could not understand its out put as its new for me.please help

---

<div class="post-metadata">

### Author: ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)
#### Post date: [May 23, 2016, 5:58am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/19 "2016-05-23T05:58:34Z")

</div>

Okay, so Elasticsearch is not running. Then please answer my second question.

You are asking very basic questions about how to use and run a Linux system. I want to spend my volunteer time helping people with Elastic-related problems and if this thread continues like this I'm going to bail.

---

<div class="post-metadata">

### Author: ![sukhada369](https://avatars.discourse-cdn.com/v4/letter/s/ce7236/32.png) [@sukhada369](https://discuss.elastic.co/u/sukhada369)
#### Post date: [May 23, 2016, 5:59am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/20 "2016-05-23T05:59:27Z")

</div>

Send the details of the log file. No one would be able to guide you without it

[Next page](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523.md?page=2)
