# Kibana 4.5 status red: unable to connect to elasticsearch

**URL:** https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523
**Category:** Elasticsearch
**Created:** [May 20, 2016, 6:44am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523 "2016-05-20T06:44:15Z")
**Posts on this page:** 20
**Page:** 2

<div class="post-metadata">

### Author: ![sarbjeet](https://avatars.discourse-cdn.com/v4/letter/s/e5b9ba/32.png) [@sarbjeet](https://discuss.elastic.co/u/sarbjeet)
#### Post date: [May 23, 2016, 6:20am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/21 "2016-05-23T06:20:19Z")

</div>

elasticsearch.log file is too long. it contains information regarding indexes that i created before for testing.  
[2016-05-23 22:09:55,984][INFO][node] [No  
cturne] version[2.3.3], pid[1191], build[218bdf1/2016-05-17T15:  
40:04Z]  
[2016-05-23 22:09:55,985][INFO][node] [No  
cturne] initializing ...  
[2016-05-23 22:09:57,898][INFO][plugins] [No  
cturne] modules [reindex, lang-expression, lang-groovy], plugin  
s [], sites []  
[2016-05-23 22:09:58,141][INFO][env] [No  
cturne] using [1] data paths, mounts [[/ (/dev/sda1)]], net usa  
ble\_space [3.3gb], net total\_space [8.7gb], spins? [possibly],  
types [ext4]  
[2016-05-23 22:09:58,141][INFO][env] [No  
cturne] heap size [1015.6mb], compressed ordinary object pointe  
rs [true]  
[2016-05-23 22:09:58,141][WARN][env] [No  
cturne] max file descriptors [65535] for elasticsearch process  
likely too low, consider increasing to at least [65536]  
[2016-05-23 22:10:06,468][ERROR][gateway] [No  
cturne] failed to read local state, exiting...  
java.lang.IllegalStateException: unable to upgrade the mappings  
for the index [data], reason: [Field name [No.] cannot contain  
'.']  
at org.elasticsearch.cluster.metadata.MetaDataIndexUpgr  
adeService.checkMappingsCompatibility(MetaDataIndexUpgradeServi  
ce.java:308)  
at org.elasticsearch.cluster.metadata.MetaDataIndexUpgr  
adeService.upgradeIndexMetaData(MetaDataIndexUpgradeService.jav  
a:116)  
at org.elasticsearch.gateway.GatewayMetaState.pre20Upgr  
ade(GatewayMetaState.java:228)  
at org.elasticsearch.gateway.GatewayMetaState.(Ga  
tewayMetaState.java:87)  
at sun.reflect.NativeConstructorAccessorImpl.newInstanc  
e0(Native Method)  
at sun.reflect.NativeConstructorAccessorImpl.newInstanc  
e(NativeConstructorAccessorImpl.java:62)  
at sun.reflect.DelegatingConstructorAccessorImpl.newIns  
tance(DelegatingConstructorAccessorImpl.java:45)  
at java.lang.reflect.Constructor.newInstance(Constructo  
r.java:423)  
at org.elasticsearch.common.inject.DefaultConstructionP  
roxyFactory$1.newInstance(DefaultConstructionProxyFactory.java:  
50)..............................................................................................................................  
...............................................................................

---

<div class="post-metadata">

### Author: ![sukhada369](https://avatars.discourse-cdn.com/v4/letter/s/ce7236/32.png) [@sukhada369](https://discuss.elastic.co/u/sukhada369)
#### Post date: [May 23, 2016, 6:47am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/22 "2016-05-23T06:47:20Z")

</div>

Try following command and post the output accordingly  
"tailf /var/log/elasticsearch/elasticsearch.log"

---

<div class="post-metadata">

### Author: ![sarbjeet](https://avatars.discourse-cdn.com/v4/letter/s/e5b9ba/32.png) [@sarbjeet](https://discuss.elastic.co/u/sarbjeet)
#### Post date: [May 23, 2016, 6:49am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/23 "2016-05-23T06:49:31Z")

</div>

root@sab-VirtualBox:~# tailf /var/log/elasticsearch/elasticsearch.log  
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)  
at java.lang.reflect.Constructor.newInstance(Constructor.java:423)  
at \<\<\>\>  
at org.elasticsearch.node.Node.(Node.java:213)  
at org.elasticsearch.node.Node.(Node.java:140)  
at org.elasticsearch.node.NodeBuilder.build(NodeBuilder.java:143)  
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:178)  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:270)  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:35)

---

<div class="post-metadata">

### Author: ![sarbjeet](https://avatars.discourse-cdn.com/v4/letter/s/e5b9ba/32.png) [@sarbjeet](https://discuss.elastic.co/u/sarbjeet)
#### Post date: [May 23, 2016, 11:07am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/24 "2016-05-23T11:07:45Z")

</div>

root@sab-VirtualBox:~# service elasticsearch start

- Starting Elasticsearch Server [OK]

root@sab-VirtualBox:~# service elasticsearch status

- elasticsearch is not running

---

<div class="post-metadata">

### Author: ![sarbjeet](https://avatars.discourse-cdn.com/v4/letter/s/e5b9ba/32.png) [@sarbjeet](https://discuss.elastic.co/u/sarbjeet)
#### Post date: [May 24, 2016, 4:44am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/25 "2016-05-24T04:44:37Z")

</div>

Today when i start the system and do work.output is  
root@sab-VirtualBox:~# service elasticsearch status

- elasticsearch is not running  
root@sab-VirtualBox:~# service elasticsearch start
- Starting Elasticsearch Server [OK]  
root@sab-VirtualBox:~# service elasticsearch status
- elasticsearch is running  
root@sab-VirtualBox:~# service elasticsearch status
- elasticsearch is not running  
root@sab-VirtualBox:~# service elasticsearch start
- Starting Elasticsearch Server [OK]  
root@sab-VirtualBox:~# service elasticsearch status
- elasticsearch is running  
root@sab-VirtualBox:~# service elasticsearch status
- elasticsearch is not running

---

<div class="post-metadata">

### Author: ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)
#### Post date: [May 24, 2016, 5:37am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/26 "2016-05-24T05:37:33Z")

</div>

> [2016-05-23 22:10:06,468][ERROR][gateway] [Nocturne] failed to read local state, exiting... java.lang.IllegalStateException: unable to upgrade the mappings for the index [data], reason: [Field name [No.] cannot contain '.']

Is this the last error message in the log? You have an on-disk index named "data" that contains a field with a period in its name. That was okay prior to ES 2.0 but is no longer allowed. You have to reindex that data to rename the field before you can run ES 2.0 or later.

---

<div class="post-metadata">

### Author: ![sarbjeet](https://avatars.discourse-cdn.com/v4/letter/s/e5b9ba/32.png) [@sarbjeet](https://discuss.elastic.co/u/sarbjeet)
#### Post date: [May 24, 2016, 5:40am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/27 "2016-05-24T05:40:45Z")

</div>

ok  
but when i run on terminal. for eg:-  
root@sab-VirtualBox:~# /opt/logstash/bin/logstash -e 'input { stdin { } } output { elasticsearch {hosts =\>'localhost' } }'  
hi. how r u  
Settings: Default pipeline workers: 1  
Connection refused {:class=\>"Manticore::SocketException", :level=\>:error}  
Logstash startup completed  
Attempted to send a bulk request to Elasticsearch configured at '["[http://localhost:9200/](http://localhost:9200/)"]', but Elasticsearch appears to be unreachable or down! {:error\_message=\>"Connection refused", :class=\>"Manticore::SocketException", :client\_config=\>{:hosts=\>["[http://localhost:9200/](http://localhost:9200/)"], :ssl=\>nil, :transport\_options=\>{:socket\_timeout=\>0, :request\_time

---

<div class="post-metadata">

### Author: ![sarbjeet](https://avatars.discourse-cdn.com/v4/letter/s/e5b9ba/32.png) [@sarbjeet](https://discuss.elastic.co/u/sarbjeet)
#### Post date: [May 24, 2016, 5:41am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/28 "2016-05-24T05:41:43Z")

</div>

yes its last error message.

---

<div class="post-metadata">

### Author: ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)
#### Post date: [May 24, 2016, 5:44am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/29 "2016-05-24T05:44:15Z")

</div>

But if ES isn't starting up properly, why would you think Logstash would be able to connect to it?

Downgrade ES, reindex the "data" index to rename all fields with periods in their name, run the migration plugin to find any other incompatibilities, then retry the upgrade.

---

<div class="post-metadata">

### Author: ![sarbjeet](https://avatars.discourse-cdn.com/v4/letter/s/e5b9ba/32.png) [@sarbjeet](https://discuss.elastic.co/u/sarbjeet)
#### Post date: [May 24, 2016, 5:45am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/30 "2016-05-24T05:45:04Z")

</div>

ok.thanks.i try.

---

<div class="post-metadata">

### Author: ![sarbjeet](https://avatars.discourse-cdn.com/v4/letter/s/e5b9ba/32.png) [@sarbjeet](https://discuss.elastic.co/u/sarbjeet)
#### Post date: [May 25, 2016, 5:18am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/31 "2016-05-25T05:18:58Z")

</div>

Is there any document regarding migration plugin?please refer.

---

<div class="post-metadata">

### Author: ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)
#### Post date: [May 25, 2016, 5:26am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/32 "2016-05-25T05:26:21Z")

</div>

For me, googling "elasticsearch migration plugin" has this as the first hit: [https://github.com/elastic/elasticsearch-migration](https://github.com/elastic/elasticsearch-migration)

---

<div class="post-metadata">

### Author: ![sarbjeet](https://avatars.discourse-cdn.com/v4/letter/s/e5b9ba/32.png) [@sarbjeet](https://discuss.elastic.co/u/sarbjeet)
#### Post date: [May 25, 2016, 5:43am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/33 "2016-05-25T05:43:11Z")

</div>

thanks. nw i installed migration plugin and check it.  
when i run in browser the message is

All checks completed successfully.  
Elasticsearch version: 1.7.5

---

<div class="post-metadata">

### Author: ![sarbjeet](https://avatars.discourse-cdn.com/v4/letter/s/e5b9ba/32.png) [@sarbjeet](https://discuss.elastic.co/u/sarbjeet)
#### Post date: [May 25, 2016, 5:45am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/34 "2016-05-25T05:45:54Z")

</div>

can i upgrade ES 2.3 version?

i install ELK by Deb .  
can i use same procedure?

---

<div class="post-metadata">

### Author: ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)
#### Post date: [May 25, 2016, 5:49am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/35 "2016-05-25T05:49:16Z")

</div>

Yes, an upgrade should be as simple as upgrading the Debian package and restarting ES (I don't think the init script does that for you).

---

<div class="post-metadata">

### Author: ![sarbjeet](https://avatars.discourse-cdn.com/v4/letter/s/e5b9ba/32.png) [@sarbjeet](https://discuss.elastic.co/u/sarbjeet)
#### Post date: [May 25, 2016, 6:49am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/36 "2016-05-25T06:49:16Z")

</div>

after upgrade there is error in elasticsearch log file regarding migration plugin.  
should i again install migration plugin for upgrade version?

java.lang.IllegalStateException: Could not load plugin descriptor for existing plugin [migration]. Was the plugin built before 2.0?

---

<div class="post-metadata">

### Author: ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)
#### Post date: [May 25, 2016, 7:14am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/37 "2016-05-25T07:14:53Z")

</div>

You can uninstall the migration plugin after the upgrade.

---

<div class="post-metadata">

### Author: ![sarbjeet](https://avatars.discourse-cdn.com/v4/letter/s/e5b9ba/32.png) [@sarbjeet](https://discuss.elastic.co/u/sarbjeet)
#### Post date: [May 25, 2016, 7:18am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/38 "2016-05-25T07:18:30Z")

</div>

ok.  
thanks

---

<div class="post-metadata">

### Author: ![sarbjeet](https://avatars.discourse-cdn.com/v4/letter/s/e5b9ba/32.png) [@sarbjeet](https://discuss.elastic.co/u/sarbjeet)
#### Post date: [May 25, 2016, 8:52am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/39 "2016-05-25T08:52:22Z")

</div>

i remove migration plugin but there is another error in elasticsearch log file that is:-  
java.lang.IllegalStateException: unable to upgrade the mappings for the index [bad], reason: [No handler for type [murmur3] declared on field [foo]]

what should i do?

---

<div class="post-metadata">

### Author: ![sarbjeet](https://avatars.discourse-cdn.com/v4/letter/s/e5b9ba/32.png) [@sarbjeet](https://discuss.elastic.co/u/sarbjeet)
#### Post date: [May 25, 2016, 9:24am UTC](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523/40 "2016-05-25T09:24:25Z")

</div>

Thanks for ur support. i install mapping plugin and elasticsearch work.

[Previous page](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523.md?page=1)

[Next page](https://discuss.elastic.co/t/kibana-4-5-status-red-unable-to-connect-to-elasticsearch/50523.md?page=3)
