# Kibana 5.2 +x-pack error when generating reports

**URL:** <https://discuss.elastic.co/t/kibana-5-2-x-pack-error-when-generating-reports/72039>\
**Category:** Kibana\
**Created:** [January 18, 2017, 3:44pm UTC](https://discuss.elastic.co/t/kibana-5-2-x-pack-error-when-generating-reports/72039 "2017-01-18T15:44:42Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![kioie](https://avatars.discourse-cdn.com/v4/letter/k/c77e96/32.png) [@kioie](https://discuss.elastic.co/u/kioie)\
**Post date:** [January 18, 2017, 3:44pm UTC](https://discuss.elastic.co/t/kibana-5-2-x-pack-error-when-generating-reports/72039/1 "2017-01-18T15:44:43Z")

</div>

X-Pack throws the following error when I try to generate a report.

Any ideas why?

Am running on ES and Kibana5.2

 ![](https://us1.discourse-cdn.com/elastic/original/2X/b/b3c35c6d143d14422a66099f9ba6ff4dbcac87f7.png)

---

<div class="post-metadata">

**Author:** ![JKhondhu](https://avatars.discourse-cdn.com/v4/letter/j/ed655f/32.png) [@JKhondhu](https://discuss.elastic.co/u/JKhondhu)\
**Post date:** [January 19, 2017, 10:41am UTC](https://discuss.elastic.co/t/kibana-5-2-x-pack-error-when-generating-reports/72039/2 "2017-01-19T10:41:43Z")

</div>

Hi,  
I believe the error speaks for itself that the report query took longer than the allottede timeout period.

How large was the report query itself? ES & K 5.1.2? In the interim, I can repro and come back to you with any of my findings.

---

<div class="post-metadata">

**Author:** ![kioie](https://avatars.discourse-cdn.com/v4/letter/k/c77e96/32.png) [@kioie](https://discuss.elastic.co/u/kioie)\
**Post date:** [January 19, 2017, 10:45am UTC](https://discuss.elastic.co/t/kibana-5-2-x-pack-error-when-generating-reports/72039/3 "2017-01-19T10:45:21Z")

</div>

the report is not as large, I was doing a one pager report of the dashboards that i've created.

---

<div class="post-metadata">

**Author:** ![Brandon\_Kobel](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/brandon_kobel/32/14829_2.png) [@Brandon\_Kobel](https://discuss.elastic.co/u/Brandon_Kobel)\
**Post date:** [January 23, 2017, 9:28pm UTC](https://discuss.elastic.co/t/kibana-5-2-x-pack-error-when-generating-reports/72039/4 "2017-01-23T21:28:15Z")

</div>

@kioie are you running Kibana behind a reverse proxy (nginx/apache/haproxy)?

---

<div class="post-metadata">

**Author:** ![kioie](https://avatars.discourse-cdn.com/v4/letter/k/c77e96/32.png) [@kioie](https://discuss.elastic.co/u/kioie)\
**Post date:** [January 24, 2017, 7:02am UTC](https://discuss.elastic.co/t/kibana-5-2-x-pack-error-when-generating-reports/72039/5 "2017-01-24T07:02:48Z")

</div>

@Brandon_Kobel no its not behind a proxy, am currently on a dev environment

---

<div class="post-metadata">

**Author:** ![JKhondhu](https://avatars.discourse-cdn.com/v4/letter/j/ed655f/32.png) [@JKhondhu](https://discuss.elastic.co/u/JKhondhu)\
**Post date:** [January 24, 2017, 9:10am UTC](https://discuss.elastic.co/t/kibana-5-2-x-pack-error-when-generating-reports/72039/6 "2017-01-24T09:10:47Z")

</div>

> [@kioie](#):
>
> ES and Kibana5.2

Is this 5.1.2 or 5.2.x?

---

<div class="post-metadata">

**Author:** ![kioie](https://avatars.discourse-cdn.com/v4/letter/k/c77e96/32.png) [@kioie](https://discuss.elastic.co/u/kioie)\
**Post date:** [January 24, 2017, 10:48am UTC](https://discuss.elastic.co/t/kibana-5-2-x-pack-error-when-generating-reports/72039/7 "2017-01-24T10:48:13Z")

</div>

@JKhondhu its 5.1.2

---

<div class="post-metadata">

**Author:** ![JKhondhu](https://avatars.discourse-cdn.com/v4/letter/j/ed655f/32.png) [@JKhondhu](https://discuss.elastic.co/u/JKhondhu)\
**Post date:** [January 24, 2017, 11:59am UTC](https://discuss.elastic.co/t/kibana-5-2-x-pack-error-when-generating-reports/72039/8 "2017-01-24T11:59:44Z")

</div>

@kioie Can you explain the exact steps you took from visualisation to dashboard to then arrive at this timeout error.

---

<div class="post-metadata">

**Author:** ![Brandon\_Kobel](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/brandon_kobel/32/14829_2.png) [@Brandon\_Kobel](https://discuss.elastic.co/u/Brandon_Kobel)\
**Post date:** [January 24, 2017, 1:23pm UTC](https://discuss.elastic.co/t/kibana-5-2-x-pack-error-when-generating-reports/72039/9 "2017-01-24T13:23:24Z")

</div>

@kioie When you specify the '--dev' flag for Kibana, it dynamically puts it behind what we refer to as a Base Path Proxy. This requires you set the following setting `xpack.reporting.kibanaServer.port: 5601` for reporting to work correctly

You could also disable the Base Path Proxy with the following flag `--no-base-path`

---

<div class="post-metadata">

**Author:** ![kioie](https://avatars.discourse-cdn.com/v4/letter/k/c77e96/32.png) [@kioie](https://discuss.elastic.co/u/kioie)\
**Post date:** [January 24, 2017, 1:30pm UTC](https://discuss.elastic.co/t/kibana-5-2-x-pack-error-when-generating-reports/72039/10 "2017-01-24T13:30:18Z")

</div>

@Brandon_Kobel I already have xpack.reporting.kibanaServer.port: 5601 on my kibana.yml. No change yet....is it necessry to add it to elasticsearch.yml file as well?

I had included these lines on my kibana.yml

![](https://us1.discourse-cdn.com/elastic/original/2X/0/0f5362ae5d2a42804771915298f81dff4eb11f05.png)

---

<div class="post-metadata">

**Author:** ![Brandon\_Kobel](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/brandon_kobel/32/14829_2.png) [@Brandon\_Kobel](https://discuss.elastic.co/u/Brandon_Kobel)\
**Post date:** [January 24, 2017, 1:46pm UTC](https://discuss.elastic.co/t/kibana-5-2-x-pack-error-when-generating-reports/72039/11 "2017-01-24T13:46:41Z")

</div>

@kioie it shouldn't be required in your elasticsearch.yml. Are you also setting `server.host: 192.168.1.237` in your kibana.yml?

---

<div class="post-metadata">

**Author:** ![kioie](https://avatars.discourse-cdn.com/v4/letter/k/c77e96/32.png) [@kioie](https://discuss.elastic.co/u/kioie)\
**Post date:** [January 24, 2017, 1:47pm UTC](https://discuss.elastic.co/t/kibana-5-2-x-pack-error-when-generating-reports/72039/12 "2017-01-24T13:47:31Z")

</div>

@JKhondhu I created a dashboard, saved it, then went to the reporting tab on management to try and download the saved report....hence the error

---

<div class="post-metadata">

**Author:** ![kioie](https://avatars.discourse-cdn.com/v4/letter/k/c77e96/32.png) [@kioie](https://discuss.elastic.co/u/kioie)\
**Post date:** [January 24, 2017, 1:48pm UTC](https://discuss.elastic.co/t/kibana-5-2-x-pack-error-when-generating-reports/72039/14 "2017-01-24T13:48:50Z")

</div>

@Brandon_Kobel yes I am

---

<div class="post-metadata">

**Author:** ![Brandon\_Kobel](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/brandon_kobel/32/14829_2.png) [@Brandon\_Kobel](https://discuss.elastic.co/u/Brandon_Kobel)\
**Post date:** [January 24, 2017, 1:51pm UTC](https://discuss.elastic.co/t/kibana-5-2-x-pack-error-when-generating-reports/72039/15 "2017-01-24T13:51:00Z")

</div>

If you set `logging.events.log: ['reporting']` as well in your kibana.yml, it'll show you the URL that reporting is using to generate the report. Would you mind trying to visit the URL that it prints to the logs to make sure it's available from your machine?

---

<div class="post-metadata">

**Author:** ![kioie](https://avatars.discourse-cdn.com/v4/letter/k/c77e96/32.png) [@kioie](https://discuss.elastic.co/u/kioie)\
**Post date:** [January 24, 2017, 1:57pm UTC](https://discuss.elastic.co/t/kibana-5-2-x-pack-error-when-generating-reports/72039/16 "2017-01-24T13:57:04Z")

</div>

are you talking about this url?

 ![](https://us1.discourse-cdn.com/elastic/original/2X/f/f1278ff6618f55858bb5f7b0899f21fbe27f8295.png)

if so, the url gives me the following error  
 ![](https://us1.discourse-cdn.com/elastic/original/2X/b/b0b20e650572c90843da2e32293bf1f812dab9bb.png)

am I looking at the right thing?

---

<div class="post-metadata">

**Author:** ![Brandon\_Kobel](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/brandon_kobel/32/14829_2.png) [@Brandon\_Kobel](https://discuss.elastic.co/u/Brandon_Kobel)\
**Post date:** [January 24, 2017, 2:04pm UTC](https://discuss.elastic.co/t/kibana-5-2-x-pack-error-when-generating-reports/72039/17 "2017-01-24T14:04:08Z")

</div>

Sorry, I was unclear earlier. When you set `logging.events.log: ['reporting']` you should have more detailed logs regarding reporting in your kibana logs. So, if you're running kibana via `./bin/kibana --dev` or `npm run start` then your terminal should have something like the following printed:

```auto
server log [14:02:49.251] [debug][reporting] fetching screenshot of https://localhost:5601/rjo/app/kibana#/visualize/edit/Apache-HTTPD-Load1-slash-5-slash-15?_g=()&_a=(filters:!(),linked:!t,query:(query_string:(query:'*')),uiState:(),vis:(aggs:!((enabled:!t,id:'1',params:(customLabel:'Load%205',field:apache.status.load.5),schema:metric,type:avg),(enabled:!t,id:'2',params:(customInterval:'2h',extended_bounds:(),field:'@timestamp',interval:auto,min_doc_count:1),schema:segment,type:date_histogram),(enabled:!t,id:'3',params:(customLabel:'Load%201',field:apache.status.load.1),schema:metric,type:avg),(enabled:!t,id:'4',params:(customLabel:'Load%2015',field:apache.status.load.15),schema:metric,type:avg),(enabled:!t,id:'5',params:(customLabel:Hostname,field:apache.status.hostname,order:desc,orderBy:'1',row:!t,size:5),schema:split,type:terms)),listeners:(),params:(addLegend:!t,addTimeMarker:!f,addTooltip:!t,defaultYExtents:!f,drawLinesBetweenPoints:!t,interpolate:linear,legendPosition:right,radiusRatio:9,scale:linear,setYExtents:!f,shareYAxis:!t,showCircles:!t,smoothLines:!f,times:!(),yAxis:()),title:'Apache%20HTTPD%20-%20Load1%2F5%2F15',type:line))

```

If you copy/paste that URL into your browser, do you see the visualization you were anticipating?

---

<div class="post-metadata">

**Author:** ![kioie](https://avatars.discourse-cdn.com/v4/letter/k/c77e96/32.png) [@kioie](https://discuss.elastic.co/u/kioie)\
**Post date:** [January 24, 2017, 2:14pm UTC](https://discuss.elastic.co/t/kibana-5-2-x-pack-error-when-generating-reports/72039/18 "2017-01-24T14:14:13Z")

</div>

@Brandon_Kobel so this is what I am getting  
 ![](https://us1.discourse-cdn.com/elastic/original/2X/a/a15fdd0ba1cecf19531a14c04b275ce2ebef0c80.png)

Not entirely sure who **192.168.1.93** is coz my own laptop is on **192.168.1.11**

---

<div class="post-metadata">

**Author:** ![Brandon\_Kobel](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/brandon_kobel/32/14829_2.png) [@Brandon\_Kobel](https://discuss.elastic.co/u/Brandon_Kobel)\
**Post date:** [January 24, 2017, 2:19pm UTC](https://discuss.elastic.co/t/kibana-5-2-x-pack-error-when-generating-reports/72039/19 "2017-01-24T14:19:00Z")

</div>

@kioie that's not the log message that we're looking for, please look at the example message that I posted above.

---

<div class="post-metadata">

**Author:** ![kioie](https://avatars.discourse-cdn.com/v4/letter/k/c77e96/32.png) [@kioie](https://discuss.elastic.co/u/kioie)\
**Post date:** [January 24, 2017, 2:24pm UTC](https://discuss.elastic.co/t/kibana-5-2-x-pack-error-when-generating-reports/72039/20 "2017-01-24T14:24:09Z")

</div>

am not running kibana on dev mode, am currently running it as a service i.e service kibana ...

I tried to run the command you have above and this is the error I got ![](https://us1.discourse-cdn.com/elastic/original/2X/d/d3e4cd4f2efa72f3ebdac4bbd0f6c77b3ca6357e.png)

---

<div class="post-metadata">

**Author:** ![Brandon\_Kobel](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/brandon_kobel/32/14829_2.png) [@Brandon\_Kobel](https://discuss.elastic.co/u/Brandon_Kobel)\
**Post date:** [January 24, 2017, 2:43pm UTC](https://discuss.elastic.co/t/kibana-5-2-x-pack-error-when-generating-reports/72039/21 "2017-01-24T14:43:29Z")

</div>

My apologies, I misread earlier and thought you were running locally in dev-mode please ignore the part about running those commands and looking at the terminal output. Have you set the 'logging.dest' setting to a file already? That's where the logs will be located. Also, you'll have to restart kibana after changing the kibana.yml to get it to see the changes.

[Next page](https://discuss.elastic.co/t/kibana-5-2-x-pack-error-when-generating-reports/72039.md?page=2)
