# Kibana 500 - huge index patterns

**URL:** <https://discuss.elastic.co/t/kibana-500-huge-index-patterns/127995>\
**Category:** Kibana\
**Created:** [April 13, 2018, 2:04pm UTC](https://discuss.elastic.co/t/kibana-500-huge-index-patterns/127995 "2018-04-13T14:04:12Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![tivvit](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tivvit/32/24685_2.png) [@tivvit](https://discuss.elastic.co/u/tivvit)\
**Post date:** [April 13, 2018, 2:04pm UTC](https://discuss.elastic.co/t/kibana-500-huge-index-patterns/127995/1 "2018-04-13T14:04:12Z")

</div>

Hi,

I have the following problem in Kibana 6.1.2

 ![Screenshot%20from%202018-04-13%2015-44-28](https://us1.discourse-cdn.com/elastic/original/3X/d/1/d1f78fa5f75e72f7f6db219095bb933c358bcc0b.png)

The problem occurs when creating or trying to open index pattern.

It only occurs in one particular pattern. This pattern contains over 500 fields and is nested a lot (over 2k fields in total). The pattern cannot be viewed / edited / deleted.

My theories are:

- The pattern mapping is just too big
- The pattern matched more than one index type (definitely not true for all the patterns)  
EDIT: it did not

I will probably try deleting the `.kibana` index.  
EDIT: deleting the index did not help

Any ideas how to fix?

---

<div class="post-metadata">

**Author:** ![thomasneirynck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/thomasneirynck/32/23313_2.png) [@thomasneirynck](https://discuss.elastic.co/u/thomasneirynck)\
**Post date:** [April 13, 2018, 6:36pm UTC](https://discuss.elastic.co/t/kibana-500-huge-index-patterns/127995/2 "2018-04-13T18:36:57Z")

</div>

Hmm, not sure.

What do the Kibana server-logs say? Is something erroring out or crashing there?

---

<div class="post-metadata">

**Author:** ![tivvit](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tivvit/32/24685_2.png) [@tivvit](https://discuss.elastic.co/u/tivvit)\
**Post date:** [April 13, 2018, 8:39pm UTC](https://discuss.elastic.co/t/kibana-500-huge-index-patterns/127995/3 "2018-04-13T20:39:54Z")

</div>

Hi i do not have full access to the server but I have this older Kibana log

```auto
{"type":"error","@timestamp":"2018-04-10T17:27:39Z","tags":[],"pid":1,"level":"error","error":{"message":"Internal Server Error","name":"Error","stack":"Internal Server Error :: {\"path\":\"/.kibana/doc/index-pattern%3A69ec8320-328f-11e8-93e3-2df0687de10e/_update\",\"query\":{\"refresh\":\"wait_for\"},\"body\":\"{\\\"doc\\\":{\\\"updated_at\\\":\\\"2018-04-10T17:27:39.263Z\\\",\\\"index-pattern\\\":{\\\"title\\\":\\\"email-probe-day-scanner*\\\",\\\"timeFieldName\\\":\\\"timestamp\\\",\\\"fields\\\":\\\"[{\\\\\\\"name\\\\\\\":\\\\\\\"_id\\\\\\\",\\\\\\\"type\\\\\\\":\\\\\\\"string\\\\\\\",\\\\\\\"count\\\\\\\":0,\\\\\\\"scripted\\\\\\\":false,\\\\\\\"searchable\\\\\\\":true,\\\\\\\"aggregatable\\\\\\\":true,\\\\\\\"readFromDocValues\\\\\\\":false},{\\\\\\\"name\\\\\\\":\\\\\\\"_index\\\\\\\",\\\\\\\"type\\\\\\\":\\\\\\\"string\\\\\\\",\\\\\\\"count\\\\\\\":0,\\\\\\\"scripted\\\\\\\":false,\\\\\\\
.... this goes forerver ;)
ends with this:
\\\"count\\\\\\\":0,\\\\\\\"scripted\\\\\\\":false,\\\\\\\"searchable\\\\\\\":true,\\\\\\\"aggregatable\\\\\\\":true,\\\\\\\"readFromDocValues\\\\\\\":true},{\\\\\\\"name\\\\\\\":\\\\\\\"young_user_many_rcpts\\\\\\\",\\\\\\\"type\\\\\\\":\\\\\\\"number\\\\\\\",\\\\\\\"count\\\\\\\":0,\\\\\\\"scripted\\\\\\\":false,\\\\\\\"searchable\\\\\\\":true,\\\\\\\"aggregatable\\\\\\\":true,\\\\\\\"readFromDocValues\\\\\\\":true}]\\\"}}}\",\"statusCode\":500,\"response\":\"<html>\\r\\n<head><title>500 Internal Server Error</title></head>\\r\\n<body bgcolor=\\\"white\\\">\\r\\n<center><h1>500 Internal Server Error</h1></center>\\r\\n<hr><center>nginx</center>\\r\\n</body>\\r\\n</html>\\r\\n\"}\n at respond (/usr/share/kibana/node_modules/elasticsearch/src/lib/transport.js:295:15)\n at checkRespForFailure (/usr/share/kibana/node_modules/elasticsearch/src/lib/transport.js:254:7)\n at HttpConnector.<anonymous> (/usr/share/kibana/node_modules/elasticsearch/src/lib/connectors/http.js:159:7)\n at IncomingMessage.bound (/usr/share/kibana/node_modules/elasticsearch/node_modules/lodash/dist/lodash.js:729:21)\n at emitNone (events.js:91:20)\n at IncomingMessage.emit (events.js:185:7)\n at endReadableNT (_stream_readable.js:974:12)\n at _combinedTickCallback (internal/process/next_tick.js:80:11)\n at process._tickDomainCallback (internal/process/next_tick.js:128:9)"},"url":{"protocol":null,"slashes":null,"auth":null,"host":null,"port":null,"hostname":null,"hash":null,"search":"","query":{},"pathname":"/api/saved_objects/index-pattern/69ec8320-328f-11e8-93e3-2df0687de10e","path":"/api/saved_objects/index-pattern/69ec8320-328f-11e8-93e3-2df0687de10e","href":"/api/saved_objects/index-pattern/69ec8320-328f-11e8-93e3-2df0687de10e"},"message":"Internal Server Error"}

```

---

<div class="post-metadata">

**Author:** ![v1dlak](https://avatars.discourse-cdn.com/v4/letter/v/ed8c4c/32.png) [@v1dlak](https://discuss.elastic.co/u/v1dlak)\
**Post date:** [April 16, 2018, 8:39am UTC](https://discuss.elastic.co/t/kibana-500-huge-index-patterns/127995/4 "2018-04-16T08:39:05Z")

</div>

Hi here is log from docker/kibana-oss:6.1.2 [https://pastebin.com/WHLqKhri](https://pastebin.com/WHLqKhri)

---

<div class="post-metadata">

**Author:** ![tivvit](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tivvit/32/24685_2.png) [@tivvit](https://discuss.elastic.co/u/tivvit)\
**Post date:** [April 24, 2018, 12:09pm UTC](https://discuss.elastic.co/t/kibana-500-huge-index-patterns/127995/5 "2018-04-24T12:09:22Z")

</div>

Hi Thomas,

any suggestions?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 22, 2018, 12:09pm UTC](https://discuss.elastic.co/t/kibana-500-huge-index-patterns/127995/6 "2018-05-22T12:09:28Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
