# Kibana 5601 connection refused

**URL:** <https://discuss.elastic.co/t/kibana-5601-connection-refused/103641>\
**Category:** Kibana\
**Created:** [October 12, 2017, 4:26am UTC](https://discuss.elastic.co/t/kibana-5601-connection-refused/103641 "2017-10-12T04:26:35Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Jhondude](https://avatars.discourse-cdn.com/v4/letter/j/7feea3/32.png) [@Jhondude](https://discuss.elastic.co/u/Jhondude)\
**Post date:** [October 12, 2017, 4:26am UTC](https://discuss.elastic.co/t/kibana-5601-connection-refused/103641/1 "2017-10-12T04:26:36Z")

</div>

Hi,  
i have install ELK and all service is running.  
but, when i tried to accesss kibana, connection refused.

```
root@picserver:/var/log/kibana# curl http://10.3.10.100:5601
curl: (7) Failed to connect to 10.3.10.100 port 5601: Connection refused

```

here its my kibana confiuration

```
elasticsearch.url: "http://10.3.10.100:9200"
server.host: "10.3.10.100"
server.port: 5601

```

i've kibana log, but its nothing

```
root@picserver:/var/log/kibana# pwd ; ls -l
/var/log/kibana
total 0

```

i have checking the port but it seems not listening

```
root@picserver:/var/log/kibana# netstat -anp | grep 5601
root@picserver:/var/log/kibana# 

```

Please need help.

---

<div class="post-metadata">

**Author:** ![Jhondude](https://avatars.discourse-cdn.com/v4/letter/j/7feea3/32.png) [@Jhondude](https://discuss.elastic.co/u/Jhondude)\
**Post date:** [October 12, 2017, 4:43am UTC](https://discuss.elastic.co/t/kibana-5601-connection-refused/103641/2 "2017-10-12T04:43:36Z")

</div>

Hi,  
my kibana has running, but should it must be running using /opt/kibana/bin/kibana ?

```
root@picserver:/etc/logstash/conf.d# /opt/kibana/bin/kibana 
  log [11:37:42.939] [info][status][plugin:kibana] Status changed from uninitialized to green - Ready
  log [11:37:43.042] [info][status][plugin:elasticsearch] Status changed from uninitialized to yellow - Waiting for Elasticsearch
  log [11:37:43.100] [info][status][plugin:kbn_vislib_vis_types] Status changed from uninitialized to green - Ready
  log [11:37:43.121] [info][status][plugin:markdown_vis] Status changed from uninitialized to green - Ready
  log [11:37:43.148] [info][status][plugin:metric_vis] Status changed from uninitialized to green - Ready
  log [11:37:43.186] [info][status][plugin:spyModes] Status changed from uninitialized to green - Ready
  log [11:37:43.197] [info][status][plugin:elasticsearch] Status changed from yellow to green - Kibana index ready
  log [11:37:43.202] [info][status][plugin:statusPage] Status changed from uninitialized to green - Ready
  log [11:37:43.217] [info][status][plugin:table_vis] Status changed from uninitialized to green - Ready
  log [11:37:43.238] [info][listening] Server running at http://10.3.10.100:5601

picserver@picserver:/var/log/kibana$ curl http://10.3.10.100:5601
<script>var hashRoute = '/app/kibana';
var defaultRoute = '/app/kibana';

var hash = window.location.hash;
if (hash.length) {
  window.location = hashRoute + hash;
} else {
  window.location = defaultRoute;
}</script>picserver@picserver:/var/log/kibana$ 
picserver@picserver:/var/log/kibana$

```

How to make its running automatically when i run "service kibana start"?

Thanks

---

<div class="post-metadata">

**Author:** ![Jhondude](https://avatars.discourse-cdn.com/v4/letter/j/7feea3/32.png) [@Jhondude](https://discuss.elastic.co/u/Jhondude)\
**Post date:** [October 12, 2017, 4:51am UTC](https://discuss.elastic.co/t/kibana-5601-connection-refused/103641/3 "2017-10-12T04:51:19Z")

</div>

How to make it running on background?  
because when i close my terminal, everything going mess again.  
and port 5601 back to connection refused.

Thanks

---

<div class="post-metadata">

**Author:** ![Jhondude](https://avatars.discourse-cdn.com/v4/letter/j/7feea3/32.png) [@Jhondude](https://discuss.elastic.co/u/Jhondude)\
**Post date:** [October 12, 2017, 5:02am UTC](https://discuss.elastic.co/t/kibana-5601-connection-refused/103641/4 "2017-10-12T05:02:02Z")

</div>

Hi,  
verything has solved using this command /opt/kibana/bin/kibana & disown

😃

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 9, 2017, 5:02am UTC](https://discuss.elastic.co/t/kibana-5601-connection-refused/103641/5 "2017-11-09T05:02:03Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
