# Kibana 6.0.0 and getting "UI Settings requires the elasticsearch plugin"

**URL:** <https://discuss.elastic.co/t/kibana-6-0-0-and-getting-ui-settings-requires-the-elasticsearch-plugin/113966>\
**Category:** Kibana\
**Created:** [January 3, 2018, 5:28pm UTC](https://discuss.elastic.co/t/kibana-6-0-0-and-getting-ui-settings-requires-the-elasticsearch-plugin/113966 "2018-01-03T17:28:32Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![zpraxis](https://avatars.discourse-cdn.com/v4/letter/z/5daacb/32.png) [@zpraxis](https://discuss.elastic.co/u/zpraxis)\
**Post date:** [January 3, 2018, 5:28pm UTC](https://discuss.elastic.co/t/kibana-6-0-0-and-getting-ui-settings-requires-the-elasticsearch-plugin/113966/1 "2018-01-03T17:28:32Z")

</div>

Hi all,

I installed Kibana 6.0.0 using `.tar.gz` option, and I'm getting the following error upon execution:

`> [error][status][ui settings] Status changed from uninitialized to red - UI Settings requires the elasticsearch plugin`

My Elasticsearch instance is up and running, so I would appreciate your guidance regarding this issue, since I have no idea of what's happening. Also, if I try to access Kibana using a browser, i get the message `ERR_CONNECTION_REFUSED`.

Thanks in advance!

---

<div class="post-metadata">

**Author:** ![thomasneirynck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/thomasneirynck/32/23313_2.png) [@thomasneirynck](https://discuss.elastic.co/u/thomasneirynck)\
**Post date:** [January 3, 2018, 10:43pm UTC](https://discuss.elastic.co/t/kibana-6-0-0-and-getting-ui-settings-requires-the-elasticsearch-plugin/113966/2 "2018-01-03T22:43:45Z")

</div>

hi @zpraxis,

Can you verify the following things first:

- elasticsearch is the same version as kibana (6.0)
- elasticsearch is running on port 9200
- you extracted kibana in a clean folder (so no conflicts with earlier versions of kibana (if any))
- clean your browser cache

thanks,

---

<div class="post-metadata">

**Author:** ![zpraxis](https://avatars.discourse-cdn.com/v4/letter/z/5daacb/32.png) [@zpraxis](https://discuss.elastic.co/u/zpraxis)\
**Post date:** [January 3, 2018, 11:24pm UTC](https://discuss.elastic.co/t/kibana-6-0-0-and-getting-ui-settings-requires-the-elasticsearch-plugin/113966/3 "2018-01-03T23:24:50Z")

</div>

Thanks! It is working now.

I think the causes were the following:

1. I was attempting to use environment variables in `kibana.yml`, which is not currently supported. No error about this was printed though. I realized this after some debugging.
2. I was defining the PID file to be a path instead, because the comment above the attribute say so. This is misleading.

Thanks again!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 31, 2018, 11:25pm UTC](https://discuss.elastic.co/t/kibana-6-0-0-and-getting-ui-settings-requires-the-elasticsearch-plugin/113966/4 "2018-01-31T23:25:20Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
