# Kibana 6.2.3 -\> 6.2.4: Error: Invalid dimensions for plot, width = 473, height = 0

**URL:** <https://discuss.elastic.co/t/kibana-6-2-3-6-2-4-error-invalid-dimensions-for-plot-width-473-height-0/129140>\
**Category:** Kibana\
**Created:** [April 23, 2018, 3:11pm UTC](https://discuss.elastic.co/t/kibana-6-2-3-6-2-4-error-invalid-dimensions-for-plot-width-473-height-0/129140 "2018-04-23T15:11:50Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![diranged](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/diranged/32/4065_2.png) [@diranged](https://discuss.elastic.co/u/diranged)\
**Post date:** [April 23, 2018, 3:11pm UTC](https://discuss.elastic.co/t/kibana-6-2-3-6-2-4-error-invalid-dimensions-for-plot-width-473-height-0/129140/1 "2018-04-23T15:11:50Z")

</div>

We recently upgraded from ES 6.2.3 -\> 6.2.4 due to a leaky file handle issue ([Open File Handles leaking on 6.2.3 nodes..?](https://discuss.elastic.co/t/open-file-handles-leaking-on-6-2-3-nodes/128979/3)). To keep Kibana happy, we upgraded it as well to 6.2.4.

We have a new issue now though - the Kibana 6.2.4 _monitoring_ UI throws an error when it loads up:

```auto
vendors.bundle.js?v=16627:116 Error: Invalid dimensions for plot, width = 473, height = 0
    at Canvas.resize (commons.bundle.js?v=16627:45)
    at new Canvas (commons.bundle.js?v=16627:45)
    at commons.bundle.js?v=16627:45
    at new Plot (commons.bundle.js?v=16627:45)
    at Function.$.plot (commons.bundle.js?v=16627:45)
    at ChartTarget.value (monitoring.bundle.js?v=16627:1)
    at ChartTarget.value (monitoring.bundle.js?v=16627:1)
    at commitLifeCycles (commons.bundle.js?v=16627:45)
    at c (commons.bundle.js?v=16627:45)
    at k (commons.bundle.js?v=16627:45)
    at p (commons.bundle.js?v=16627:45)
    at y (commons.bundle.js?v=16627:45)
    at D (commons.bundle.js?v=16627:45)
    at Object.updateContainer (commons.bundle.js?v=16627:45)
    at commons.bundle.js?v=16627:45
    at Object.unbatchedUpdates (commons.bundle.js?v=16627:45)

```

The UI is pretty unusable, looking like this:

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/4/9/498a867294ef2e37b17fa6b044006d39da0e80fa.png)

---

<div class="post-metadata">

**Author:** ![Stacey\_Gammon](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stacey_gammon/32/14025_2.png) [@Stacey\_Gammon](https://discuss.elastic.co/u/Stacey_Gammon)\
**Post date:** [April 23, 2018, 6:35pm UTC](https://discuss.elastic.co/t/kibana-6-2-3-6-2-4-error-invalid-dimensions-for-plot-width-473-height-0/129140/2 "2018-04-23T18:35:35Z")

</div>

Yes that UI doesn't look right at all.

I upgraded from 6.2.3 to 6.2.4 and wasn't able to repro.

What page in monitoring did you screenshot that from? The landing page when you click on the monitoring app, or the `Overview` page in monitoring? If you have access to the landing page, do any of the other sub sections work? e.g. if you click on `Nodes` or `Indices`

 ![41%20PM](https://us1.discourse-cdn.com/elastic/original/3X/f/3/f32e8c212ca596894ae2f5faaa9411d1e57f731c.png)

cc @tsullivan@pickypg - you guys see anything like this before?

---

<div class="post-metadata">

**Author:** ![pickypg](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pickypg/32/62409_2.png) [@pickypg](https://discuss.elastic.co/u/pickypg)\
**Post date:** [April 23, 2018, 7:03pm UTC](https://discuss.elastic.co/t/kibana-6-2-3-6-2-4-error-invalid-dimensions-for-plot-width-473-height-0/129140/3 "2018-04-23T19:03:33Z")

</div>

That appears to be an index-level page based on the screenshot. I am also unable to reproduce this as well, but it appears to be caused by at least one of the charts on the page based on the error.

Does it happen on any other page(s), or just this one page and is it specific to this index (suggesting it's the index's data that triggers the condition)? Does resizing the browser window, then refreshing the page help?

---

<div class="post-metadata">

**Author:** ![diranged](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/diranged/32/4065_2.png) [@diranged](https://discuss.elastic.co/u/diranged)\
**Post date:** [April 23, 2018, 8:00pm UTC](https://discuss.elastic.co/t/kibana-6-2-3-6-2-4-error-invalid-dimensions-for-plot-width-473-height-0/129140/4 "2018-04-23T20:00:09Z")

</div>

This happens basically on any of the "Monitoring" pages. We do a pretty basic install of Kibana w/ the [Elastic.co](http://Elastic.co) provided Puppet module (v6.0.1). Double checking the Kibana logs, I see this in the Kibana error log:

```auto
FATAL { Error: EACCES: permission denied, open '/usr/share/kibana/optimize/bundles/ml.style.css'
    at Error (native)
  cause: 
   { Error: EACCES: permission denied, open '/usr/share/kibana/optimize/bundles/ml.style.css'
       at Error (native)
     errno: -13,
     code: 'EACCES',
     syscall: 'open',
     path: '/usr/share/kibana/optimize/bundles/ml.style.css' },
  isOperational: true,
  errno: -13,
  code: 'EACCES',
  syscall: 'open',
  path: '/usr/share/kibana/optimize/bundles/ml.style.css' }

```

I've seen some permissions issues here before, so I wiped out the bundles directory and restarted Kibana. That seems to have solved it. It seems like its some issue with the Kibana puppet module and the order-of-operations.. some files get owned by root before Kibana starts up, and then it can't properly generate the bundles.

---

<div class="post-metadata">

**Author:** ![pickypg](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pickypg/32/62409_2.png) [@pickypg](https://discuss.elastic.co/u/pickypg)\
**Post date:** [April 23, 2018, 8:06pm UTC](https://discuss.elastic.co/t/kibana-6-2-3-6-2-4-error-invalid-dimensions-for-plot-width-473-height-0/129140/5 "2018-04-23T20:06:52Z")

</div>

@diranged

Thanks for the update. I'll add an issue to the Puppet module to point this out.

> <https://github.com/elastic/puppet-kibana/issues/27>

If you have any other issues, please add them to the ticket there so that the maintainer can properly fix it (I'm not a Puppet expert unfortunately). It may also be worthwhile for you to follow the issue over there in case any questions that you can answer come in.

Thanks,  
Chris

---

<div class="post-metadata">

**Author:** ![tsullivan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tsullivan/32/31077_2.png) [@tsullivan](https://discuss.elastic.co/u/tsullivan)\
**Post date:** [April 23, 2018, 8:15pm UTC](https://discuss.elastic.co/t/kibana-6-2-3-6-2-4-error-invalid-dimensions-for-plot-width-473-height-0/129140/6 "2018-04-23T20:15:56Z")

</div>

The chart height dimension comes from a CSS style, so if there were problems loading a CSS resource, then this issue makes sense. Thanks for the update!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 21, 2018, 8:22pm UTC](https://discuss.elastic.co/t/kibana-6-2-3-6-2-4-error-invalid-dimensions-for-plot-width-473-height-0/129140/7 "2018-05-21T20:22:24Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
