# Kibana 6.2.3: localhost port 5061: Connection refused

**URL:** https://discuss.elastic.co/t/kibana-6-2-3-localhost-port-5061-connection-refused/125460
**Category:** Kibana
**Created:** [March 24, 2018, 11:57pm UTC](https://discuss.elastic.co/t/kibana-6-2-3-localhost-port-5061-connection-refused/125460 "2018-03-24T23:57:40Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Alphakilo](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alphakilo/32/29202_2.png) [@Alphakilo](https://discuss.elastic.co/u/Alphakilo)
#### Post date: [March 24, 2018, 11:57pm UTC](https://discuss.elastic.co/t/kibana-6-2-3-localhost-port-5061-connection-refused/125460/1 "2018-03-24T23:57:40Z")

</div>

Hi there!

I'm having some issues getting my Kibana installation up and running.  
I've installed Elasticsearch and Kibana on the same machine using the official repository:

```
root@{{hostname}}:~# apt list elasticsearch kibana
Listing... Done
elasticsearch/stable,now 6.2.3 all [installed]
kibana/stable,now 6.2.3 amd64 [installed]

```

From here on, everything between `{{}}` is something I redacted.

Elasticsearch works out of the box:

```
root@{{hostname}}:~# curl -XGET 'localhost:9200/?pretty'
{{
  "name" : "{{hostname}}",
  "cluster_name" : "{{cluster_name}}",
  "cluster_uuid" : "{{uuid}}",
  "version" : {{
    "number" : "6.2.3",
    "build_hash" : "c59ff00",
    "build_date" : "2018-03-13T10:06:29.741383Z",
    "build_snapshot" : false,
    "lucene_version" : "7.2.1",
    "minimum_wire_compatibility_version" : "5.6.0",
    "minimum_index_compatibility_version" : "5.0.0"
  }},
  "tagline" : "You Know, for Search"
}}

```

Kibana how ever does not:

```
root@{{hostname}}:~# curl 'localhost:5061'
curl: (7) Failed to connect to localhost port 5061: Connection refused
root@{{hostname}}:~# nc -v 127.0.0.1 5061
nc: connect to 127.0.0.1 port 5061 (tcp) failed: Connection refused
root@{{hostname}}:~# nc -v ::1 5061
nc: connect to ::1 port 5061 (tcp) failed: Connection refused

```

It is running and has a listener:

```
root@{{hostname}}:~# netstat -tlpn
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 127.0.0.1:5601 0.0.0.0:* LISTEN 862/node        
{{...}}
tcp6 0 0 ::1:9200 :::* LISTEN 605/java        
tcp6 0 0 127.0.0.1:9200 :::* LISTEN 605/java        
tcp6 0 0 ::1:9300 :::* LISTEN 605/java        
tcp6 0 0 127.0.0.1:9300 :::* LISTEN 605/java        
{{...}}

```

The Kibana log's looking good:

```
{"type":"log","@timestamp":"2018-03-24T23:43:09Z","tags":["status","plugin:kibana@6.2.3","info"],"pid":917,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2018-03-24T23:43:09Z","tags":["status","plugin:elasticsearch@6.2.3","info"],"pid":917,"state":"yellow","message":"Status changed from uninitialized to yellow - Waiting for Elasticsearch","prevState":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2018-03-24T23:43:09Z","tags":["status","plugin:timelion@6.2.3","info"],"pid":917,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2018-03-24T23:43:09Z","tags":["status","plugin:console@6.2.3","info"],"pid":917,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2018-03-24T23:43:09Z","tags":["status","plugin:metrics@6.2.3","info"],"pid":917,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2018-03-24T23:43:10Z","tags":["listening","info"],"pid":917,"message":"Server running at http://127.0.0.1:5601"}
{"type":"log","@timestamp":"2018-03-24T23:43:10Z","tags":["status","plugin:elasticsearch@6.2.3","info"],"pid":917,"state":"green","message":"Status changed from yellow to green - Ready","prevState":"yellow","prevMsg":"Waiting for Elasticsearch"}

```

These are the not-commented (active) lines in both config files:

```
root@{{hostname}}:~# grep -Ev "#|^$" /etc/kibana/kibana.yml
server.port: 5601
server.host: "127.0.0.1"
server.name: "{{hostname}}{{domain.tld}}"
elasticsearch.url: "http://localhost:9200"
logging.dest: /var/log/kibana/kibana.log

root@{{hostname}}:~# grep -Ev "#|^$" /etc/elasticsearch/elasticsearch.yml
cluster.name: {{cluster.name}}
node.name: {{hostname}}
path.data: /var/lib/elasticsearch
path.logs: /var/log/elasticsearch
network.host: localhost
http.cors.enabled: true
http.cors.allow-origin: http://localhost:5601

```

What am I missing?

---

<div class="post-metadata">

### Author: ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)
#### Post date: [March 25, 2018, 6:09am UTC](https://discuss.elastic.co/t/kibana-6-2-3-localhost-port-5061-connection-refused/125460/2 "2018-03-25T06:09:52Z")

</div>

> [@Alphakilo](#):
>
> root@{{hostname}}:~# curl 'localhost:5061'

This is supposed to be `5601`, not `5061`.

---

<div class="post-metadata">

### Author: ![Alphakilo](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alphakilo/32/29202_2.png) [@Alphakilo](https://discuss.elastic.co/u/Alphakilo)
#### Post date: [March 25, 2018, 10:25am UTC](https://discuss.elastic.co/t/kibana-6-2-3-localhost-port-5061-connection-refused/125460/3 "2018-03-25T10:25:04Z")

</div>

🤦‍♂️

TYVM!

Never do deployments at 02:00 AM.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [April 22, 2018, 10:25am UTC](https://discuss.elastic.co/t/kibana-6-2-3-localhost-port-5061-connection-refused/125460/4 "2018-04-22T10:25:06Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
