# Kibana 6.3.2 does not work on ipv6

**URL:** <https://discuss.elastic.co/t/kibana-6-3-2-does-not-work-on-ipv6/171731>\
**Category:** Kibana\
**Created:** [March 11, 2019, 10:52am UTC](https://discuss.elastic.co/t/kibana-6-3-2-does-not-work-on-ipv6/171731 "2019-03-11T10:52:04Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![vara0855](https://avatars.discourse-cdn.com/v4/letter/v/3da27b/32.png) [@vara0855](https://discuss.elastic.co/u/vara0855)\
**Post date:** [March 11, 2019, 10:52am UTC](https://discuss.elastic.co/t/kibana-6-3-2-does-not-work-on-ipv6/171731/1 "2019-03-11T10:52:04Z")

</div>

**Kibana version** : 6.3.2 OSS  
**Elasticsearch version** : 6.3.2 OSS

Elasticsearch and kibana are located on the same hosts

my properties on kibana.yml file:

```auto
elasticsearch.url: "http://[fd95:ff55:7fb8:f1e5:f816:3eff:feed:ce5b]:9201"
server.host: "fd95:ff55:7fb8:f1e5:f816:3eff:feed:ce5b"
server.port: 5601

```

i have this error on browser when i open any kibana plugins:

```javascript
ERROR: 2019-03-11T10:43:22Z
  Error: Request error, retrying
  POST https://fd95:ff55:7fb8:f1e5:f816:3eff:feed:ce5b:5601/elasticsearch/_msearch => Failed to execute 'open' on 'XMLHttpRequest': Invalid URL
      at Log.error (https://[fd95:ff55:7fb8:f1e5:f816:3eff:feed:ce5b]:5601/bundles/vendors.bundle.js?v=17307:162:80027)
      at checkRespForFailure (https://[fd95:ff55:7fb8:f1e5:f816:3eff:feed:ce5b]:5601/bundles/vendors.bundle.js?v=17307:162:88597)
      at https://[fd95:ff55:7fb8:f1e5:f816:3eff:feed:ce5b]:5601/bundles/vendors.bundle.js?v=17307:162:98978
      at processQueue (https://[fd95:ff55:7fb8:f1e5:f816:3eff:feed:ce5b]:5601/bundles/vendors.bundle.js?v=17307:125:134252)
      at https://[fd95:ff55:7fb8:f1e5:f816:3eff:feed:ce5b]:5601/bundles/vendors.bundle.js?v=17307:125:135201
      at Scope.$digest (https://[fd95:ff55:7fb8:f1e5:f816:3eff:feed:ce5b]:5601/bundles/vendors.bundle.js?v=17307:125:146077)
      at https://[fd95:ff55:7fb8:f1e5:f816:3eff:feed:ce5b]:5601/bundles/vendors.bundle.js?v=17307:125:148581
      at completeOutstandingRequest (https://[fd95:ff55:7fb8:f1e5:f816:3eff:feed:ce5b]:5601/bundles/vendors.bundle.js?v=17307:125:37082)
      at https://[fd95:ff55:7fb8:f1e5:f816:3eff:feed:ce5b]:5601/bundles/vendors.bundle.js?v=17307:125:40220

```

Also Kibana devTools working. I think that something wrong with elasticsearch ui client or proxy.  
This is bug? or not?  
I haven't opportunity to use ipv4 network.  
Please, help me.

---

<div class="post-metadata">

**Author:** ![Joe\_Fleming](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/joe_fleming/32/3561_2.png) [@Joe\_Fleming](https://discuss.elastic.co/u/Joe_Fleming)\
**Post date:** [March 11, 2019, 9:19pm UTC](https://discuss.elastic.co/t/kibana-6-3-2-does-not-work-on-ipv6/171731/2 "2019-03-11T21:19:48Z")

</div>

[This issue talks about the server not binding to the IPv6 localhost address](https://github.com/elastic/kibana/issues/23431), but that's a difference use case, you're setting the host to the IPv6 address.

It may be related to [this addressing fix](https://github.com/elastic/kibana/pull/29891) which looks like will be part of v7.0.0 of the stack, but wasn't backported to any 6.x version. It may be worthwhile following up on that PR and asking about a backport.

---

<div class="post-metadata">

**Author:** ![vara0855](https://avatars.discourse-cdn.com/v4/letter/v/3da27b/32.png) [@vara0855](https://discuss.elastic.co/u/vara0855)\
**Post date:** [March 12, 2019, 10:44am UTC](https://discuss.elastic.co/t/kibana-6-3-2-does-not-work-on-ipv6/171731/3 "2019-03-12T10:44:12Z")

</div>

I tried different host configurations.

- with [::0]
- with bind name in /etc/hosts . Like this :`fd95:ff55:7fb8:f1e5:f816:3eff:feed:ce5b elk-network-host`

none of them worked.

if this is useful, I also use **ssl**.

---

<div class="post-metadata">

**Author:** ![vara0855](https://avatars.discourse-cdn.com/v4/letter/v/3da27b/32.png) [@vara0855](https://discuss.elastic.co/u/vara0855)\
**Post date:** [March 12, 2019, 10:48am UTC](https://discuss.elastic.co/t/kibana-6-3-2-does-not-work-on-ipv6/171731/4 "2019-03-12T10:48:32Z")

</div>

Oh. If I change the kibana code as specified in that [FIX](https://github.com/elastic/kibana/pull/29891/files).

Everything works!!!

Where do I go to get a fix for the 6.3.2 version of Kibana?

---

<div class="post-metadata">

**Author:** ![Joe\_Fleming](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/joe_fleming/32/3561_2.png) [@Joe\_Fleming](https://discuss.elastic.co/u/Joe_Fleming)\
**Post date:** [March 19, 2019, 9:03pm UTC](https://discuss.elastic.co/t/kibana-6-3-2-does-not-work-on-ipv6/171731/5 "2019-03-19T21:03:55Z")

</div>

> Where do I go to get a fix for the 6.3.2 version of Kibana?

You'd have to roll your own build with that fix in it. I don't think there will be any more 6.3 releases at all, so even if this was backported, you'd still need to upgrade to 6.6 or 6.7 (depending on when that release is cut).

I [added a comment](https://github.com/elastic/kibana/pull/29891#issuecomment-474583293) to the PR that fixed it to see why it wasn't made available in any 6.x version, feel free to follow up or plead the case for backporting there.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 16, 2019, 9:03pm UTC](https://discuss.elastic.co/t/kibana-6-3-2-does-not-work-on-ipv6/171731/6 "2019-04-16T21:03:57Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
