# Kibana 6.3 fatal error (upgrade from 6.2)

**URL:** <https://discuss.elastic.co/t/kibana-6-3-fatal-error-upgrade-from-6-2/135804>\
**Category:** Kibana\
**Created:** [June 13, 2018, 10:47pm UTC](https://discuss.elastic.co/t/kibana-6-3-fatal-error-upgrade-from-6-2/135804 "2018-06-13T22:47:03Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![ocabj](https://avatars.discourse-cdn.com/v4/letter/o/f6c823/32.png) [@ocabj](https://discuss.elastic.co/u/ocabj)\
**Post date:** [June 13, 2018, 10:47pm UTC](https://discuss.elastic.co/t/kibana-6-3-fatal-error-upgrade-from-6-2/135804/1 "2018-06-13T22:47:03Z")

</div>

I RPM upgraded kibana to 6.3 from 6.2 and am getting a fatal error preventing kibana from starting up:

{"type":"error","@timestamp":"2018-06-13T22:43:49Z","tags":["fatal"],"pid":10211,"level":"fatal","error":{"message":"Multple plugins found with the id "xpack\_main":\n - xpack\_main at /usr/share/kibana/node\_modules/x-pack\n - xpack\_main at /usr/share/kibana/plugins/x-pack","name":"Error","stack":"Error: Multple plugins found with the id "xpack\_main":\n - xpack\_main at /usr/share/kibana/node\_modules/x-pack\n - xpack\_main at /usr/share/kibana/plugins/x-pack\n at MergeMapSubscriber.find$.mergeMap.toArray.mergeMap.allSpecs [as project] (/usr/share/kibana/src/plugin\_discovery/find\_plugin\_specs.js:87:15)\n at MergeMapSubscriber.\_tryNext (/usr/share/kibana/node\_modules/rxjs/src/operator/mergeMap.ts:125:21)\n at MergeMapSubscriber.\_next (/usr/share/kibana/node\_modules/rxjs/src/operator/mergeMap.ts:115:12)\n at MergeMapSubscriber.Subscriber.next (/usr/share/kibana/node\_modules/rxjs/src/Subscriber.ts:95:12)\n at ToArraySubscriber.\_complete (/usr/share/kibana/node\_modules/rxjs/src/operator/toArray.ts:38:22)\n at ToArraySubscriber.Subscriber.complete (/usr/share/kibana/node\_modules/rxjs/src/Subscriber.ts:122:12)\n at MergeMapSubscriber.\_complete (/usr/share/kibana/node\_modules/rxjs/src/operator/mergeMap.ts:141:24)\n at MergeMapSubscriber.Subscriber.complete (/usr/share/kibana/node\_modules/rxjs/src/Subscriber.ts:122:12)\n at RefCountSubscriber.Subscriber.\_complete (/usr/share/kibana/node\_modules/rxjs/src/Subscriber.ts:144:22)\n at RefCountSubscriber.Subscriber.complete (/usr/share/kibana/node\_modules/rxjs/src/Subscriber.ts:122:12)\n at Subject.complete (/usr/share/kibana/node\_modules/rxjs/src/Subject.ts:91:15)\n at ConnectableSubscriber.Subscriber.\_complete (/usr/share/kibana/node\_modules/rxjs/src/Subscriber.ts:144:22)\n at ConnectableSubscriber.\_complete (/usr/share/kibana/node\_modules/rxjs/src/observable/ConnectableObservable.ts:82:20)\n at ConnectableSubscriber.Subscriber.complete (/usr/share/kibana/node\_modules/rxjs/src/Subscriber.ts:122:12)\n at DistinctSubscriber.Subscriber.\_complete (/usr/share/kibana/node\_modules/rxjs/src/Subscriber.ts:144:22)\n at DistinctSubscriber.Subscriber.complete (/usr/share/kibana/node\_modules/rxjs/src/Subscriber.ts:122:12)\n at MergeAllSubscriber.notifyComplete (/usr/share/kibana/node\_modules/rxjs/src/operator/mergeAll.ts:106:24)\n at InnerSubscriber.\_complete (/usr/share/kibana/node\_modules/rxjs/src/InnerSubscriber.ts:26:17)\n at InnerSubscriber.Subscriber.complete (/usr/share/kibana/node\_modules/rxjs/src/Subscriber.ts:122:12)\n at CatchSubscriber.Subscriber.\_complete (/usr/share/kibana/node\_modules/rxjs/src/Subscriber.ts:144:22)\n at CatchSubscriber.Subscriber.complete (/usr/share/kibana/node\_modules/rxjs/src/Subscriber.ts:122:12)\n at MergeMapSubscriber.notifyComplete (/usr/share/kibana/node\_modules/rxjs/src/operator/mergeMap.ts:173:24)\n at InnerSubscriber.\_complete (/usr/share/kibana/node\_modules/rxjs/src/InnerSubscriber.ts:26:17)\n at InnerSubscriber.Subscriber.complete (/usr/share/kibana/node\_modules/rxjs/src/Subscriber.ts:122:12)\n at CatchSubscriber.Subscriber.\_complete (/usr/share/kibana/node\_modules/rxjs/src/Subscriber.ts:144:22)\n at CatchSubscriber.Subscriber.complete (/usr/share/kibana/node\_modules/rxjs/src/Subscriber.ts:122:12)\n at MapSubscriber.Subscriber.\_complete (/usr/share/kibana/node\_modules/rxjs/src/Subscriber.ts:144:22)\n at MapSubscriber.Subscriber.complete (/usr/share/kibana/node\_modules/rxjs/src/Subscriber.ts:122:12)"},"message":"Multple plugins found with the id "xpack\_main":\n - xpack\_main at /usr/share/kibana/node\_modules/x-pack\n - xpack\_main at /usr/share/kibana/plugins/x-pack"}

---

<div class="post-metadata">

**Author:** ![ocabj](https://avatars.discourse-cdn.com/v4/letter/o/f6c823/32.png) [@ocabj](https://discuss.elastic.co/u/ocabj)\
**Post date:** [June 13, 2018, 10:52pm UTC](https://discuss.elastic.co/t/kibana-6-3-fatal-error-upgrade-from-6-2/135804/2 "2018-06-13T22:52:46Z")

</div>

Resolved my own issue by uninstalling kibana (yum / rpm) and deleting the entire /usr/share/kibana directory and resinstalling.

---

<div class="post-metadata">

**Author:** ![A\_B](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/a_b/32/17104_2.png) [@A\_B](https://discuss.elastic.co/u/A_B)\
**Post date:** [June 14, 2018, 7:43am UTC](https://discuss.elastic.co/t/kibana-6-3-fatal-error-upgrade-from-6-2/135804/3 "2018-06-14T07:43:50Z")

</div>

I have a similar issue on Debian.

As far as I can work out, Kibana 6.3.0 comes with x-pack. I guess I should have removed the old x-pack plugin first

When I try to remove the old version now I see

```
$ ./kibana-plugin remove x-pack
You are using the standard distrbution of Kibana. Please install the OSS-only distribution to remove X-Pack features.

```

I will also simply purge old version and reinstall. It's only a test setup so I do not need to worry about stored dashboards or anything like that...

---

<div class="post-metadata">

**Author:** ![willemdh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/willemdh/32/16922_2.png) [@willemdh](https://discuss.elastic.co/u/willemdh)\
**Post date:** [June 14, 2018, 7:51am UTC](https://discuss.elastic.co/t/kibana-6-3-fatal-error-upgrade-from-6-2/135804/4 "2018-06-14T07:51:50Z")

</div>

Same issue here on update of Elastic Kibana community edition on a CentOS 7 server.

`FATAL Error: Multple plugins found with the id "xpack_main"`

---

<div class="post-metadata">

**Author:** ![willemdh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/willemdh/32/16922_2.png) [@willemdh](https://discuss.elastic.co/u/willemdh)\
**Post date:** [June 14, 2018, 8:18am UTC](https://discuss.elastic.co/t/kibana-6-3-fatal-error-upgrade-from-6-2/135804/5 "2018-06-14T08:18:26Z")

</div>

The issue is caused by a wrong update order. After stopping the service, we need to first remove x-pack, then update and finally reinstall x-pack, after which the update works ok.

---

<div class="post-metadata">

**Author:** ![mans39](https://avatars.discourse-cdn.com/v4/letter/m/82dd89/32.png) [@mans39](https://discuss.elastic.co/u/mans39)\
**Post date:** [June 14, 2018, 3:11pm UTC](https://discuss.elastic.co/t/kibana-6-3-fatal-error-upgrade-from-6-2/135804/6 "2018-06-14T15:11:30Z")

</div>

Hi,

I have the same error about Kibana after upgrade from 6.2 to 6.3.

You are using the standard distrbution of Kibana. Please install the OSS-only distribution to remove X-Pack features.

I tryied to stop Kibana and execute /usr/share/kibana/bin/kibana-plugin remove x-pack but I have this error.

How can I solve this please ?

Regards,

---

<div class="post-metadata">

**Author:** ![zermoth](https://avatars.discourse-cdn.com/v4/letter/z/54ee81/32.png) [@zermoth](https://discuss.elastic.co/u/zermoth)\
**Post date:** [June 14, 2018, 3:16pm UTC](https://discuss.elastic.co/t/kibana-6-3-fatal-error-upgrade-from-6-2/135804/7 "2018-06-14T15:16:39Z")

</div>

yum downgrade kibana  
/usr/share/kibana/bin/kibana-plugin remove x-pack  
yum update kibana  
systemctl restart kibana.service

working now

---

<div class="post-metadata">

**Author:** ![CW360\_Michael](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cw360_michael/32/31437_2.png) [@CW360\_Michael](https://discuss.elastic.co/u/CW360_Michael)\
**Post date:** [June 15, 2018, 2:02pm UTC](https://discuss.elastic.co/t/kibana-6-3-fatal-error-upgrade-from-6-2/135804/8 "2018-06-15T14:02:25Z")

</div>

To anyone reading this with similar issues, you don't need to downgrade or uninstall/reinstall. You can simply remove the leftover X-Pack code from the 6.3 codebase.

Assuming you've upgraded to 6.3, all you need to do is:

```
# For Debian, Kibana is at...
cd /usr/share/kibana
# Remove X-Pack 6.2.4
rm -rf plugins/x-pack
# Now restart Kibana
systemctl restart kibana

```

Looking at how they remove plugins from Kibana (`src/cli_plugin/remove/remove.js`) you can do this to remove an old x-pack from Kibana and you're doing it very close the same way `bin/kibana-plugin remove` handles things.

If you're super paranoid, you can check the X-Pack version from `plugins/x-pack/package.json` to verify that it's the older version (pre-6.3). X-Pack is bundled, so it doesn't show up or need to be shown in the plugins folder.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 13, 2018, 2:06pm UTC](https://discuss.elastic.co/t/kibana-6-3-fatal-error-upgrade-from-6-2/135804/9 "2018-07-13T14:06:02Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
