# KIbana 6.7.0 broken upgrade

**URL:** <https://discuss.elastic.co/t/kibana-6-7-0-broken-upgrade/174162>\
**Category:** Kibana\
**Created:** [March 27, 2019, 3:26pm UTC](https://discuss.elastic.co/t/kibana-6-7-0-broken-upgrade/174162 "2019-03-27T15:26:23Z")\
**Posts on this page:** 10\
**Page:** 1

<div class="post-metadata">

**Author:** ![paulsbuxton](https://avatars.discourse-cdn.com/v4/letter/p/858c86/32.png) [@paulsbuxton](https://discuss.elastic.co/u/paulsbuxton)\
**Post date:** [March 27, 2019, 3:26pm UTC](https://discuss.elastic.co/t/kibana-6-7-0-broken-upgrade/174162/1 "2019-03-27T15:26:24Z")

</div>

Running on Ubuntu, and post upgrade of the stack from 6.6.1 to 6.7.0, kibana has a problem!!

When trying to start Kibana, the outoput dumped to screen has the following entries

log [15:15:01.468] [info][status][plugin:reporting@6.7.0] Status changed from uninitialized to green - Ready  
log [15:15:01.497] [warning][reporting] The Reporting plugin encountered issues launching Chromium in a self-test. You may have trouble generating reports: Error: Failed to launch chrome!  
/var/lib/kibana/headless\_shell-linux/headless\_shell: error while loading shared libraries: libnss3.so: cannot open shared object file: No such file or directory

TROUBLESHOOTING: [https://github.com/GoogleChrome/puppeteer/blob/master/docs/troubleshooting.md](https://github.com/GoogleChrome/puppeteer/blob/master/docs/troubleshooting.md)

log [15:15:01.497] [warning][reporting] See Chromium's log output at "/var/lib/kibana/headless\_shell-linux/chrome\_debug.log"

When trying to browse to Kibana, i Get

# Kibana did not load properly. Check the server output for more information.

The file chrome\_debug.log DOES not exist in the directory listed above.

---

<div class="post-metadata">

**Author:** ![paulsbuxton](https://avatars.discourse-cdn.com/v4/letter/p/858c86/32.png) [@paulsbuxton](https://discuss.elastic.co/u/paulsbuxton)\
**Post date:** [March 27, 2019, 4:15pm UTC](https://discuss.elastic.co/t/kibana-6-7-0-broken-upgrade/174162/2 "2019-03-27T16:15:30Z")

</div>

Just to keep you updated on this one......

The error relating to Kibana not loading properly was pinned down to a plugin i was using. GIven the plugin didn't have a 6.7 version (enhanced-table plugin), I had done the package.json edit.

This was only apparent as being the issue when i ran Developer Tools of Chrome, and saw something relating to this plugin mentioned in a 404 error.

The libnss3.so appeared to be resolved by doing a libnss3-tools install.

Kibana is now accessible...... but the chromium error still occurs.

---

<div class="post-metadata">

**Author:** ![Brandon\_Kobel](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/brandon_kobel/32/14829_2.png) [@Brandon\_Kobel](https://discuss.elastic.co/u/Brandon_Kobel)\
**Post date:** [March 27, 2019, 7:07pm UTC](https://discuss.elastic.co/t/kibana-6-7-0-broken-upgrade/174162/3 "2019-03-27T19:07:44Z")

</div>

Hey @paulxbuxton, starting in 6.7 we're launching a version of Chromium on startup to issue a warning whether there are dependencies missing that could potentially cause Reporting jobs to fail.

Are you still seeing the `Error: Failed to launch chrome! /var/lib/kibana/headless_shell-linux/headless_shell: error while loading shared libraries: libnss3.so: cannot open shared object file: No such file or directory` when starting up Kibana? Installing the libnss3 package should make this error stop occurring.

---

<div class="post-metadata">

**Author:** ![paulsbuxton](https://avatars.discourse-cdn.com/v4/letter/p/858c86/32.png) [@paulsbuxton](https://discuss.elastic.co/u/paulsbuxton)\
**Post date:** [March 28, 2019, 12:16pm UTC](https://discuss.elastic.co/t/kibana-6-7-0-broken-upgrade/174162/4 "2019-03-28T12:16:54Z")

</div>

Hi Brandon,

As I noted in my previous reply, I did do that, and the error did go away regarding the library missing.

Still had a failed to launch chromium message though - it didn't stop kibana working - after this.

---

<div class="post-metadata">

**Author:** ![Brandon\_Kobel](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/brandon_kobel/32/14829_2.png) [@Brandon\_Kobel](https://discuss.elastic.co/u/Brandon_Kobel)\
**Post date:** [March 28, 2019, 1:45pm UTC](https://discuss.elastic.co/t/kibana-6-7-0-broken-upgrade/174162/5 "2019-03-28T13:45:24Z")

</div>

> Still had a failed to launch chromium message though - it didn't stop kibana working - after this.

Would you mind sharing the entire failed to launch message? There might be another error being logged.

---

<div class="post-metadata">

**Author:** ![paulsbuxton](https://avatars.discourse-cdn.com/v4/letter/p/858c86/32.png) [@paulsbuxton](https://discuss.elastic.co/u/paulsbuxton)\
**Post date:** [March 28, 2019, 4:01pm UTC](https://discuss.elastic.co/t/kibana-6-7-0-broken-upgrade/174162/6 "2019-03-28T16:01:34Z")

</div>

Hi Brandon,

As below

 ![kibana-startup_chromium](https://us1.discourse-cdn.com/elastic/original/3X/9/7/97dcd880581b30e38f574c42324accbbb3c78f1f.png)

---

<div class="post-metadata">

**Author:** ![Brandon\_Kobel](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/brandon_kobel/32/14829_2.png) [@Brandon\_Kobel](https://discuss.elastic.co/u/Brandon_Kobel)\
**Post date:** [March 28, 2019, 5:39pm UTC](https://discuss.elastic.co/t/kibana-6-7-0-broken-upgrade/174162/7 "2019-03-28T17:39:17Z")

</div>

@paulsbuxton is the Kibana server as the `root` user?

---

<div class="post-metadata">

**Author:** ![paulsbuxton](https://avatars.discourse-cdn.com/v4/letter/p/858c86/32.png) [@paulsbuxton](https://discuss.elastic.co/u/paulsbuxton)\
**Post date:** [April 1, 2019, 10:19am UTC](https://discuss.elastic.co/t/kibana-6-7-0-broken-upgrade/174162/8 "2019-04-01T10:19:20Z")

</div>

Brandon,

Apologies for the delay.

I was running this via the sudo command.

---

<div class="post-metadata">

**Author:** ![Brandon\_Kobel](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/brandon_kobel/32/14829_2.png) [@Brandon\_Kobel](https://discuss.elastic.co/u/Brandon_Kobel)\
**Post date:** [April 1, 2019, 2:53pm UTC](https://discuss.elastic.co/t/kibana-6-7-0-broken-upgrade/174162/9 "2019-04-01T14:53:09Z")

</div>

@paulsbuxton I'd highly suggest not running Kibana as `root` or using `sudo`, using a dedicated user/group to do so in Linux is highly recommended.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 29, 2019, 2:53pm UTC](https://discuss.elastic.co/t/kibana-6-7-0-broken-upgrade/174162/10 "2019-04-29T14:53:22Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
