# Kibana 6.8.8 - Monitoring Request Error

**URL:** https://discuss.elastic.co/t/kibana-6-8-8-monitoring-request-error/228574
**Category:** Kibana
**Created:** [April 17, 2020, 8:10pm UTC](https://discuss.elastic.co/t/kibana-6-8-8-monitoring-request-error/228574 "2020-04-17T20:10:38Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![jwcw](https://avatars.discourse-cdn.com/v4/letter/j/a6a055/32.png) [@jwcw](https://discuss.elastic.co/u/jwcw)
#### Post date: [April 17, 2020, 8:10pm UTC](https://discuss.elastic.co/t/kibana-6-8-8-monitoring-request-error/228574/1 "2020-04-17T20:10:39Z")

</div>

I am receiving the following error on the Monitoring page in Kibana after configuring TLS to [encrypt communications between nodes in the cluster](https://www.elastic.co/guide/en/elasticsearch/reference/6.8/configuring-tls.html#tls-transport).

> Monitoring Request Error
> 
> [transport\_exception] handshake failed because connection reset: Check the Elasticsearch Monitoring cluster network connection or the load level of the nodes.
> 
> HTTP 503

Background:  
I set up a new elasticsearch 6.8.8 cluster with a separate server running Kibana. I have 3 master nodes, 2 data nodes, and 2 coordinating nodes plus the server running Kibana.

In order to apply my license, I had to set up TLS and followed the documentation to configure. I applied the configurations to all of the elasticsearch nodes in the cluster, and only the elasticsearch nodes.

I thought perhaps I had to apply the xpack transport configurations to Kibana so I did but this caused further issues (i.e. Kibana would not start). After reviewing [this other discussion thread](https://discuss.elastic.co/t/errors-after-updating-to-6-2-4/135724/3) I see that these settings aren't supported by Kibana and I removed them (i.e. I removed the xpack.security.transport.ssl.\* lines from kibana.yml and removed the xpack keystores I created).

I'm now back where I started. Kibana starts, I can sign in, but the Monitoring page returns an HTTP 503.

I have confirmed that the cluster is healthy:

```auto
$ curl -X GET -k "https://master-0:9200/_cat/nodes?pretty"
10.10.1.5 30 86 1 0.07 0.05 0.04 di - data-0
10.10.1.10 5 95 1 0.13 0.05 0.01 i - client-1
10.10.1.7 5 95 0 0.13 0.03 0.01 mi - master-1
10.10.1.8 4 95 0 0.03 0.01 0.00 mi - master-2
10.10.1.9 5 95 1 0.00 0.02 0.00 mi * master-0
10.10.1.11 5 95 0 0.01 0.06 0.02 i - client-0
10.10.1.6 29 85 0 0.11 0.04 0.01 di - data-1
$ curl -X GET -k "https://master-0:9200/_cat/health?pretty"
1587153023 19:50:23 elasticsearch green 7 2 30 15 0 0 0 0 - 100.0%

```

What is the Elasticsearch Monitoring cluster network connection? How can I resolve this issue?

---

<div class="post-metadata">

### Author: ![jwcw](https://avatars.discourse-cdn.com/v4/letter/j/a6a055/32.png) [@jwcw](https://discuss.elastic.co/u/jwcw)
#### Post date: [April 17, 2020, 10:56pm UTC](https://discuss.elastic.co/t/kibana-6-8-8-monitoring-request-error/228574/2 "2020-04-17T22:56:31Z")

</div>

I have identified and resolve the issue.

I had added a remote cluster that was not connecting. When I removed this, the monitoring page loaded as expected.

---

<div class="post-metadata">

### Author: ![rashmi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rashmi/32/16391_2.png) [@rashmi](https://discuss.elastic.co/u/rashmi)
#### Post date: [April 19, 2020, 6:25pm UTC](https://discuss.elastic.co/t/kibana-6-8-8-monitoring-request-error/228574/3 "2020-04-19T18:25:20Z")

</div>

> [@jwcw](#):
>
> handshake failed because connection reset: Check the Elasticsearch Monitoring cluster network connection or the load level of the nodes.

Thanks for posting your solutions as well. Helps the community

thanks  
Rashmi

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [May 17, 2020, 6:25pm UTC](https://discuss.elastic.co/t/kibana-6-8-8-monitoring-request-error/228574/4 "2020-05-17T18:25:24Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
