# Kibana 6.x throws FATAL error for 'action.search.shard\_count.limit'

**URL:** <https://discuss.elastic.co/t/kibana-6-x-throws-fatal-error-for-action-search-shard-count-limit/112011>\
**Category:** Kibana\
**Created:** [December 15, 2017, 4:03pm UTC](https://discuss.elastic.co/t/kibana-6-x-throws-fatal-error-for-action-search-shard-count-limit/112011 "2017-12-15T16:03:49Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![choppa](https://avatars.discourse-cdn.com/v4/letter/c/977dab/32.png) [@choppa](https://discuss.elastic.co/u/choppa)\
**Post date:** [December 15, 2017, 4:03pm UTC](https://discuss.elastic.co/t/kibana-6-x-throws-fatal-error-for-action-search-shard-count-limit/112011/1 "2017-12-15T16:03:50Z")

</div>

I am running my own dockerized setup to install all necessary Elastic-Stack components through debian packages in a "fresh" debian container.

Elasticsearch and the indices are starting fine in version 6.x

Starting with version 6 the kibana container does not start at all and exits immediately with the following error message:

kibana | FATAL "action.search.shard\_count.limit" setting was not applied. Check for spelling errors and ensure that expected plugins are installed and enabled.  
kibana exited with code 64

Tried many things to get it starting again:

- Setting a transient action.search.shard\_count.limit
- Setting action.search.shard\_count.limit to "null"
- Backing up old .kibana indices and starting with no .kibana index in order to start "with a clean slate"

The message still shows up and I have no clue where and how this setting gets involved.  
Anything to be set in the cluster to start kibana again?

---

<div class="post-metadata">

**Author:** ![timroes](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timroes/32/19712_2.png) [@timroes](https://discuss.elastic.co/u/timroes)\
**Post date:** [December 15, 2017, 4:33pm UTC](https://discuss.elastic.co/t/kibana-6-x-throws-fatal-error-for-action-search-shard-count-limit/112011/2 "2017-12-15T16:33:49Z")

</div>

Hi,

it seems like you put a setting `action.search.shard_count.limit` into your `kibana.yml` that is unknown. In that cases Kibana refused to boot up since 6.0. You need to remove that setting from your `kibana.yml`. Then it should start up again.

Cheers,  
Tim

---

<div class="post-metadata">

**Author:** ![choppa](https://avatars.discourse-cdn.com/v4/letter/c/977dab/32.png) [@choppa](https://discuss.elastic.co/u/choppa)\
**Post date:** [December 15, 2017, 5:27pm UTC](https://discuss.elastic.co/t/kibana-6-x-throws-fatal-error-for-action-search-shard-count-limit/112011/3 "2017-12-15T17:27:47Z")

</div>

Hi Tim! 🕶

That finally brought the solution. I always checked the kibana.yml in the wrong location. The docker config included another version of the file. Thanks a lot for the quick nudge in the right direction.

Thanks,  
Christian

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 12, 2018, 5:27pm UTC](https://discuss.elastic.co/t/kibana-6-x-throws-fatal-error-for-action-search-shard-count-limit/112011/4 "2018-01-12T17:27:52Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
