# Kibana 7.0.0 - FATAL ValidationError: child "elasticsearch" fails because \["url" is not allowed\]

**URL:** <https://discuss.elastic.co/t/kibana-7-0-0-fatal-validationerror-child-elasticsearch-fails-because-url-is-not-allowed/178773>\
**Category:** Kibana\
**Created:** [April 28, 2019, 12:35am UTC](https://discuss.elastic.co/t/kibana-7-0-0-fatal-validationerror-child-elasticsearch-fails-because-url-is-not-allowed/178773 "2019-04-28T00:35:40Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![nvelumani](https://avatars.discourse-cdn.com/v4/letter/n/96bed5/32.png) [@nvelumani](https://discuss.elastic.co/u/nvelumani)\
**Post date:** [April 28, 2019, 12:35am UTC](https://discuss.elastic.co/t/kibana-7-0-0-fatal-validationerror-child-elasticsearch-fails-because-url-is-not-allowed/178773/1 "2019-04-28T00:35:40Z")

</div>

Hello Team,

I am trying to install elasticserach and kibana 7.0.0 on a new machine with Ubuntu server 18.04 on it, My elasticsearch is running fine which I was able to confirm by running "curl -X GET "192.168.x.xxx:9200" " but when try to start kibana it gives me an error as below

Apr 27 23:50:03 kibana[5105]: FATAL ValidationError: child "elasticsearch" fails because ["url" is not allowed]  
Apr 27 23:50:03 systemd[1]: kibana.service: Main process exited, code=exited, status=1/FAILURE  
Apr 27 23:50:03 systemd[1]: kibana.service: Failed with result 'exit-code'.  
Apr 27 23:50:04 systemd[1]: kibana.service: Service hold-off time over, scheduling restart.  
Apr 27 23:50:04 systemd[1]: kibana.service: Scheduled restart job, restart counter is at 3.  
Apr 27 23:50:04 systemd[1]: Stopped Kibana.  
Apr 27 23:50:04 systemd[1]: kibana.service: Start request repeated too quickly.  
Apr 27 23:50:04 systemd[1]: kibana.service: Failed with result 'exit-code'.  
Apr 27 23:50:04 systemd[1]: Failed to start Kibana.`Preformatted text`

My Kibana.yml config file as follows

server.port: 5601  
server.host: "192.168.x.xxx"  
server.name: "xxxxxxxx"  
elasticsearch.url: "[https://192.168.x.xxx:9200](https://192.168.x.xxx:9200)"  
elasticsearch.username: "kibanaserver"  
elasticsearch.password: "kibanaserver"

What am I missing? Thanks in Advance.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [April 28, 2019, 2:26am UTC](https://discuss.elastic.co/t/kibana-7-0-0-fatal-validationerror-child-elasticsearch-fails-because-url-is-not-allowed/178773/2 "2019-04-28T02:26:24Z")

</div>

> [@nvelumani](#):
>
> elasticsearch.url: "[https://192.168.x.xxx:9200](https://192.168.x.xxx:9200/)"

You want `elasticsearch.hosts` as per [Configuring Kibana | Kibana Guide [7.0] | Elastic](https://www.elastic.co/guide/en/kibana/7.0/settings.html)

---

<div class="post-metadata">

**Author:** ![nvelumani](https://avatars.discourse-cdn.com/v4/letter/n/96bed5/32.png) [@nvelumani](https://discuss.elastic.co/u/nvelumani)\
**Post date:** [April 28, 2019, 3:33pm UTC](https://discuss.elastic.co/t/kibana-7-0-0-fatal-validationerror-child-elasticsearch-fails-because-url-is-not-allowed/178773/3 "2019-04-28T15:33:20Z")

</div>

Thank You.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 26, 2019, 3:33pm UTC](https://discuss.elastic.co/t/kibana-7-0-0-fatal-validationerror-child-elasticsearch-fails-because-url-is-not-allowed/178773/4 "2019-05-26T15:33:23Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
