# Kibana 7.0.1 does not work on IPv6

**URL:** <https://discuss.elastic.co/t/kibana-7-0-1-does-not-work-on-ipv6/207937>\
**Category:** Kibana\
**Created:** [November 14, 2019, 4:42pm UTC](https://discuss.elastic.co/t/kibana-7-0-1-does-not-work-on-ipv6/207937 "2019-11-14T16:42:45Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![shivani\_aggarwal](https://avatars.discourse-cdn.com/v4/letter/s/22d042/32.png) [@shivani\_aggarwal](https://discuss.elastic.co/u/shivani_aggarwal)\
**Post date:** [November 14, 2019, 4:42pm UTC](https://discuss.elastic.co/t/kibana-7-0-1-does-not-work-on-ipv6/207937/1 "2019-11-14T16:42:45Z")

</div>

Hi,  
I am using kibana-oss (version - 7.0.1) in kubernetes environment with IPv6 environment.  
My kibana.yaml looks like this:

```
server.name: kibana
server.host: "[::0]"
server.port: 5601
elasticsearch.hosts: "http://elasticsearch:9200"

```

**Kibana pod fails to come up & shows the below error:**

```
`"{ Error: [server.host]: value is [[::0]] but it must be a valid hostname (see RFC 1123).\n at ObjectType.validate (/usr/share/kibana/node_modules/@kbn/config-schema/target/out/types/type.js:59:19)\n at ConfigService.createConfig (/usr/share/kibana/src/core/server/config/config_service.js:97:52)\n at MapSubscriber.getDistinctConfig.pipe.operators_1.map.config [as project] (/usr/share/kibana/src/core/server/config/config_service.js:51:81)\n at MapSubscriber._next (/usr/share/kibana/node_modules/rxjs/internal/operators/map.js:46:35)\n at MapSubscriber.Subscriber.next (/usr/share/kibana/node_modules/rxjs/internal/Subscriber.js:64:18)\n at DistinctUntilChangedSubscriber._next (/usr/share/kibana
/node_modules/rxjs/internal/operators/distinctUntilChanged.js:65:30)\n at DistinctUntilChangedSubscriber.Subscriber.next (/usr/share/kibana/node_modules/rxjs/internal/Subscriber.js:64:18)\n at MapSubscriber._next (/usr/share/kibana/node_modules/rxjs/internal/operators/map.js:52:26)\n at MapSubscriber.Subscriber.next (/usr/share/kibana/node_modules/rxjs/internal/Subscriber.js:64:18)\n at MapSubscriber._next (/usr/share/kibana/node_modules/rxjs/internal/operators/map.js:52:26)\n cause:\n { Error: value is [[::0]] but it must be a valid hostname (see RFC 1123).\n at StringType.onError (/usr/share/kibana/node_modules/@kbn/config-schema/target/out/types/type.js:84:20)\n at type.Type.schema.error (/usr/share/kibana/node_modules/@kbn/config-schema/target/out/types/type.js:49:53)\n at finish (/usr/share/kibana/node_modules/joi/lib/types/any/index.js:529:50)\n at type._validate (/usr/share/kibana/node_modules/joi/lib/types/any/index.js:656:28)\n at type._base (/usr/share/kibana/node_modules/joi/lib/types/object/index.js:212:45)\n at type._validate (/usr/share/kibana/node_modules/joi/lib/types/any/index.js:614:37)\n at type._validateWithOptions (/usr/share/kibana/node_modules/joi/lib/types/any/index.js:674:29)\n at module.exports.internals.Any.root.validate (/usr/share/kibana/node_modules/joi/lib/index.js:146:23)\n at ObjectType.validate (/usr/share/kibana/node_modules/@kbn/config-schema/target/out/types/type.js:54:72)\n at ConfigService.createConfig (/usr/share/kibana/src/core/server/config/config_service.js:97:52) cause: undefined, path: ['host'] } }"`

```

I see same error for server.host configured as "[::]", "[::1]".

Can you please tell me the right configuration for this in an IPv6 environment?  
Thanks,  
Shivani

---

<div class="post-metadata">

**Author:** ![rashmi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rashmi/32/16391_2.png) [@rashmi](https://discuss.elastic.co/u/rashmi)\
**Post date:** [November 14, 2019, 5:11pm UTC](https://discuss.elastic.co/t/kibana-7-0-1-does-not-work-on-ipv6/207937/2 "2019-11-14T17:11:45Z")

</div>

@jbudz/@tylersmalley - any ideas here ?

Thanks  
Rashmi

---

<div class="post-metadata">

**Author:** ![shivani\_aggarwal](https://avatars.discourse-cdn.com/v4/letter/s/22d042/32.png) [@shivani\_aggarwal](https://discuss.elastic.co/u/shivani_aggarwal)\
**Post date:** [November 19, 2019, 5:01am UTC](https://discuss.elastic.co/t/kibana-7-0-1-does-not-work-on-ipv6/207937/3 "2019-11-19T05:01:57Z")

</div>

@jbudz/@tylersmalley - Can you please tell me the right configuration for kibana server.host parameter in IPv6 environment?

---

<div class="post-metadata">

**Author:** ![rashmi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rashmi/32/16391_2.png) [@rashmi](https://discuss.elastic.co/u/rashmi)\
**Post date:** [December 12, 2019, 5:39pm UTC](https://discuss.elastic.co/t/kibana-7-0-1-does-not-work-on-ipv6/207937/4 "2019-12-12T17:39:52Z")

</div>

[This issue talks about the server not binding to the IPv6 localhost address](https://github.com/elastic/kibana/issues/23431), but that's a difference use case, you're setting the host to the IPv6 address.

It may be related to [this addressing fix](https://github.com/elastic/kibana/pull/29891) which looks like will be part of v7.0.0 of the stack.

---

<div class="post-metadata">

**Author:** ![shivani\_aggarwal](https://avatars.discourse-cdn.com/v4/letter/s/22d042/32.png) [@shivani\_aggarwal](https://discuss.elastic.co/u/shivani_aggarwal)\
**Post date:** [December 14, 2019, 3:07pm UTC](https://discuss.elastic.co/t/kibana-7-0-1-does-not-work-on-ipv6/207937/5 "2019-12-14T15:07:47Z")

</div>

I am using kibana-oss-7.0.1. **Not sure if the mentioned fix is available in this rpm**.  
I was able to proceed by configuring "server.host" with the hostname instead of IP address.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 11, 2020, 3:07pm UTC](https://discuss.elastic.co/t/kibana-7-0-1-does-not-work-on-ipv6/207937/6 "2020-01-11T15:07:56Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
