# Kibana 7.10 - Error connecting to package registry

**URL:** <https://discuss.elastic.co/t/kibana-7-10-error-connecting-to-package-registry/256701>\
**Category:** Kibana\
**Created:** [November 25, 2020, 6:36pm UTC](https://discuss.elastic.co/t/kibana-7-10-error-connecting-to-package-registry/256701 "2020-11-25T18:36:31Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![teej](https://avatars.discourse-cdn.com/v4/letter/t/b5a626/32.png) [@teej](https://discuss.elastic.co/u/teej)\
**Post date:** [November 25, 2020, 6:36pm UTC](https://discuss.elastic.co/t/kibana-7-10-error-connecting-to-package-registry/256701/1 "2020-11-25T18:36:32Z")

</div>

Currently running Kibana 7.10 and the logs are getting filled with the following message:

> "error","plugins","ingestManager"],"pid":11460,"message":"Error connecting to package registry: request to [https://epr.elastic.co/search?category=security&kibana.version=7.10.0](https://epr.elastic.co/search?category=security&kibana.version=7.10.0) failed, reason: connect ETIMEDOUT 151.101.66.217:443"}

I found that this may be the cause:

> In order to install Integrations, the Fleet app needs to connect to an external service called the Elastic Package Registry. For this to work, the Kibana server must be able to connect to [https://epr.elastic.co](https://epr.elastic.co) on port 443

But what if its a cluster thats not connected to the Internet?

.

---

<div class="post-metadata">

**Author:** ![ropc](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ropc/32/47022_2.png) [@ropc](https://discuss.elastic.co/u/ropc)\
**Post date:** [November 26, 2020, 2:57am UTC](https://discuss.elastic.co/t/kibana-7-10-error-connecting-to-package-registry/256701/2 "2020-11-26T02:57:03Z")

</div>

Hi @teej - I am afraid that this is a current limitation in the product and it is documented [here](https://www.elastic.co/guide/en/fleet/current/fleet-limitations.html):

- `Requires internet access for Kibana to download integration packages`

Our development team is looking into this and you can subscribe to the related [Github issue](https://github.com/elastic/kibana/issues/77333) for further updates.

There is actually a workaround proposed by our developer in this [comment](https://github.com/elastic/kibana/issues/77333#issue-701061565) but this approach should only be used for development and it is not supported.

I hope that answers your question.

---

<div class="post-metadata">

**Author:** ![teej](https://avatars.discourse-cdn.com/v4/letter/t/b5a626/32.png) [@teej](https://discuss.elastic.co/u/teej)\
**Post date:** [November 26, 2020, 4:53am UTC](https://discuss.elastic.co/t/kibana-7-10-error-connecting-to-package-registry/256701/3 "2020-11-26T04:53:15Z")

</div>

Hi Ropc  
Yes, that is very helpful. Thank you very much. I look forward to seeing how they fix that. It sometimes feels that Elastic is trying to be too many things to too many people.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 24, 2020, 4:53am UTC](https://discuss.elastic.co/t/kibana-7-10-error-connecting-to-package-registry/256701/4 "2020-12-24T04:53:35Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
