# Kibana 7.11.2 fails to start post upgrade

**URL:** https://discuss.elastic.co/t/kibana-7-11-2-fails-to-start-post-upgrade/266926
**Category:** Kibana
**Created:** [March 11, 2021, 10:42am UTC](https://discuss.elastic.co/t/kibana-7-11-2-fails-to-start-post-upgrade/266926 "2021-03-11T10:42:04Z")
**Posts on this page:** 8
**Page:** 1

<div class="post-metadata">

### Author: ![parthmaniar](https://avatars.discourse-cdn.com/v4/letter/p/71e660/32.png) [@parthmaniar](https://discuss.elastic.co/u/parthmaniar)
#### Post date: [March 11, 2021, 10:42am UTC](https://discuss.elastic.co/t/kibana-7-11-2-fails-to-start-post-upgrade/266926/1 "2021-03-11T10:42:04Z")

</div>

I just upgraded my stack to 7.11.2 and kibana is not starting. My elasticsearch status is green. I have rebooted the host and the problem persists.

```auto
Mar 11 09:59:01 hostname systemd[1]: kibana.service: State 'stop-sigterm' timed out. Killing.
Mar 11 09:59:01 hostname systemd[1]: kibana.service: Killing process 2645 (node) with signal SIGKILL.
Mar 11 09:59:01 hostname systemd[1]: kibana.service: Killing process 2669 (node) with signal SIGKILL.
Mar 11 09:59:01 hostname systemd[1]: kibana.service: Killing process 2670 (node) with signal SIGKILL.
Mar 11 09:59:01 hostname systemd[1]: kibana.service: Killing process 2671 (node) with signal SIGKILL.
Mar 11 09:59:01 hostname systemd[1]: kibana.service: Killing process 2672 (node) with signal SIGKILL.
Mar 11 09:59:01 hostname systemd[1]: kibana.service: Killing process 2673 (node) with signal SIGKILL.
Mar 11 09:59:01 hostname systemd[1]: kibana.service: Killing process 2674 (n/a) with signal SIGKILL.
Mar 11 09:59:01 hostname systemd[1]: kibana.service: Killing process 2676 (n/a) with signal SIGKILL.
Mar 11 09:59:01 hostname systemd[1]: kibana.service: Killing process 2677 (n/a) with signal SIGKILL.
Mar 11 09:59:01 hostname systemd[1]: kibana.service: Killing process 2678 (n/a) with signal SIGKILL.
Mar 11 09:59:01 hostname systemd[1]: kibana.service: Main process exited, code=killed, status=9/KILL
Mar 11 09:59:01 hostname systemd[1]: kibana.service: Failed with result 'timeout'.

```

Following are the last set of logs from kibana.log

```auto
{"type":"log","@timestamp":"2021-03-11T10:08:12+00:00","tags":["info","savedobjects-service"],"pid":3271,"message":"Starting saved objects migrations"}
{"type":"log","@timestamp":"2021-03-11T10:08:12+00:00","tags":["info","savedobjects-service"],"pid":3271,"message":"Creating index .kibana_7."}
{"type":"log","@timestamp":"2021-03-11T10:08:12+00:00","tags":["warning","savedobjects-service"],"pid":3271,"message":"Unable to connect to Elasticsearch. Error: resource_already_exists_exception"}
{"type":"log","@timestamp":"2021-03-11T10:08:12+00:00","tags":["warning","savedobjects-service"],"pid":3271,"message":"Another Kibana instance appears to be migrating the index. Waiting for that migration to complete. If no other Kibana instance is attempting migrations, you can get past this message by deleting index .kibana_7 and restarting Kibana."}

```

There is no other Kibana instance that is operational in the cluster. What is the best way to get the system online?

---

<div class="post-metadata">

### Author: ![rashmi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rashmi/32/16391_2.png) [@rashmi](https://discuss.elastic.co/u/rashmi)
#### Post date: [March 12, 2021, 6:29pm UTC](https://discuss.elastic.co/t/kibana-7-11-2-fails-to-start-post-upgrade/266926/2 "2021-03-12T18:29:42Z")

</div>

> [@parthmaniar](#):
>
> `deleting index .kibana_7 and restarting Kibana."}`

Have u tried `deleting index .kibana_7 and restarting Kibana` ? Try this and let us know if it works .

Rashmi

---

<div class="post-metadata">

### Author: ![parthmaniar](https://avatars.discourse-cdn.com/v4/letter/p/71e660/32.png) [@parthmaniar](https://discuss.elastic.co/u/parthmaniar)
#### Post date: [March 12, 2021, 6:50pm UTC](https://discuss.elastic.co/t/kibana-7-11-2-fails-to-start-post-upgrade/266926/3 "2021-03-12T18:50:19Z")

</div>

Yes that is how I got Kibana to work. Is there a way to diagnose what happened and how this can be avoided?

---

<div class="post-metadata">

### Author: ![cheiligers](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cheiligers/32/73114_2.png) [@cheiligers](https://discuss.elastic.co/u/cheiligers)
#### Post date: [March 15, 2021, 4:52pm UTC](https://discuss.elastic.co/t/kibana-7-11-2-fails-to-start-post-upgrade/266926/4 "2021-03-15T16:52:52Z")

</div>

@parthmaniar The last set of logs leads up to the problem that caused Kibana to not start and the reason was that there was an issue with migrating saved objects (visualizations, saved searches etc).  
You can try using [verbose logging](https://www.elastic.co/guide/en/kibana/current/settings.html#logging-verbose) to get a lot more info from the logs.

---

<div class="post-metadata">

### Author: ![rudolf](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rudolf/32/51200_2.png) [@rudolf](https://discuss.elastic.co/u/rudolf)
#### Post date: [March 15, 2021, 6:47pm UTC](https://discuss.elastic.co/t/kibana-7-11-2-fails-to-start-post-upgrade/266926/5 "2021-03-15T18:47:20Z")

</div>

See [Upgrade migrations | Kibana Guide [7.11] | Elastic](https://www.elastic.co/guide/en/kibana/current/upgrade-migrations.html#_retry_a_migration_by_restoring_a_backup_snapshot) for more information about the process and ways to avoid errors.

The first time an upgrade fails Kibana will log a fatal error, this is the root cause. Your logs show subsequent Kibana instances noticing another instance has already started an attempt and then simply waiting for the migration to complete.

---

<div class="post-metadata">

### Author: ![parthmaniar](https://avatars.discourse-cdn.com/v4/letter/p/71e660/32.png) [@parthmaniar](https://discuss.elastic.co/u/parthmaniar)
#### Post date: [March 16, 2021, 5:53pm UTC](https://discuss.elastic.co/t/kibana-7-11-2-fails-to-start-post-upgrade/266926/6 "2021-03-16T17:53:51Z")

</div>

Thank you very much. I will play with this next time 🙂

---

<div class="post-metadata">

### Author: ![parthmaniar](https://avatars.discourse-cdn.com/v4/letter/p/71e660/32.png) [@parthmaniar](https://discuss.elastic.co/u/parthmaniar)
#### Post date: [March 16, 2021, 5:55pm UTC](https://discuss.elastic.co/t/kibana-7-11-2-fails-to-start-post-upgrade/266926/7 "2021-03-16T17:55:11Z")

</div>

Thank you very much. Noted. I did find different configuration between Kibana instances which may have caused the issue. I'll note my experience during the next update.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [April 13, 2021, 5:55pm UTC](https://discuss.elastic.co/t/kibana-7-11-2-fails-to-start-post-upgrade/266926/8 "2021-04-13T17:55:54Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
