# Kibana 7.2 not coming up on CentOS 7

**URL:** <https://discuss.elastic.co/t/kibana-7-2-not-coming-up-on-centos-7/191483>\
**Category:** Kibana\
**Created:** [July 20, 2019, 1:02pm UTC](https://discuss.elastic.co/t/kibana-7-2-not-coming-up-on-centos-7/191483 "2019-07-20T13:02:53Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![vinodres](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/vinodres/32/50379_2.png) [@vinodres](https://discuss.elastic.co/u/vinodres)\
**Post date:** [July 20, 2019, 1:02pm UTC](https://discuss.elastic.co/t/kibana-7-2-not-coming-up-on-centos-7/191483/1 "2019-07-20T13:02:53Z")

</div>

I am just trying to installing Kibana and running into some issues.

I initially ran into some issue installing ElasticSeaerch, but that issue is now resolved. Please refer to below post for what I did to resolve it.

> [@Elasticsearch 7.2 not starting on CentOS 7 because of xpack.security.enabled setting](https://discuss.elastic.co/t/elasticsearch-7-2-not-starting-on-centos-7-because-of-xpack-security-enabled-setting/191055):
>
> I have just installed ElasticSearch 7.2 OSS (rpm) using Ansible 2.8.2 on a CentOS 7 POC server. The Ansible playbook ran successfully. I used following path to download it [https://artifacts.elastic.co/downloads/elasticsearch/elasticsearch-oss-7.2.0-x86\_64.rpm](https://artifacts.elastic.co/downloads/elasticsearch/elasticsearch-oss-7.2.0-x86_64.rpm) When I checked the status of elasticsearch.service, it is not in a running state. [user1@devsrv001 ~] systemctl status elasticsearch.service ● elasticsearch.service - Elasticsearch Loaded: loaded (/usr/lib/systemd/system/elasticsea…

I am installing Kibana 7.2 Basic on CentOS 7 using Ansible. Looks like installation is successful. Also when I checked the status of Kibana using  
systemctl status kibana.service, it said, Kibana is running

> [devsrv001: SU: logs 58] systemctl status kibana.service  
> ● kibana.service - Kibana  
> Loaded: loaded (/etc/systemd/system/kibana.service; enabled; vendor preset: disabled)  
> Active: active (running) since Sat 2019-07-20 08:48:35 EDT; 27s ago  
> Main PID: 10698 (node)  
> CGroup: /system.slice/kibana.service  
> └─10698 /usr/share/kibana/bin/../node/bin/node --no-warnings --max-http-header-size=65536 /usr/share/kibana/bin/../src/cli -c /etc/kibana/kibana.yml
> 
> Jul 20 08:48:44 devsrv001 kibana[10698]: {"type":"log","@timestamp":"2019-07-20T12:48:44Z","tags":["status","plugin:index\_management@7.2.0","error"],"pid":10698,"state":"red","message":"Status changed fr...  
> Jul 20 08:48:44 devsrv001 kibana[10698]: {"type":"log","@timestamp":"2019-07-20T12:48:44Z","tags":["status","plugin:index\_lifecycle\_management@7.2.0","error"],"pid":10698,"state":"red","message":"Status ...  
> Jul 20 08:48:44 devsrv001 kibana[10698]: {"type":"log","@timestamp":"2019-07-20T12:48:44Z","tags":["status","plugin:rollup@7.2.0","error"],"pid":10698,"state":"red","message":"Status changed from yellow ...  
> Jul 20 08:48:44 devsrv001 kibana[10698]: {"type":"log","@timestamp":"2019-07-20T12:48:44Z","tags":["status","plugin:remote\_clusters@7.2.0","error"],"pid":10698,"state":"red","message":"Status changed fro...  
> Jul 20 08:48:44 devsrv001 kibana[10698]: {"type":"log","@timestamp":"2019-07-20T12:48:44Z","tags":["status","plugin:cross\_cluster\_replication@7.2.0","error"],"pid":10698,"state":"red","message":"Status c...  
> Jul 20 08:48:44 devsrv001 kibana[10698]: {"type":"log","@timestamp":"2019-07-20T12:48:44Z","tags":["status","plugin:snapshot\_restore@7.2.0","error"],"pid":10698,"state":"red","message":"Status changed fr...  
> Jul 20 08:48:45 devsrv001 kibana[10698]: {"type":"log","@timestamp":"2019-07-20T12:48:45Z","tags":["reporting","browser-driver","warning"],"pid":10698,"message":"Enabling the Chromium sandb... protection."}  
> Jul 20 08:48:45 devsrv001 kibana[10698]: {"type":"log","@timestamp":"2019-07-20T12:48:45Z","tags":["reporting","warning"],"pid":10698,"message":"Generating a random key for xpack.reporting....n kibana.yml"}  
> Jul 20 08:48:45 devsrv001 kibana[10698]: {"type":"log","@timestamp":"2019-07-20T12:48:45Z","tags":["status","plugin:reporting@7.2.0","error"],"pid":10698,"state":"red","message":"Status changed from unin...  
> Jul 20 08:48:45 devsrv001 kibana[10698]: {"type":"log","@timestamp":"2019-07-20T12:48:45Z","tags":["status","plugin:security@7.2.0","error"],"pid":10698,"state":"red","message":"Status chan...vMsg":"Ready"}  
> Hint: Some lines were ellipsized, use -l to show in full.

But when I try to check kibana status  
[http://devsrv001:5601/api/status](http://devsrv001:5601/api/status)

I am receiving

> Kibana server is not ready yet

I tried to look for logs and see a bunch of errors in /srchdata/elasticsearch/cf-dev-clusterlog

> [2019-07-20T08:27:12,995][DEBUG][o.e.a.a.i.g.TransportGetIndexAction] [cf-node-devsrv001] timed out while retrying [indices:admin/get] after failure (timeout [30s])  
> [2019-07-20T08:27:12,995][WARN][r.suppressed] [cf-node-devsrv001] path: /.kibana, params: {index=.kibana}  
> org.elasticsearch.discovery.MasterNotDiscoveredException: null  
> at org.elasticsearch.action.support.master.TransportMasterNodeAction$AsyncSingleAction$3.onTimeout(TransportMasterNodeAction.java:251) [elasticsearch-7.2.0.jar:7.2.0]  
> at org.elasticsearch.cluster.ClusterStateObserver$ContextPreservingListener.onTimeout(ClusterStateObserver.java:325) [elasticsearch-7.2.0.jar:7.2.0]  
> at org.elasticsearch.cluster.ClusterStateObserver$ObserverClusterStateListener.onTimeout(ClusterStateObserver.java:252) [elasticsearch-7.2.0.jar:7.2.0]  
> at org.elasticsearch.cluster.service.ClusterApplierService$NotifyTimeout.run(ClusterApplierService.java:572) [elasticsearch-7.2.0.jar:7.2.0]  
> at org.elasticsearch.common.util.concurrent.ThreadContext$ContextPreservingRunnable.run(ThreadContext.java:688) [elasticsearch-7.2.0.jar:7.2.0]  
> at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128) [?:?]  
> at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628) [?:?]  
> at java.lang.Thread.run(Thread.java:835) [?:?]  
> [2019-07-20T08:27:15,992][DEBUG][o.e.a.a.i.t.g.TransportGetIndexTemplatesAction] [cf-node-devsrv001] timed out while retrying [indices:admin/template/get] after failure (timeout [30s])

Just fyi: /srchdata is an extra disk I have mounted and pointed the index and logs to that location

Can you please help me understand what am I doing wrong? Really appreciate any assistance. I am trying to install Elasticsearch and Kibana for the first time.

---

<div class="post-metadata">

**Author:** ![vinodres](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/vinodres/32/50379_2.png) [@vinodres](https://discuss.elastic.co/u/vinodres)\
**Post date:** [July 20, 2019, 9:03pm UTC](https://discuss.elastic.co/t/kibana-7-2-not-coming-up-on-centos-7/191483/2 "2019-07-20T21:03:40Z")

</div>

After diving thru documentation, I noticed that to start a cluster for the first time, cluster.initial\_master\_nodes should be set. Now both elasticsearch and kibana are up and running. Now I need to figure out how to enable authentication.

here is the documentation.  
[https://www.elastic.co/guide/en/elasticsearch/reference/current/modules-discovery-bootstrap-cluster.html](https://www.elastic.co/guide/en/elasticsearch/reference/current/modules-discovery-bootstrap-cluster.html)

---

<div class="post-metadata">

**Author:** ![bhavyarm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bhavyarm/32/22392_2.png) [@bhavyarm](https://discuss.elastic.co/u/bhavyarm)\
**Post date:** [July 22, 2019, 1:14pm UTC](https://discuss.elastic.co/t/kibana-7-2-not-coming-up-on-centos-7/191483/3 "2019-07-22T13:14:05Z")

</div>

Thanks for keeping us posted.

Bhavya

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 19, 2019, 1:14pm UTC](https://discuss.elastic.co/t/kibana-7-2-not-coming-up-on-centos-7/191483/4 "2019-08-19T13:14:09Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
