Kibana 7.4 Status: Red

Hi, I recently tried to install Elasticsearch and Kibana 7.4. After starting both, I am receiving the following Red status on Kibana console.

The error message is saying "This version of Kibana requires Elasticsearch v6.1.2 on all nodes. I found the following incompatible nodes in your cluster: v7.4.0 @ 127.0.0.1:9200 (127.0.0.1)" but I downloaded 7.4.

Can someone help me fix this issue? Thanks in advance. :slight_smile:

Regards,
Julius

Hi
From the error message it clearly says that all the products need to be on the same version. I guess there is an old version of Elasticsearch still running somewhere. Can you shut down all the node/ services and bring it up. Also the logs give some important information. It should be in /var/log/elasticsearch . Failing that, look in the system logs perhaps?
You can also check the version of ES running by curl -XGET 'localhost:9200'

Hope this helps
Rashmi

Hi Rashmi,

Thank you for your reply. I have now found out the issue. Apparently, I have another application running and its using elastic stack as a built in logging functionality.

Regards,
Julius