# KIBANA 7.6.0 - FATAL TypeError: Cannot read property 'length' of undefined

**URL:** <https://discuss.elastic.co/t/kibana-7-6-0-fatal-typeerror-cannot-read-property-length-of-undefined/220910>\
**Category:** Kibana\
**Created:** [February 25, 2020, 6:29pm UTC](https://discuss.elastic.co/t/kibana-7-6-0-fatal-typeerror-cannot-read-property-length-of-undefined/220910 "2020-02-25T18:29:29Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![jessicalh](https://avatars.discourse-cdn.com/v4/letter/j/6de8d8/32.png) [@jessicalh](https://discuss.elastic.co/u/jessicalh)\
**Post date:** [February 25, 2020, 6:29pm UTC](https://discuss.elastic.co/t/kibana-7-6-0-fatal-typeerror-cannot-read-property-length-of-undefined/220910/1 "2020-02-25T18:29:30Z")

</div>

**Kibana version:** 7.6.0

**Elasticsearch version:** 7.6.0

**Server OS version:** Centos 7

**Original install method (e.g. download page, yum, from source, etc.):** YUM

**Describe the bug:**  
After the elk update from version 7.5 to version 7.6, the kibana service does not run, and the only log I have tells me the following.

Could you please help me?

```
Feb 25 12:03:56 elk1.tekium.int systemd[1]: **Unit kibana.service entered failed state.**
Feb 25 12:03:56 elk1.tekium.int systemd[1]: **kibana.service failed.**
Feb 25 12:04:00 elk1.tekium.int systemd[1]: kibana.service holdoff time over, scheduling restart.
Feb 25 12:04:00 elk1.tekium.int systemd[1]: Stopped Kibana.
-- Subject: Unit kibana.service has finished shutting down
-- Defined-By: systems
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- Unit kibana.service has finished shutting down.
Feb 25 12:04:00 elk1.tekium.int systemd[1]: Started Kibana.
-- Subject: Unit kibana.service has finished start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit kibana.service has finished starting up.
--
-- The start-up result is done.
Feb 25 12:04:02 elk1.tekium.int kibana[1630]: {"type":"log","@timestamp":"2020-02-25T18:04:02Z","tags":["info","plugins-service"],"pid":1630,"message":"Plugin \"case\" is disabled."}
Feb 25 12:04:03 elk1.tekium.int kibana[1630]: {"type":"log","@timestamp":"2020-02-25T18:04:03Z","tags":["fatal","root"],"pid":1630,"message":"TypeError: Cannot read property 'length' of undefined\n at
Feb 25 12:04:03 elk1.tekium.int kibana[1630]: FATAL TypeError: Cannot read property 'length' of undefined
Feb 25 12:04:03 elk1.tekium.int systemd[1]: **kibana.service: main process exited, code=exited, status=1/FAILURE**
Feb 25 12:04:03 elk1.tekium.int systemd[1]: **Unit kibana.service entered failed state.**
Feb 25 12:04:03 elk1.tekium.int systemd[1]: **kibana.service failed.**
Feb 25 12:04:06 elk1.tekium.int systemd[1]: kibana.service holdoff time over, scheduling restart.
Feb 25 12:04:06 elk1.tekium.int systemd[1]: Stopped Kibana.
-- Subject: Unit kibana.service has finished shutting down
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit kibana.service has finished shutting down.
Feb 25 12:04:06 elk1.tekium.int systemd[1]: Started Kibana.
-- Subject: Unit kibana.service has finished start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit kibana.service has finished starting up.
```

---

<div class="post-metadata">

**Author:** ![rudolf](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rudolf/32/51200_2.png) [@rudolf](https://discuss.elastic.co/u/rudolf)\
**Post date:** [February 25, 2020, 6:51pm UTC](https://discuss.elastic.co/t/kibana-7-6-0-fatal-typeerror-cannot-read-property-length-of-undefined/220910/2 "2020-02-25T18:51:05Z")

</div>

The following log message seems to be cut off

> "TypeError: Cannot read property 'length' of undefined\n at

Can you post the entire log line? There should be a stack trace which might help pinpoint the problem.

Regards,

---

<div class="post-metadata">

**Author:** ![jessicalh](https://avatars.discourse-cdn.com/v4/letter/j/6de8d8/32.png) [@jessicalh](https://discuss.elastic.co/u/jessicalh)\
**Post date:** [February 25, 2020, 7:01pm UTC](https://discuss.elastic.co/t/kibana-7-6-0-fatal-typeerror-cannot-read-property-length-of-undefined/220910/3 "2020-02-25T19:01:43Z")

</div>

Sorry! Here is the full log.

```
Feb 25 12:58:37 elk1.tekium.int kibana[1835]: {"type":"log","@timestamp":"2020-02-25T18:58:37Z","tags":["info","plugins-service"],"pid":1835,"message":"Plugin \"case\" is disabled."}
Feb 25 12:58:38 elk1.tekium.int kibana[1835]: {"type":"log","@timestamp":"2020-02-25T18:58:38Z","tags":["fatal","root"],"pid":1835,"message":"TypeError: Cannot read property 'length' of undefined\n at Object.<anonymous> (/usr/share/kibana/node_modules/del/node_modules/fast-glob/out/settings.js:5:28)\n at Module._compile (internal/modules/cjs/loader.js:778:30)\n at Module._compile (/usr/share/kibana/node_modules/pirates/lib/index.js:99:24)\n at Module._extensions..js (internal/modules/cjs/loader.js:789:10)\n at Object.newLoader [as .js] (/usr/share/kibana/node_modules/pirates/lib/index.js:104:7)\n at Module.load (internal/modules/cjs/loader.js:653:32)\n at tryModuleLoad (internal/modules/cjs/loader.js:593:12)\n at Function.Module._load (internal/modules/cjs/loader.js:585:3)\n at Module.require (internal/modules/cjs/loader.js:692:17)\n at require (internal/modules/cjs/helpers.js:25:18)\n at Object.<anonymous> (/usr/share/kibana/node_modules/del/node_modules/fast-glob/out/index.js:6:20)\n at Module._compile (internal/modules/cjs/loader.js:778:30)\n at Module._compile (/usr/share/kibana/node_modules/pirates/lib/index.js:99:24)\n at Module._extensions..js (internal/modules/cjs/loader.js:789:10)\n at Object.newLoader [as .js] (/usr/share/kibana/node_modules/pirates/lib/index.js:104:7)\n at Module.load (internal/modules/cjs/loader.js:653:32)"}
Feb 25 12:58:38 elk1.tekium.int kibana[1835]: FATAL TypeError: Cannot read property 'length' of undefined
Feb 25 12:58:38 elk1.tekium.int systemd[1]: kibana.service: main process exited, code=exited, status=1/FAILURE
Feb 25 12:58:38 elk1.tekium.int systemd[1]: Unit kibana.service entered failed state.
Feb 25 12:58:38 elk1.tekium.int systemd[1]: kibana.service failed.
Feb 25 12:58:41 elk1.tekium.int systemd[1]: kibana.service holdoff time over, scheduling restart.
Feb 25 12:58:41 elk1.tekium.int systemd[1]: Stopped Kibana.
-- Subject: Unit kibana.service has finished shutting down
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit kibana.service has finished shutting down.
Feb 25 12:58:41 elk1.tekium.int systemd[1]: Started Kibana.
-- Subject: Unit kibana.service has finished start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit kibana.service has finished starting up.
-- 
-- The start-up result is done.
```

---

<div class="post-metadata">

**Author:** ![rudolf](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rudolf/32/51200_2.png) [@rudolf](https://discuss.elastic.co/u/rudolf)\
**Post date:** [February 27, 2020, 3:06pm UTC](https://discuss.elastic.co/t/kibana-7-6-0-fatal-typeerror-cannot-read-property-length-of-undefined/220910/4 "2020-02-27T15:06:45Z")

</div>

Unfortunately that stack trace isn't very helpful. It appears as if it's an error in a dependency we use to delete files.

Can you run Kibana with `--verbose` and post the logs?

---

<div class="post-metadata">

**Author:** ![jessicalh](https://avatars.discourse-cdn.com/v4/letter/j/6de8d8/32.png) [@jessicalh](https://discuss.elastic.co/u/jessicalh)\
**Post date:** [March 12, 2020, 4:16pm UTC](https://discuss.elastic.co/t/kibana-7-6-0-fatal-typeerror-cannot-read-property-length-of-undefined/220910/5 "2020-03-12T16:16:17Z")

</div>

Hi Rudolf!

I had to delete the cluster because it was installed on LXC, and there was no way to recover the cluster.  
Fortunately, it was only a testing environment.

I have installed the 7.6 version on centos in a virtual machine, and I haven't had an issue.

Thanks for your support.

---

<div class="post-metadata">

**Author:** ![rudolf](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rudolf/32/51200_2.png) [@rudolf](https://discuss.elastic.co/u/rudolf)\
**Post date:** [March 12, 2020, 7:52pm UTC](https://discuss.elastic.co/t/kibana-7-6-0-fatal-typeerror-cannot-read-property-length-of-undefined/220910/6 "2020-03-12T19:52:23Z")

</div>

Good to hear that you came right 🙂

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 9, 2020, 7:52pm UTC](https://discuss.elastic.co/t/kibana-7-6-0-fatal-typeerror-cannot-read-property-length-of-undefined/220910/7 "2020-04-09T19:52:34Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
