# Kibana 7.8 won't start

**URL:** https://discuss.elastic.co/t/kibana-7-8-wont-start/241336
**Category:** Kibana
**Created:** [July 15, 2020, 4:44pm UTC](https://discuss.elastic.co/t/kibana-7-8-wont-start/241336 "2020-07-15T16:44:30Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![Amphagory](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/amphagory/32/46127_2.png) [@Amphagory](https://discuss.elastic.co/u/Amphagory)
#### Post date: [July 15, 2020, 4:44pm UTC](https://discuss.elastic.co/t/kibana-7-8-wont-start/241336/1 "2020-07-15T16:44:30Z")

</div>

Hello,

I seen similar issues to mine on this forum and other sites (i.e. stack overflow), but no concrete solution. I thought I would post it again and see if someone has a solution now.

I am unable to start Kibana:

AWS t2.medium EC2 instance running Amazon Linux 2 AMI  
Elasticsearch Version: 7.8  
Kibana Version: kibana-7.8

kibana.yml file:  
server.host: "0.0.0.0"  
elasticsearch.hosts: ["https://ELASTICSEARCH\_MANAGED\_SERVICE:9243"]  
elasticsearch.username: "elastic"  
elasticsearch.password: "SECRET"  
xpack.reporting.encryptionKey: "PRIVATE"

Status:

```auto
[ec2-user@ip-172-31-22-249 infra]$ sudo systemctl status kibana.service
● kibana.service - Kibana
   Loaded: loaded (/etc/systemd/system/kibana.service; enabled; vendor preset: disabled)
   Active: active (running) since Wed 2020-07-15 16:34:12 UTC; 10s ago
 Main PID: 19313 (node)
   CGroup: /system.slice/kibana.service
           └─19313 /usr/share/kibana/bin/../node/bin/node /usr/share/kibana/bin/../src/cli

Jul 15 16:34:12 ip-172-31-22-249.us-west-1.compute.internal systemd[1]: Started Kibana.
Jul 15 16:34:12 ip-172-31-22-249.us-west-1.compute.internal systemd[1]: Starting Kibana...
Jul 15 16:34:16 ip-172-31-22-249.us-west-1.compute.internal kibana[19313]: {"type":"log","@timestamp":"2020-07-15T16:33:46Z","tags":["warning","plugins-discovery"],"pid":19275,"message":"Expect plugin \"id\" in camelCase, but found: apm_oss"}

Jul 15 16:34:16 ip-172-31-22-249.us-west-1.compute.internal kibana[19313]: {"type":"log","@timestamp":"2020-07-15T16:33:46Z","tags":["warning","plugins-discovery"],"pid":19275,"message":"Expect plugin \"id\" in camelCase, but found: triggers_actions_ui"}

Hint: Some lines were ellipsized, use -l to show in full.

[ec2-user@ip-172-31-22-249 infra]$ sudo systemctl status-l kibana.service 
● kibana.service - Kibana
   Loaded: loaded (/etc/systemd/system/kibana.service; enabled; vendor preset: disabled)
   Active: failed (Result: start-limit) since Wed 2020-07-15 16:34:27 UTC; 8min ago
  Process: 19313 ExecStart=/usr/share/kibana/bin/kibana (code=exited, status=1/FAILURE)
 Main PID: 19313 (code=exited, status=1/FAILURE)

Jul 15 16:34:24 ip-172-31-22-249.us-west-1.compute.internal systemd[1]: Unit kibana.service entered failed state.
Jul 15 16:34:24 ip-172-31-22-249.us-west-1.compute.internal systemd[1]: kibana.service failed.
Jul 15 16:34:27 ip-172-31-22-249.us-west-1.compute.internal systemd[1]: kibana.service holdoff time over, scheduling restart.
Jul 15 16:34:27 ip-172-31-22-249.us-west-1.compute.internal systemd[1]: start request repeated too quickly for kibana.service
Jul 15 16:34:27 ip-172-31-22-249.us-west-1.compute.internal systemd[1]: Failed to start Kibana.
Jul 15 16:34:27 ip-172-31-22-249.us-west-1.compute.internal systemd[1]: Unit kibana.service entered failed state.
Jul 15 16:34:27 ip-172-31-22-249.us-west-1.compute.internal systemd[1]: kibana.service failed.

```

---

<div class="post-metadata">

### Author: ![Mikhail\_Shustov](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mikhail_shustov/32/49186_2.png) [@Mikhail\_Shustov](https://discuss.elastic.co/u/Mikhail_Shustov)
#### Post date: [July 16, 2020, 7:33am UTC](https://discuss.elastic.co/t/kibana-7-8-wont-start/241336/2 "2020-07-16T07:33:05Z")

</div>

It's hard to identify the problem without any logs. Would you mind providing more info? The warnings couldn't prevent Kibana from starting

```auto
Jul 15 16:34:16 ip-172-31-22-249.us-west-1.compute.internal kibana[19313]: {"type":"log","@timestamp":"2020-07-15T16:33:46Z","tags":["warning","plugins-discovery"],"pid":19275,"message":"Expect plugin \"id\" in camelCase, but found: apm_oss"}
Jul 15 16:34:16 ip-172-31-22-249.us-west-1.compute.internal kibana[19313]: {"type":"log","@timestamp":"2020-07-15T16:33:46Z","tags":["warning","plugins-discovery"],"pid":19275,"message":"Expect plugin \"id\" in camelCase, but found: triggers_actions_ui"}

```

Are you trying to update the Kibana version? Or you start a new project?  
Do you use ElasticCloud? If so, have you tried to contact our support?

---

<div class="post-metadata">

### Author: ![Amphagory](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/amphagory/32/46127_2.png) [@Amphagory](https://discuss.elastic.co/u/Amphagory)
#### Post date: [July 16, 2020, 11:01pm UTC](https://discuss.elastic.co/t/kibana-7-8-wont-start/241336/3 "2020-07-16T23:01:57Z")

</div>

I am just installing a fresh Kibana onto an EC2 instance and starting it. No plugins or any modifications.

As for the Kibana logs, I guess I would need to install them as suggest by this page -\> [https://www.elastic.co/guide/en/elastic-stack-get-started/7.8/get-started-elastic-stack.html#install-kibana](https://www.elastic.co/guide/en/elastic-stack-get-started/7.8/get-started-elastic-stack.html#install-kibana)?

---

<div class="post-metadata">

### Author: ![Amphagory](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/amphagory/32/46127_2.png) [@Amphagory](https://discuss.elastic.co/u/Amphagory)
#### Post date: [July 16, 2020, 11:02pm UTC](https://discuss.elastic.co/t/kibana-7-8-wont-start/241336/4 "2020-07-16T23:02:57Z")

</div>

I do use the Elastic service for my Elasticsearch.

I guess I can contact them as well.

---

<div class="post-metadata">

### Author: ![Mikhail\_Shustov](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mikhail_shustov/32/49186_2.png) [@Mikhail\_Shustov](https://discuss.elastic.co/u/Mikhail_Shustov)
#### Post date: [July 19, 2020, 11:49am UTC](https://discuss.elastic.co/t/kibana-7-8-wont-start/241336/5 "2020-07-19T11:49:43Z")

</div>

> [@Amphagory](#):
>
> As for the Kibana logs, I guess I would need to install them as suggest by this page

Not really, Kibana logs the most important messages out of the box. You already have provided some of them:

```auto
Jul 15 16:34:16 ip-172-31-22-249.us-west-1.compute.internal kibana[19313]: {"type":"log","@timestamp":"2020-07-15T16:33:46Z","tags":["warning","plugins-discovery"],"pid":19275,"message":"Expect plugin \"id\" in camelCase, but found: apm_oss"}
Jul 15 16:34:16 ip-172-31-22-249.us-west-1.compute.internal kibana[19313]: {"type":"log","@timestamp":"2020-07-15T16:33:46Z","tags":["warning","plugins-discovery"],"pid":19275,"message":"Expect plugin \"id\" in camelCase, but found: triggers_actions_ui"}

```

But it doesn't look like a complete log. You should be able to find the full logs in the cloud console.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [August 16, 2020, 11:49am UTC](https://discuss.elastic.co/t/kibana-7-8-wont-start/241336/6 "2020-08-16T11:49:47Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
