# Kibana 7.9 keystore permissions error

**URL:** https://discuss.elastic.co/t/kibana-7-9-keystore-permissions-error/247854
**Category:** Kibana
**Tags:** elastic-stack-security
**Created:** [September 8, 2020, 9:13am UTC](https://discuss.elastic.co/t/kibana-7-9-keystore-permissions-error/247854 "2020-09-08T09:13:38Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![AleksandrN](https://avatars.discourse-cdn.com/v4/letter/a/9fc348/32.png) [@AleksandrN](https://discuss.elastic.co/u/AleksandrN)
#### Post date: [September 8, 2020, 9:13am UTC](https://discuss.elastic.co/t/kibana-7-9-keystore-permissions-error/247854/1 "2020-09-08T09:13:38Z")

</div>

I have installed a fresh kibana on CentOS 7 via yum (rpm) and when I'm trying to add entity to a keystore, I get an error:

` /usr/share/kibana/bin/kibana-keystore add server.ssl.keyPassphrase`  
` Enter value for server.ssl.keyPassphrase:`  
`Babel could not write cache to file: /usr/share/kibana/optimize/.babel_register_cache.json due to a permission issue. Cache is disabled.`  
` Enter value for server.ssl.keyPassphrase: ******** `  
`FATAL CLI ERROR Error: EACCES: permission denied, open '/usr/share/kibana/config/kibana.keystore'`  
` at Object.openSync (fs.js:443:3)`  
`at writeFileSync (fs.js:1194:35)`  
`at Keystore.save (/usr/share/kibana/src/legacy/server/keystore/keystore.js:65:27)`  
`at add (/usr/share/kibana/src/cli_keystore/add.js:73:12)`  
`at process._tickCallback (internal/process/next_tick.js:68:7)`

Same error, when I'm trying to delete and create store.

Which exact permissions must be on a keystore?

Now it's:  
`-rw-r--r--. 1 root root 130 Sep 7 21:57 /usr/share/kibana/config/kibana.keystore`

UPDATE1: I added entity as sudo with --allow-root, kibana must be supposed to read the value. If that's all, topic must be closed.

---

<div class="post-metadata">

### Author: ![wylie](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/wylie/32/81794_2.png) [@wylie](https://discuss.elastic.co/u/wylie)
#### Post date: [September 10, 2020, 8:11pm UTC](https://discuss.elastic.co/t/kibana-7-9-keystore-permissions-error/247854/2 "2020-09-10T20:11:55Z")

</div>


