# Kibana 7 - Docker - permission denied - RESOLVED

**URL:** https://discuss.elastic.co/t/kibana-7-docker-permission-denied-resolved/177051
**Category:** Kibana
**Tags:** docker
**Created:** [April 16, 2019, 9:55am UTC](https://discuss.elastic.co/t/kibana-7-docker-permission-denied-resolved/177051 "2019-04-16T09:55:24Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![DieMal](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/diemal/32/44229_2.png) [@DieMal](https://discuss.elastic.co/u/DieMal)
#### Post date: [April 16, 2019, 9:55am UTC](https://discuss.elastic.co/t/kibana-7-docker-permission-denied-resolved/177051/1 "2019-04-16T09:55:24Z")

</div>

Hi all,  
after upgrading from 6.7.0 to 7 i have a problem when run container. This is the logs from docker service logs:

Error: EACCES: permission denied, open '/usr/share/kibana/optimize/.babelcache.json'  
^

```
^

at Object.openSync (fs.js:439:3)

```

Error: EACCES: permission denied, open '/usr/share/kibana/optimize/.babelcache.json'  
Error: EACCES: permission denied, open '/usr/share/kibana/optimize/.babelcache.json'  
Error: EACCES: permission denied, open '/usr/share/kibana/optimize/.babelcache.json'  
at Object.openSync (fs.js:439:3)  
at Object.openSync (fs.js:439:3)  
at Object.writeFileSync (fs.js:1190:35)  
at Object.openSync (fs.js:439:3)  
at Object.writeFileSync (fs.js:1190:35)  
at Object.writeFileSync (fs.js:1190:35)  
at save (/usr/share/kibana/node\_modules/babel-register/lib/cache.js:48:16)  
at Object.writeFileSync (fs.js:1190:35)  
at save (/usr/share/kibana/node\_modules/babel-register/lib/cache.js:48:16)  
at save (/usr/share/kibana/node\_modules/babel-register/lib/cache.js:48:16)  
at save (/usr/share/kibana/node\_modules/babel-register/lib/cache.js:48:16)  
at process.\_tickCallback (internal/process/next\_tick.js:61:11)  
at process.\_tickCallback (internal/process/next\_tick.js:61:11)  
at process.\_tickCallback (internal/process/next\_tick.js:61:11)  
at process.\_tickCallback (internal/process/next\_tick.js:61:11)  
at Function.Module.runMain (internal/modules/cjs/loader.js:745:11)  
at Function.Module.runMain (internal/modules/cjs/loader.js:745:11)  
at Object.openSync (fs.js:439:3)  
at Function.Module.runMain (internal/modules/cjs/loader.js:745:11)  
at Function.Module.runMain (internal/modules/cjs/loader.js:745:11)  
at Object.writeFileSync (fs.js:1190:35)  
at startup (internal/bootstrap/node.js:283:19)  
at startup (internal/bootstrap/node.js:283:19)  
at startup (internal/bootstrap/node.js:283:19)  
at save (/usr/share/kibana/node\_modules/babel-register/lib/cache.js:48:16)  
at bootstrapNodeJSCore (internal/bootstrap/node.js:743:3)  
at startup (internal/bootstrap/node.js:283:19)  
at bootstrapNodeJSCore (internal/bootstrap/node.js:743:3)  
at bootstrapNodeJSCore (internal/bootstrap/node.js:743:3)  
at bootstrapNodeJSCore (internal/bootstrap/node.js:743:3)  
at process.\_tickCallback (internal/process/next\_tick.js:61:11)  
at Function.Module.runMain (internal/modules/cjs/loader.js:745:11)  
at startup (internal/bootstrap/node.js:283:19)  
at bootstrapNodeJSCore (internal/bootstrap/node.js:743:3)

What can I do ?  
best regards

DM

---

<div class="post-metadata">

### Author: ![DieMal](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/diemal/32/44229_2.png) [@DieMal](https://discuss.elastic.co/u/DieMal)
#### Post date: [April 16, 2019, 12:11pm UTC](https://discuss.elastic.co/t/kibana-7-docker-permission-denied-resolved/177051/2 "2019-04-16T12:11:14Z")

</div>

I'don't know why, but the Kibane image was corrupted, i remove it ad force a new updating and everything is back to work fine.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [May 14, 2019, 12:17pm UTC](https://discuss.elastic.co/t/kibana-7-docker-permission-denied-resolved/177051/3 "2019-05-14T12:17:15Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
