# Kibana Access Behind NAT IP

**URL:** https://discuss.elastic.co/t/kibana-access-behind-nat-ip/197896
**Category:** Kibana
**Created:** [September 3, 2019, 3:46pm UTC](https://discuss.elastic.co/t/kibana-access-behind-nat-ip/197896 "2019-09-03T15:46:47Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Jensjp](https://avatars.discourse-cdn.com/v4/letter/j/3bc359/32.png) [@Jensjp](https://discuss.elastic.co/u/Jensjp)
#### Post date: [September 3, 2019, 3:46pm UTC](https://discuss.elastic.co/t/kibana-access-behind-nat-ip/197896/1 "2019-09-03T15:46:48Z")

</div>

Hi , I have kibana setup in an external server which is made available inside the corporate network through a Natted IP. The NAT is one-to-one to the kibana host. The issue is when I use the internal IP of the kibana machine the page is displayed correctly but when accessing from outside using the NAT IP, Kibana is not loading properly ..

Error :

# Kibana did not load properly. Check the server output for more information.

In the chrome developer console the following error is shown ..

kibana:186 Refused to execute inline script because it violates the following Content Security Policy directive: "script-src 'unsafe-eval' 'self'". Either the 'unsafe-inline' keyword, a hash ('sha256-SHHSeLc0bp6xt4BoVVyUy+3IbVqp3ujLaR+s+kSP5UI='), or a nonce ('nonce-...') is required to enable inline execution.

bootstrap.js:10 ^ A single error about an inline script not firing due to content security policy is expected!  
/txprobe-kibana/built\_assets/dlls/vendors.bundle.dll.js:1 Failed to load resource: net::ERR\_CONNECTION\_RESET

Kibana Version : kibana-6.7.0-linux-x86\_64

Configurations in kibana.yml is default with no changes made.

---

<div class="post-metadata">

### Author: ![Marius\_Dragomir](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/marius_dragomir/32/42087_2.png) [@Marius\_Dragomir](https://discuss.elastic.co/u/Marius_Dragomir)
#### Post date: [September 6, 2019, 12:11pm UTC](https://discuss.elastic.co/t/kibana-access-behind-nat-ip/197896/2 "2019-09-06T12:11:51Z")

</div>

Can you try with `csp.strict: false` in kibana.yml and see if it's the same problem?

---

<div class="post-metadata">

### Author: ![Jensjp](https://avatars.discourse-cdn.com/v4/letter/j/3bc359/32.png) [@Jensjp](https://discuss.elastic.co/u/Jensjp)
#### Post date: [September 15, 2019, 9:23pm UTC](https://discuss.elastic.co/t/kibana-access-behind-nat-ip/197896/3 "2019-09-15T21:23:21Z")

</div>

I have tried toggling this property but this did not fix the issue.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [October 13, 2019, 9:23pm UTC](https://discuss.elastic.co/t/kibana-access-behind-nat-ip/197896/4 "2019-10-13T21:23:23Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
