# Kibana already started but the status is not running

**URL:** <https://discuss.elastic.co/t/kibana-already-started-but-the-status-is-not-running/42667>\
**Category:** Kibana\
**Created:** [February 25, 2016, 4:32am UTC](https://discuss.elastic.co/t/kibana-already-started-but-the-status-is-not-running/42667 "2016-02-25T04:32:40Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![fadzhli](https://avatars.discourse-cdn.com/v4/letter/f/7bcc69/32.png) [@fadzhli](https://discuss.elastic.co/u/fadzhli)\
**Post date:** [February 25, 2016, 4:32am UTC](https://discuss.elastic.co/t/kibana-already-started-but-the-status-is-not-running/42667/1 "2016-02-25T04:32:41Z")

</div>

I'm just updated my Kibana to 4.4 and I have encounter some problems:

```auto
[fadzhli@elk ~]$ sudo service kibana start
chown: invalid user: 'kibana:root'
kibana started

[fadzhli@elk ~]$ sudo service kibana status
[sudo] password for fadzhli: 
kibana is not running

```

As you can see I start the service, the service is running but on the status is not running. How to resolve this problem,

Thank you

---

<div class="post-metadata">

**Author:** ![LeeDr](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leedr/32/9289_2.png) [@LeeDr](https://discuss.elastic.co/u/LeeDr)\
**Post date:** [February 25, 2016, 6:08pm UTC](https://discuss.elastic.co/t/kibana-already-started-but-the-status-is-not-running/42667/2 "2016-02-25T18:08:24Z")

</div>

The first message "kibana started" just means it _ **was** _ started, but apparently failed and now is not running.

You probably need to look in /var/log/kibana. There should be a stdout and stderr file. If that doesn't tell you the problem please paste it here and someone will try to help.

Regards,  
Lee

---

<div class="post-metadata">

**Author:** ![carlosq](https://avatars.discourse-cdn.com/v4/letter/c/8e8cbc/32.png) [@carlosq](https://discuss.elastic.co/u/carlosq)\
**Post date:** [February 25, 2016, 6:27pm UTC](https://discuss.elastic.co/t/kibana-already-started-but-the-status-is-not-running/42667/3 "2016-02-25T18:27:56Z")

</div>

I have same problem and I checked log file /var/log/kibana/kibana.stderr, it has errors as:

Error: Cannot find module '/opt/kibana/src/src/utils/packageJson'  
at Function.Module.\_resolveFilename (module.js:336:15)  
at Function.Module.\_load (module.js:278:25)  
at Module.require (module.js:365:17)  
at require (module.js:384:17)  
at requireModule (/opt/kibana/src/node\_modules/requirefrom/index.js:24:10)  
at Object. (/opt/kibana/src/cli/cli.js:6:11)  
at Module.\_compile (module.js:460:26)  
at Module.\_extensions..js (module.js:478:10)  
at Object.require.extensions.(anonymous function) [as .js] (/opt/kibana/node\_modules/babel-core/lib/api/register/node.js:214:7)  
at Module.load (module.js:355:32)

---

<div class="post-metadata">

**Author:** ![fadzhli](https://avatars.discourse-cdn.com/v4/letter/f/7bcc69/32.png) [@fadzhli](https://discuss.elastic.co/u/fadzhli)\
**Post date:** [February 26, 2016, 4:33am UTC](https://discuss.elastic.co/t/kibana-already-started-but-the-status-is-not-running/42667/4 "2016-02-26T04:33:58Z")

</div>

Hi, although the status is not running, my kibana works just fine and this is weird.

My stderr output is

```
chroot: invalid user
chroot: invalid user
chroot: invalid user
chroot: invalid user
chroot: invalid user
chroot: invalid user
chroot: invalid user
chroot: invalid user
chroot: invalid user
chroot: invalid user

```

My stdout is

```
{"type":"log","@timestamp":"2016-02-22T09:26:32+00:00","tags":["error","elasticsearch"],"pid":1436,"message":"Request error, retrying -- connect ECONNREFUSED"}
{"type":"log","@timestamp":"2016-02-22T09:26:32+00:00","tags":["status","plugin:markdown_vis","info"],"pid":1436,"name":"plugin:markdown_vis","state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2016-02-22T09:26:32+00:00","tags":["status","plugin:metric_vis","info"],"pid":1436,"name":"plugin:metric_vis","state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2016-02-22T09:26:32+00:00","tags":["warning","elasticsearch"],"pid":1436,"message":"Unable to revive connection: http://localhost:9200/"}
{"type":"log","@timestamp":"2016-02-22T09:26:32+00:00","tags":["warning","elasticsearch"],"pid":1436,"message":"No living connections"}
{"type":"log","@timestamp":"2016-02-22T09:26:32+00:00","tags":["status","plugin:elasticsearch","error"],"pid":1436,"name":"plugin:elasticsearch","state":"red","message":"Status changed from yellow to red - Unable to connect to Elasticsearch at http://localhost:9200. Retrying in 2.5 seconds.","prevState":"yellow","prevMsg":"Waiting for Elasticsearch"}
{"type":"log","@timestamp":"2016-02-22T09:26:32+00:00","tags":["status","plugin:spyModes","info"],"pid":1436,"name":"plugin:spyModes","state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2016-02-22T09:26:32+00:00","tags":["status","plugin:statusPage","info"],"pid":1436,"name":"plugin:statusPage","state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2016-02-22T09:26:32+00:00","tags":["status","plugin:table_vis","info"],"pid":1436,"name":"plugin:table_vis","state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2016-02-22T09:26:32+00:00","tags":["fatal"],"pid":1436,"level":"fatal","message":"listen EADDRINUSE","error":{"message":"listen EADDRINUSE","name":"Error","stack":"Error: listen EADDRINUSE\n at exports._errnoException (util.js:746:11)\n at Server._listen2 (net.js:1156:14)\n at listen (net.js:1182:10)\n at net.js:1280:9\n at GetAddrInfoReqWrap.asyncCallback [as callback] (dns.js:81:16)\n at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:99:10)","code":"EADDRINUSE"}}

```

Thank you

---

<div class="post-metadata">

**Author:** ![LeeDr](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leedr/32/9289_2.png) [@LeeDr](https://discuss.elastic.co/u/LeeDr)\
**Post date:** [February 26, 2016, 5:17pm UTC](https://discuss.elastic.co/t/kibana-already-started-but-the-status-is-not-running/42667/5 "2016-02-26T17:17:24Z")

</div>

Hi Mohd,

Let's go back and try to figure out why you're getting this `invalid user` error;

> [@fadzhli](#):
>
> [fadzhli@elk ~]$ sudo service kibana start  
> chown: invalid user: 'kibana:root'

Can you check this;  
`ls -l /opt/kibana`

On my install I see the optimize folder is owned by kibana in the root group;  
`drwxrwxr-x 3 kibana root 4096 Feb 25 17:58 optimize`

Does you're look the same?

Or another thing to check is  
`leedr@U14K:~$ grep kibana /etc/passwd kibana:x:998:998::/home/kibana:`

If you don't have the kibana user we need to see how you installed kibana and maybe go through that process again.

BY THE WAY, there is a 4.4.1 kibana release now that has a security fix.

Also, the last stdout message is a fatal message saying that the address is in use. So you may have 2 instances of kibana trying to start. You can check with `ps -ef | grep kibana`

---

<div class="post-metadata">

**Author:** ![fadzhli](https://avatars.discourse-cdn.com/v4/letter/f/7bcc69/32.png) [@fadzhli](https://discuss.elastic.co/u/fadzhli)\
**Post date:** [March 1, 2016, 7:37am UTC](https://discuss.elastic.co/t/kibana-already-started-but-the-status-is-not-running/42667/6 "2016-03-01T07:37:44Z")

</div>

Hi Lee,

Thank you for your response.

> [@LeeDr](#):
>
> ls -l /opt/kibana

`drwxr-xr-x 3 990 989 43 Jan 19 11:16 optimize`

> [@LeeDr](#):
>
> If you don't have the kibana user we need to see how you installed kibana and maybe go through that process again.

I don't have kibana user on my /etc/passwd & I installed my kibana by doing _\*\* yum update kibana\*\*_

Can you show me how to add user kibana back on the server.

Thank you

---

<div class="post-metadata">

**Author:** ![LeeDr](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leedr/32/9289_2.png) [@LeeDr](https://discuss.elastic.co/u/LeeDr)\
**Post date:** [March 1, 2016, 2:47pm UTC](https://discuss.elastic.co/t/kibana-already-started-but-the-status-is-not-running/42667/7 "2016-03-01T14:47:21Z")

</div>

Hi Mohd,

I'm not sure which version of Kibana you had installed prior to your "yum update", but there may have been some changes to the packaging in the way the kibana user is created. And a problem has recently been reported that the upgrade process tries to delete and then recreate the kibana user which it should not do.

And yes, there is a 4.4.1 release now with a security fix.

The easiest way to get back on track would be to uninstall Kibana, and then install Kibana 4.4.1.

If you have any modifications to your kibana/config/kibana.yml save a copy of that in a different directory.

Regards,  
Lee

---

<div class="post-metadata">

**Author:** ![fadzhli](https://avatars.discourse-cdn.com/v4/letter/f/7bcc69/32.png) [@fadzhli](https://discuss.elastic.co/u/fadzhli)\
**Post date:** [March 2, 2016, 3:43am UTC](https://discuss.elastic.co/t/kibana-already-started-but-the-status-is-not-running/42667/8 "2016-03-02T03:43:11Z")

</div>

Hi Lee

I've already uninstall Kibana and install Kibana 4.4.1.

```
sh-4.2$ sudo service kibana start
kibana started
sh-4.2$ sudo service kibana status
kibana is not running

```

Kibana user also in /etc/passwd

Funny thing is, the kibana service is running perfectly but when I check the status is not running.

Then I check ls -l /opt/kibana and my kibana is not in root group.

So I run

`sudo chown -R kibana:kibana /opt/kibana`

Now the output of my kibana status is ok

```
sh-4.2$ sudo service kibana start
kibana started
sh-4.2$ sudo service kibana status
kibana is running

```

But I have this error on stderr

```
Error: EACCES, permission denied '/opt/kibana/optimize/.babelcache.json'
    at Error (native)
    at Object.fs.openSync (fs.js:500:18)
    at Object.fs.writeFileSync (fs.js:1099:15)
    at save (/opt/kibana/node_modules/babel-core/lib/api/register/cache.js:35:19)
    at process._tickDomainCallback (node.js:381:11)
    at Function.Module.runMain (module.js:503:11)
    at startup (node.js:129:16)
    at node.js:814:3
```

---

<div class="post-metadata">

**Author:** ![LeeDr](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leedr/32/9289_2.png) [@LeeDr](https://discuss.elastic.co/u/LeeDr)\
**Post date:** [March 2, 2016, 2:27pm UTC](https://discuss.elastic.co/t/kibana-already-started-but-the-status-is-not-running/42667/9 "2016-03-02T14:27:53Z")

</div>

Hi Mohd,

Here's the permissions on that .babelcache.json on my system where I just did a clean install and service start on kibana;

```
root@U14K:~# ls -al /opt/kibana/optimize/
total 16
drwxrwxr-x 3 kibana root 4096 Mar 2 08:14 .
drwxrwxr-x 10 root root 4096 Mar 2 08:12 ..
-rw-r--r-- 1 kibana root 2 Mar 2 08:14 .babelcache.json
drwxrwxr-x 4 root root 4096 Mar 2 08:12 bundles

```

I'm guessing your .babelcache.json is owned by root instead of kibana? If that's true, I would stop your kibana service and change the owner to `kibana:root` like this one. Then start kibana and see that you don't get that error any longer.

Since the kibana service runs as user kibana, it's probably OK to do a recursive chown on the entire /opt/kibana directory to kibana:kibana.

Regards,  
Lee

---

<div class="post-metadata">

**Author:** ![fadzhli](https://avatars.discourse-cdn.com/v4/letter/f/7bcc69/32.png) [@fadzhli](https://discuss.elastic.co/u/fadzhli)\
**Post date:** [March 3, 2016, 9:20am UTC](https://discuss.elastic.co/t/kibana-already-started-but-the-status-is-not-running/42667/10 "2016-03-03T09:20:20Z")

</div>

Hi Lee,

I've change the owner to kibana:root

> [@LeeDr](#):
>
> ls -al /opt/kibana/optimize/

```
sh-4.2$ ls -al /opt/kibana/optimize/
total 12
drwxr-xr-x 3 kibana root 43 Jan 19 11:16 .
drwxr-xr-x 10 kibana root 4096 Mar 2 10:26 ..
-rw-r--r-- 1 kibana root 2 Mar 3 17:17 .babelcache.json
drwxr-xr-x 4 kibana root 4096 Mar 2 10:26 bundles

```

But now I have this new error in my stderr log

```
FATAL { [Error: listen EADDRINUSE]
  cause: { [Error: listen EADDRINUSE] code: 'EADDRINUSE', errno: 'EADDRINUSE', syscall: 'listen' },
  isOperational: true,
  code: 'EADDRINUSE',
  errno: 'EADDRINUSE',
  syscall: 'listen' }

```

How to resolve this error?

---

<div class="post-metadata">

**Author:** ![LeeDr](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leedr/32/9289_2.png) [@LeeDr](https://discuss.elastic.co/u/LeeDr)\
**Post date:** [March 3, 2016, 3:04pm UTC](https://discuss.elastic.co/t/kibana-already-started-but-the-status-is-not-running/42667/11 "2016-03-03T15:04:11Z")

</div>

You must have 2 instances trying to start now. First try `service kibana stop`  
Wait a few seconds for kibana to stop.  
Then check with `ps -ef | grep kibana`  
If there's still a kibana process running, you could wait another few seconds and check again, or kill it with `kill -9 <pid-of-kibana-process>`  
Then start it normally `service kibana start`

---

<div class="post-metadata">

**Author:** ![fadzhli](https://avatars.discourse-cdn.com/v4/letter/f/7bcc69/32.png) [@fadzhli](https://discuss.elastic.co/u/fadzhli)\
**Post date:** [March 4, 2016, 9:17am UTC](https://discuss.elastic.co/t/kibana-already-started-but-the-status-is-not-running/42667/12 "2016-03-04T09:17:22Z")

</div>

Hi Lee,

I have kill my kibana process but it seem the process is still there. Although I have error in my stderr log but my kibana work just fine. I think maybe I just can reinstall all the ELK stack later. Or do you have other opinion?

Thank you.

---

<div class="post-metadata">

**Author:** ![LeeDr](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leedr/32/9289_2.png) [@LeeDr](https://discuss.elastic.co/u/LeeDr)\
**Post date:** [March 14, 2016, 7:15pm UTC](https://discuss.elastic.co/t/kibana-already-started-but-the-status-is-not-running/42667/13 "2016-03-14T19:15:39Z")

</div>

Hi Mohd,

I was out on vacation last week. Do you have Kibana working now? Still have errors in your log?

Lee

---

<div class="post-metadata">

**Author:** ![fadzhli](https://avatars.discourse-cdn.com/v4/letter/f/7bcc69/32.png) [@fadzhli](https://discuss.elastic.co/u/fadzhli)\
**Post date:** [March 18, 2016, 3:32am UTC](https://discuss.elastic.co/t/kibana-already-started-but-the-status-is-not-running/42667/14 "2016-03-18T03:32:37Z")

</div>

Hi lee,

My Kibana is working fine. But I still have the error on my stderr

```
  isOperational: true,
  code: 'EADDRINUSE',
  errno: 'EADDRINUSE',
  syscall: 'listen' }
FATAL { [Error: listen EADDRINUSE]
  cause: { [Error: listen EADDRINUSE] code: 'EADDRINUSE', errno: 'EADDRINUSE', syscall: 'listen' },
  isOperational: true,
  code: 'EADDRINUSE',
  errno: 'EADDRINUSE',
  syscall: 'listen' }

```

I just ignore it.

Thank you for replying =)

---

<div class="post-metadata">

**Author:** ![Deepak\_Patnaik](https://avatars.discourse-cdn.com/v4/letter/d/73ab20/32.png) [@Deepak\_Patnaik](https://discuss.elastic.co/u/Deepak_Patnaik)\
**Post date:** [September 24, 2016, 5:19pm UTC](https://discuss.elastic.co/t/kibana-already-started-but-the-status-is-not-running/42667/15 "2016-09-24T17:19:43Z")

</div>

Hi,  
I am also getting the same error message. Now when I try to remove the Kibana. it gives me the below message.

Package kibana is not installed, so not removed

Need urgent help as I have got a demo scheduled for next week.

Thanks,  
Deepak

---

<div class="post-metadata">

**Author:** ![Deepak\_Patnaik](https://avatars.discourse-cdn.com/v4/letter/d/73ab20/32.png) [@Deepak\_Patnaik](https://discuss.elastic.co/u/Deepak_Patnaik)\
**Post date:** [September 24, 2016, 5:22pm UTC](https://discuss.elastic.co/t/kibana-already-started-but-the-status-is-not-running/42667/16 "2016-09-24T17:22:32Z")

</div>

I checked for any running jobs.

deepak 18060 18004 0 22:51 pts/1 00:00:00 grep --color=auto kibana

I tried to kill 18060, but it shows, there is no such job.

---

<div class="post-metadata">

**Author:** ![LeeDr](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leedr/32/9289_2.png) [@LeeDr](https://discuss.elastic.co/u/LeeDr)\
**Post date:** [September 26, 2016, 12:54pm UTC](https://discuss.elastic.co/t/kibana-already-started-but-the-status-is-not-running/42667/17 "2016-09-26T12:54:15Z")

</div>

Hi Deepak,

When you run something like `ps -ef | grep Kibana`, the `ps -ef` includes the process doing the grep and that's the output you see `... grep --color=auto kinana`. So you have to ignore that line, or remove it like this;  
`ps - ef | grep kibana | grep -v grep`

For your Kibana issue, can you reply with your operating system, Kibana version, and how you installed it?

Thanks,  
Lee

---

<div class="post-metadata">

**Author:** ![Spandana](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spandana/32/133011_2.png) [@Spandana](https://discuss.elastic.co/u/Spandana)\
**Post date:** [October 21, 2016, 2:07pm UTC](https://discuss.elastic.co/t/kibana-already-started-but-the-status-is-not-running/42667/18 "2016-10-21T14:07:20Z")

</div>

Hi Lee,

I have a similar problem. When i try to start kibana  
I get this  
bash-4.1$ sudo service kibana start  
chown: invalid group: `kibana:kibana'  
kibana started

and

bash-4.1$ ls -al /opt/kibana/optimize/  
total 16  
drwxr-xr-x 3 kibana root 4096 Oct 21 05:39 .  
drwxr-xr-x 10 kibana root 4096 Oct 21 05:39 ..  
-rw-rw-r-- 1 kibana root 2 Oct 21 06:45 .babelcache.json  
drwxr-xr-x 4 kibana root 4096 Oct 21 05:39 bundles

Any suggestions on this please. I tried yum update kibana it says 'No Packages marked for Update'

---

<div class="post-metadata">

**Author:** ![fadzhli](https://avatars.discourse-cdn.com/v4/letter/f/7bcc69/32.png) [@fadzhli](https://discuss.elastic.co/u/fadzhli)\
**Post date:** [October 21, 2016, 2:35pm UTC](https://discuss.elastic.co/t/kibana-already-started-but-the-status-is-not-running/42667/19 "2016-10-21T14:35:46Z")

</div>

Hi,

What version of kibana you using now?

---

<div class="post-metadata">

**Author:** ![Spandana](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spandana/32/133011_2.png) [@Spandana](https://discuss.elastic.co/u/Spandana)\
**Post date:** [October 22, 2016, 12:55pm UTC](https://discuss.elastic.co/t/kibana-already-started-but-the-status-is-not-running/42667/20 "2016-10-22T12:55:56Z")

</div>

Hi fadzhil,  
Its kibana 4.5 version

[Next page](https://discuss.elastic.co/t/kibana-already-started-but-the-status-is-not-running/42667.md?page=2)
