# Kibana and Elasticsearch Node configuration not working after moving data directory

**URL:** <https://discuss.elastic.co/t/kibana-and-elasticsearch-node-configuration-not-working-after-moving-data-directory/244467>\
**Category:** Elasticsearch\
**Created:** [August 10, 2020, 9:56pm UTC](https://discuss.elastic.co/t/kibana-and-elasticsearch-node-configuration-not-working-after-moving-data-directory/244467 "2020-08-10T21:56:35Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![userR](https://avatars.discourse-cdn.com/v4/letter/u/22d042/32.png) [@userR](https://discuss.elastic.co/u/userR)\
**Post date:** [August 10, 2020, 9:56pm UTC](https://discuss.elastic.co/t/kibana-and-elasticsearch-node-configuration-not-working-after-moving-data-directory/244467/1 "2020-08-10T21:56:35Z")

</div>

I have two elasticsearch nodes and for one of them, I moved the the /var/lib/elasticsearch folder to a mount with more storage. I chown'd an elasticsearch user and changed the path.data in the elasticsearch.yml file and everything worked fine with that node.

However, Kibana and my other elasticsearch node are unable to connect and I am getting the below errors in the log data:  
Kibana:

> Aug 10 10:11:58 _server_ kibana[3136]: FATAL Error: [config validation of [elasticsearch].hosts]: types that failed validation:  
> Aug 10 10:11:58 _server_ kibana[3136]: - [config validation of [elasticsearch].hosts.0]: expected value of type [string] but got [Array].  
> Aug 10 10:11:58 _server_ kibana[3136]: - [config validation of [elasticsearch].hosts.1.1]: expected URI with scheme [http|https].  
> Aug 10 10:12:00 _server_ systemd[1]: kibana.service: main process exited, code=exited, status=1/FAILURE  
> Aug 10 10:12:00 _server_ systemd[1]: Unit kibana.service entered failed state.  
> Aug 10 10:12:00 _server_ systemd[1]: kibana.service failed.

Other elasticsearch Node:

> org.elasticsearch.transport.ConnectTransportException: [_NODE_][_IP INFO_] connect\_exception  
> at org.elasticsearch.transport.TcpTransport$ChannelsConnectedListener.onFailure(TcpTransport.java:966) ~[elasticsearch-7.8.1.jar:7.8.1]  
> at org.elasticsearch.action.ActionListener.lambda$toBiConsumer$2(ActionListener.java:198) ~[elasticsearch-7.8.1.jar:7.8.1]  
> at org.elasticsearch.common.concurrent.CompletableContext.lambda$addListener$0(CompletableContext.java:42) ~[elasticsearch-core-7.8.1.jar:7.8.1]  
> at java.util.concurrent.CompletableFuture.uniWhenComplete(CompletableFuture.java:859) ~[?:?]  
> at java.util.concurrent.CompletableFuture$UniWhenComplete.tryFire(CompletableFuture.java:837) ~[?:?]  
> at java.util.concurrent.CompletableFuture.postComplete(CompletableFuture.java:506) ~[?:?]  
> at java.util.concurrent.CompletableFuture.completeExceptionally(CompletableFuture.java:2152) ~[?:?]  
> at org.elasticsearch.common.concurrent.CompletableContext.completeExceptionally(CompletableContext.java:57) ~[elasticsearch-core-7.8.1.jar:7.8.1]  
> at org.elasticsearch.transport.netty4.Netty4TcpChannel.lambda$addListener$0(Netty4TcpChannel.java:68) ~[?:?]  
> at io.netty.util.concurrent.DefaultPromise.notifyListener0(DefaultPromise.java:577) ~[?:?]  
> at io.netty.util.concurrent.DefaultPromise.notifyListeners0(DefaultPromise.java:570) ~[?:?]  
> at io.netty.util.concurrent.DefaultPromise.notifyListenersNow(DefaultPromise.java:549) ~[?:?]  
> at io.netty.util.concurrent.DefaultPromise.notifyListeners(DefaultPromise.java:490) ~[?:?]  
> at io.netty.util.concurrent.DefaultPromise.setValue0(DefaultPromise.java:615) ~[?:?]  
> at io.netty.util.concurrent.DefaultPromise.setFailure0(DefaultPromise.java:608) ~[?:?]  
> at io.netty.util.concurrent.DefaultPromise.tryFailure(DefaultPromise.java:117) ~[?:?]  
> at io.netty.channel.nio.AbstractNioChannel$AbstractNioUnsafe.fulfillConnectPromise(AbstractNioChannel.java:321) ~[?:?]  
> at io.netty.channel.nio.AbstractNioChannel$AbstractNioUnsafe.finishConnect(AbstractNioChannel.java:337) ~[?:?]  
> at io.netty.channel.nio.NioEventLoop.processSelectedKey(NioEventLoop.java:702) ~[?:?]  
> at io.netty.channel.nio.NioEventLoop.processSelectedKeysPlain(NioEventLoop.java:615) ~[?:?]  
> at io.netty.channel.nio.NioEventLoop.processSelectedKeys(NioEventLoop.java:578) ~[?:?]  
> at io.netty.channel.nio.NioEventLoop.run(NioEventLoop.java:493) ~[?:?]  
> at io.netty.util.concurrent.SingleThreadEventExecutor$4.run(SingleThreadEventExecutor.java:989) ~[?:?]  
> at io.netty.util.internal.ThreadExecutorMap$2.run(ThreadExecutorMap.java:74) ~[?:?]  
> at java.lang.Thread.run(Thread.java:832) [?:?]  
> Caused by: io.netty.channel.AbstractChannel$AnnotatedConnectException: Connection refused: _IP INFORMATION_  
> Caused by: java.net.ConnectException: Connection refused  
> at sun.nio.ch.Net.pollConnect(Native Method) ~[?:?]  
> at sun.nio.ch.Net.pollConnectNow(Net.java:589) ~[?:?]  
> at sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:839) ~[?:?]  
> at io.netty.channel.socket.nio.NioSocketChannel.doFinishConnect(NioSocketChannel.java:330) ~[?:?]  
> at io.netty.channel.nio.AbstractNioChannel$AbstractNioUnsafe.finishConnect(AbstractNioChannel.java:334) ~[?:?]

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [August 10, 2020, 10:01pm UTC](https://discuss.elastic.co/t/kibana-and-elasticsearch-node-configuration-not-working-after-moving-data-directory/244467/2 "2020-08-10T22:01:59Z")

</div>

> [@userR](#):
>
> Aug 10 10:11:58 _server_ kibana[3136]: - [config validation of [elasticsearch].hosts.0]: expected value of type [string] but got [Array].

That looks pretty relevant, what's your setting there look like?

---

<div class="post-metadata">

**Author:** ![userR](https://avatars.discourse-cdn.com/v4/letter/u/22d042/32.png) [@userR](https://discuss.elastic.co/u/userR)\
**Post date:** [August 10, 2020, 10:12pm UTC](https://discuss.elastic.co/t/kibana-and-elasticsearch-node-configuration-not-working-after-moving-data-directory/244467/3 "2020-08-10T22:12:13Z")

</div>

Here are my kibana.yml settings:

> server.host: "0.0.0.0"  
> server.name: "_SERVER NAME_"  
> elasticsearch.hosts: ["[http://localhost:9200](http://localhost:9200)", "_Other elasticsearch node_"]

This set up was working fine before I moved the directory

---

<div class="post-metadata">

**Author:** ![userR](https://avatars.discourse-cdn.com/v4/letter/u/22d042/32.png) [@userR](https://discuss.elastic.co/u/userR)\
**Post date:** [August 11, 2020, 5:58pm UTC](https://discuss.elastic.co/t/kibana-and-elasticsearch-node-configuration-not-working-after-moving-data-directory/244467/4 "2020-08-11T17:58:49Z")

</div>

I still can't seem to figure this error out. Any update on how I can fix this?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 8, 2020, 5:58pm UTC](https://discuss.elastic.co/t/kibana-and-elasticsearch-node-configuration-not-working-after-moving-data-directory/244467/5 "2020-09-08T17:58:50Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
