# Kibana and elasticsearch status is active , i can access elasticsearch via browser but kibana is giving error

**URL:** <https://discuss.elastic.co/t/kibana-and-elasticsearch-status-is-active-i-can-access-elasticsearch-via-browser-but-kibana-is-giving-error/194197>\
**Category:** Kibana\
**Created:** [August 7, 2019, 9:45am UTC](https://discuss.elastic.co/t/kibana-and-elasticsearch-status-is-active-i-can-access-elasticsearch-via-browser-but-kibana-is-giving-error/194197 "2019-08-07T09:45:48Z")\
**Posts on this page:** 16\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ayush\_Verma](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ayush_verma/32/46709_2.png) [@Ayush\_Verma](https://discuss.elastic.co/u/Ayush_Verma)\
**Post date:** [August 7, 2019, 9:45am UTC](https://discuss.elastic.co/t/kibana-and-elasticsearch-status-is-active-i-can-access-elasticsearch-via-browser-but-kibana-is-giving-error/194197/1 "2019-08-07T09:45:48Z")

</div>

I installed kibana and elasticsearch on google instance, elasticsearch is working fine.  
`curl -X GET "10.128.0.26:9200/"`  
{  
"name" : "node-1",  
"cluster\_name" : "ElasticsearchStaging",  
"cluster\_uuid" : "r-A1o-coQlWUWeoXIFa5gw",  
"version" : {  
"number" : "7.3.0",  
"build\_flavor" : "default",  
"build\_type" : "deb",  
"build\_hash" : "de777fa",  
"build\_date" : "2019-07-24T18:30:11.767338Z",  
"build\_snapshot" : false,  
"lucene\_version" : "8.1.0",  
"minimum\_wire\_compatibility\_version" : "6.8.0",  
"minimum\_index\_compatibility\_version" : "6.0.0-beta1"  
},  
"tagline" : "You Know, for Search"  
}

`curl -X GET "10.128.0.26:5601/"`  
`Kibana server is not ready yet`

kibana/log file:

```
07T10:17:41Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"No living connections"}
07T10:17:41Z","tags":["warning","task_manager"],"pid":6590,"message":"PollError No Living connections"}
07T10:17:43Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"Unable to revive connection: http://0.0.0.0:9200/"}
07T10:17:43Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"No living connections"}
07T10:17:44Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"Unable to revive connection: http://0.0.0.0:9200/"}
07T10:17:44Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"No living connections"}
07T10:17:44Z","tags":["warning","task_manager"],"pid":6590,"message":"PollError No Living connections"}
07T10:17:46Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"Unable to revive connection: http://0.0.0.0:9200/"}
07T10:17:46Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"No living connections"}
07T10:17:47Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"Unable to revive connection: http://0.0.0.0:9200/"}
07T10:17:47Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"No living connections"}
07T10:17:47Z","tags":["warning","task_manager"],"pid":6590,"message":"PollError No Living connections"}
07T10:17:48Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"Unable to revive connection: http://0.0.0.0:9200/"}
07T10:17:48Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"No living connections"}
07T10:17:50Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"Unable to revive connection: http://0.0.0.0:9200/"}
07T10:17:50Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"No living connections"}
07T10:17:50Z","tags":["warning","task_manager"],"pid":6590,"message":"PollError No Living connections"}
07T10:17:51Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"Unable to revive connection: http://0.0.0.0:9200/"}
07T10:17:51Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"No living connections"}
07T10:17:53Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"Unable to revive connection: http://0.0.0.0:9200/"}
07T10:17:53Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"No living connections"}
07T10:17:53Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"Unable to revive connection: http://0.0.0.0:9200/"}
07T10:17:53Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"No living connections"}
07T10:17:53Z","tags":["warning","task_manager"],"pid":6590,"message":"PollError No Living connections"}
07T10:17:56Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"Unable to revive connection: http://0.0.0.0:9200/"}
07T10:17:56Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"No living connections"}
07T10:17:56Z","tags":["warning","elasticsearch","data"],"pid":6590,"message":"Unable to revive connection: http://0.0.0.0:9200/"}
07T10:17:56Z","tags":["warning","elasticsearch","data"],"pid":6590,"message":"No living connections"}
07T10:17:56Z","tags":["license","warning","xpack"],"pid":6590,"message":"License information from the X-Pack plugin could not be obtained from Elasticsearch for the [data] cluation from the X-Pack plugin could not be obtained from Elasticsearch for the [data] cluster. Error: No Living connections"}
07T10:17:56Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"Unable to revive connection: http://0.0.0.0:9200/"}
07T10:17:56Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"No living connections"}
07T10:17:56Z","tags":["warning","task_manager"],"pid":6590,"message":"PollError No Living connections"}
07T10:17:58Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"Unable to revive connection: http://0.0.0.0:9200/"}
07T10:17:58Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"No living connections"}
```

---

<div class="post-metadata">

**Author:** ![Ayush\_Verma](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ayush_verma/32/46709_2.png) [@Ayush\_Verma](https://discuss.elastic.co/u/Ayush_Verma)\
**Post date:** [August 7, 2019, 9:51am UTC](https://discuss.elastic.co/t/kibana-and-elasticsearch-status-is-active-i-can-access-elasticsearch-via-browser-but-kibana-is-giving-error/194197/2 "2019-08-07T09:51:45Z")

</div>

kibana.yml file:

```
# Kibana is served by a back end server. This setting specifies the port to use.
server.port: 5601
# Specifies the address to which the Kibana server will bind. IP addresses and host names are both valid values.
# The default is 'localhost', which usually means remote machines will not be able to connect.
# To allow connections from remote users, set this parameter to a non-loopback address.
server.host: "10.128.0.26"
# Enables you to specify a path to mount Kibana at if you are running behind a proxy.
# Use the `server.rewriteBasePath` setting to tell Kibana if it should remove the basePath
# from requests it receives, and to prevent a deprecation warning at startup.
# This setting cannot end in a slash.
#server.basePath: ""
# Specifies whether Kibana should rewrite requests that are prefixed with
# `server.basePath` or require that they are rewritten by your reverse proxy.
# This setting was effectively always `false` before Kibana 6.3 and will
# default to `true` starting in Kibana 7.0.
#server.rewriteBasePath: false
# The maximum payload size in bytes for incoming server requests.
#server.maxPayloadBytes: 1048576
# The Kibana server's name. This is used for display purposes.
server.name: "ironman"
# The URLs of the Elasticsearch instances to use for all your queries.
elasticsearch.hosts: ["http://0.0.0.0:9200"]
# When this setting's value is true Kibana uses the hostname specified in the server.host
# setting. When the value of this setting is false, Kibana uses the hostname of the host
# that connects to this Kibana instance.
elasticsearch.preserveHost: true
# Kibana uses an index in Elasticsearch to store saved searches, visualizations and
# dashboards. Kibana creates a new index if the index doesn't already exist.
kibana.index: ".kibana"

```

also I tried `./bin/kibana`  
this is the message i am getting.  
`Kibana should not be run as root. Use --allow-root to continue.`

after following instruction  
`./bin/kibana --allow-root`

```
  log [09:53:13.146] [fatal][root] Error: Port 5601 is already in use. Another instance of Kibana may be running!
    at Root.shutdown (/usr/share/kibana/src/core/server/root/index.js:67:18)
    at Root.setup (/usr/share/kibana/src/core/server/root/index.js:46:18)
    at process._tickCallback (internal/process/next_tick.js:68:7)
    at Function.Module.runMain (internal/modules/cjs/loader.js:745:11)
    at startup (internal/bootstrap/node.js:283:19)
    at bootstrapNodeJSCore (internal/bootstrap/node.js:743:3)
 FATAL Error: Port 5601 is already in use. Another instance of Kibana may be running!

```

Thanks

---

<div class="post-metadata">

**Author:** ![wylie](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/wylie/32/81794_2.png) [@wylie](https://discuss.elastic.co/u/wylie)\
**Post date:** [August 7, 2019, 5:34pm UTC](https://discuss.elastic.co/t/kibana-and-elasticsearch-status-is-active-i-can-access-elasticsearch-via-browser-but-kibana-is-giving-error/194197/3 "2019-08-07T17:34:53Z")

</div>

It looks like kibana can't connect to your elasticsearch instance. It looks like your configuration for `elasticsearch.hosts: ["http://0.0.0.0:9200"]` is pointing to a local address instead of the IP you said elasticsearch is located at.

---

<div class="post-metadata">

**Author:** ![Ayush\_Verma](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ayush_verma/32/46709_2.png) [@Ayush\_Verma](https://discuss.elastic.co/u/Ayush_Verma)\
**Post date:** [August 8, 2019, 8:58am UTC](https://discuss.elastic.co/t/kibana-and-elasticsearch-status-is-active-i-can-access-elasticsearch-via-browser-but-kibana-is-giving-error/194197/4 "2019-08-08T08:58:35Z")

</div>

Thanks for the reply, can please elaborate a little bit what should i do now?  
should i change the ip?

---

<div class="post-metadata">

**Author:** ![wylie](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/wylie/32/81794_2.png) [@wylie](https://discuss.elastic.co/u/wylie)\
**Post date:** [August 8, 2019, 3:24pm UTC](https://discuss.elastic.co/t/kibana-and-elasticsearch-status-is-active-i-can-access-elasticsearch-via-browser-but-kibana-is-giving-error/194197/5 "2019-08-08T15:24:39Z")

</div>

Yes, does that solve the issue?

---

<div class="post-metadata">

**Author:** ![Ayush\_Verma](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ayush_verma/32/46709_2.png) [@Ayush\_Verma](https://discuss.elastic.co/u/Ayush_Verma)\
**Post date:** [August 8, 2019, 4:09pm UTC](https://discuss.elastic.co/t/kibana-and-elasticsearch-status-is-active-i-can-access-elasticsearch-via-browser-but-kibana-is-giving-error/194197/6 "2019-08-08T16:09:57Z")

</div>

No , i changed the  
`elasticsearch.host: ["http://internal_ip:9200"]`  
but still its not working.  
What else can i try ??

---

<div class="post-metadata">

**Author:** ![wylie](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/wylie/32/81794_2.png) [@wylie](https://discuss.elastic.co/u/wylie)\
**Post date:** [August 8, 2019, 4:23pm UTC](https://discuss.elastic.co/t/kibana-and-elasticsearch-status-is-active-i-can-access-elasticsearch-via-browser-but-kibana-is-giving-error/194197/7 "2019-08-08T16:23:33Z")

</div>

Just to confirm, you previously said the IP address of elasticsearch is `10.128.0.26:9200`- did you SSH into your Kibana server and verify that that server can access elasticsearch? It sounds like you are having networking issues, and I don't think I can help with those more than I already have.

---

<div class="post-metadata">

**Author:** ![Ayush\_Verma](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ayush_verma/32/46709_2.png) [@Ayush\_Verma](https://discuss.elastic.co/u/Ayush_Verma)\
**Post date:** [August 8, 2019, 4:31pm UTC](https://discuss.elastic.co/t/kibana-and-elasticsearch-status-is-active-i-can-access-elasticsearch-via-browser-but-kibana-is-giving-error/194197/8 "2019-08-08T16:31:15Z")

</div>

Thank you for being with me and replying me.  
Can you tell me how to SSH into kibana server, i know its silly question but i am very new to this networking thing.

---

<div class="post-metadata">

**Author:** ![wylie](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/wylie/32/81794_2.png) [@wylie](https://discuss.elastic.co/u/wylie)\
**Post date:** [August 8, 2019, 6:02pm UTC](https://discuss.elastic.co/t/kibana-and-elasticsearch-status-is-active-i-can-access-elasticsearch-via-browser-but-kibana-is-giving-error/194197/9 "2019-08-08T18:02:41Z")

</div>

I notice that you set `elasticsearch.host`, but the config name is `elasticsearch.hosts`. You can see all the config options here: [https://www.elastic.co/guide/en/kibana/current/settings.html](https://www.elastic.co/guide/en/kibana/current/settings.html)

If you're not very familiar with ssh, I think it's out of scope of what I was trying to ask. I was trying to verify that your Kibana host can talk to your Elasticsearch cluster, but if you can access it from your local machine that is probably fine.

---

<div class="post-metadata">

**Author:** ![Ayush\_Verma](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ayush_verma/32/46709_2.png) [@Ayush\_Verma](https://discuss.elastic.co/u/Ayush_Verma)\
**Post date:** [August 8, 2019, 6:18pm UTC](https://discuss.elastic.co/t/kibana-and-elasticsearch-status-is-active-i-can-access-elasticsearch-via-browser-but-kibana-is-giving-error/194197/10 "2019-08-08T18:18:46Z")

</div>

sorry i think there is some sort of misunderstanding my config name is `elasticsearch.hosts:` . No i don't think my kibana host can talk to elasticsearch cluster that's why i am getting an error message when i hit `curl -X GET "10.128.0.26:5601/"`  
msg: `Kibana server is not ready yet` . Another important information that i mentioned is i installed it on google cloud instance and ultimately i want to access kibana and elasticsearch from my machine my local browser , and i succeed with elasticsearch i can access elasticsearch from my browser using external ip of google instance , but facing trouble with kibana.  
Thanks.

---

<div class="post-metadata">

**Author:** ![wylie](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/wylie/32/81794_2.png) [@wylie](https://discuss.elastic.co/u/wylie)\
**Post date:** [August 8, 2019, 7:38pm UTC](https://discuss.elastic.co/t/kibana-and-elasticsearch-status-is-active-i-can-access-elasticsearch-via-browser-but-kibana-is-giving-error/194197/11 "2019-08-08T19:38:40Z")

</div>

Based on the information you've given me, I'm suspicious of the IP addresses you've told me you're using- they are all local network addresses instead of public internet addresses. I would recommend sshing into your cloud instance and running the same `curl` commands you've told me already to verify network connectivity. If your instance has a public and fixed IP, you could use that. Alternatively, if it only has a private IP, then I'm not sure how you are able to access it from your local machine. I am not going to be able to help any more on this issue unless you can clarify the networking setup more.

---

<div class="post-metadata">

**Author:** ![Ayush\_Verma](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ayush_verma/32/46709_2.png) [@Ayush\_Verma](https://discuss.elastic.co/u/Ayush_Verma)\
**Post date:** [August 9, 2019, 7:52am UTC](https://discuss.elastic.co/t/kibana-and-elasticsearch-status-is-active-i-can-access-elasticsearch-via-browser-but-kibana-is-giving-error/194197/12 "2019-08-09T07:52:45Z")

</div>

Can you tell me how to generate log file in kibana??

---

<div class="post-metadata">

**Author:** ![wylie](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/wylie/32/81794_2.png) [@wylie](https://discuss.elastic.co/u/wylie)\
**Post date:** [August 9, 2019, 2:03pm UTC](https://discuss.elastic.co/t/kibana-and-elasticsearch-status-is-active-i-can-access-elasticsearch-via-browser-but-kibana-is-giving-error/194197/13 "2019-08-09T14:03:46Z")

</div>

You have already shown me a kibana log- can you do that again?

Like I said above, unless you are able to clarify the setup of your network I will not be able to help you more.

---

<div class="post-metadata">

**Author:** ![Ayush\_Verma](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ayush_verma/32/46709_2.png) [@Ayush\_Verma](https://discuss.elastic.co/u/Ayush_Verma)\
**Post date:** [August 9, 2019, 6:41pm UTC](https://discuss.elastic.co/t/kibana-and-elasticsearch-status-is-active-i-can-access-elasticsearch-via-browser-but-kibana-is-giving-error/194197/14 "2019-08-09T18:41:45Z")

</div>

Sir i already tell you everything, i tell you internal as well as external ip of the instance i share log i share yml file, i mean is there anything else? and what is this setup of instance can you please elaborate , what this thing contains?

---

<div class="post-metadata">

**Author:** ![Ayush\_Verma](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ayush_verma/32/46709_2.png) [@Ayush\_Verma](https://discuss.elastic.co/u/Ayush_Verma)\
**Post date:** [August 9, 2019, 6:47pm UTC](https://discuss.elastic.co/t/kibana-and-elasticsearch-status-is-active-i-can-access-elasticsearch-via-browser-but-kibana-is-giving-error/194197/15 "2019-08-09T18:47:09Z")

</div>

Since the IP address is a private one, you might need to create an SSH tunnel from your workstation to your GCP host in order to access it.

This suggestion i got, but didn't get it, can you help me out with this. Do you think its right ?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 6, 2019, 6:47pm UTC](https://discuss.elastic.co/t/kibana-and-elasticsearch-status-is-active-i-can-access-elasticsearch-via-browser-but-kibana-is-giving-error/194197/16 "2019-09-06T18:47:09Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
