# Kibana and Fleet setup failed unable to authenticate user

**URL:** <https://discuss.elastic.co/t/kibana-and-fleet-setup-failed-unable-to-authenticate-user/304325>\
**Category:** Elastic Cloud on Kubernetes (ECK)\
**Tags:** fleet\
**Created:** [May 10, 2022, 9:03am UTC](https://discuss.elastic.co/t/kibana-and-fleet-setup-failed-unable-to-authenticate-user/304325 "2022-05-10T09:03:10Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Kay\_Khan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kay_khan/32/45028_2.png) [@Kay\_Khan](https://discuss.elastic.co/u/Kay_Khan)\
**Post date:** [May 10, 2022, 9:03am UTC](https://discuss.elastic.co/t/kibana-and-fleet-setup-failed-unable-to-authenticate-user/304325/1 "2022-05-10T09:03:10Z")

</div>

Im trying to setup kibana and fleet uisng the following example. [https://github.com/elastic/cloud-on-k8s/blob/main/config/recipes/elastic-agent/fleet-kubernetes-integration.yaml](https://github.com/elastic/cloud-on-k8s/blob/main/config/recipes/elastic-agent/fleet-kubernetes-integration.yaml)

However kibana is giving me the following error:

> [2022-05-10T08:51:45.939+00:00][INFO][http.server.Kibana] http server  
> running at [https://0.0.0.0:5601](https://0.0.0.0:5601) [2022-05-10T08:51:45.964+00:00][WARN  
> ][environment] Detected an unhandled Promise rejection: ResponseError:  
> unable to authenticate user [elastic-system-kibana-prod-kibana-user]  
> for REST request  
> [/.kibana\_task\_manager\_8.2.0/\_doc/task%3Adata\_enhanced\_search\_sessions\_cleanup?refresh=wait\_for]:  
> security\_exception: [security\_exception] Reason: unable to  
> authenticate user [elastic-system-kibana-prod-kibana-user] for REST  
> request  
> [/.kibana\_task\_manager\_8.2.0/\_doc/task%3Adata\_enhanced\_search\_sessions\_cleanup?refresh=wait\_for]  
> at KibanaTransport.request (/usr/share/kibana/node\_modules/@elastic/transport/lib/Transport.js:476:27)  
> at processTicksAndRejections (node:internal/process/task\_queues:96:5)  
> at KibanaTransport.request (/usr/share/kibana/src/core/server/elasticsearch/client/create\_transport.js:58:16)  
> at ClientTraced.DeleteApi [as delete] (/usr/share/kibana/node\_modules/@elastic/elasticsearch/lib/api/api/delete.js:36:12)  
> [2022-05-10T08:51:46.088+00:00][INFO][status] Kibana is now critical  
> [2022-05-10T08:51:46.099+00:00][WARN][environment] Detected an  
> unhandled Promise rejection: ResponseError: unable to authenticate  
> user [elastic-system-kibana-prod-kibana-user] for REST request  
> [/.kibana\_8.2.0/\_search?rest\_total\_hits\_as\_int=true]:  
> security\_exception: [security\_exception] Reason: unable to  
> authenticate user [elastic-system-kibana-prod-kibana-user] for REST  
> request [/.kibana\_8.2.0/\_search?rest\_total\_hits\_as\_int=true]  
> at KibanaTransport.request (/usr/share/kibana/node\_modules/@elastic/transport/lib/Transport.js:476:27)  
> at processTicksAndRejections (node:internal/process/task\_queues:96:5)  
> at KibanaTransport.request (/usr/share/kibana/src/core/server/elasticsearch/client/create\_transport.js:58:16)  
> at ClientTraced.SearchApi [as search] (/usr/share/kibana/node\_modules/@elastic/elasticsearch/lib/api/api/search.js:65:12)

**kibana.yml**

```auto
apiVersion: kibana.k8s.elastic.co/v1
kind: Kibana
metadata:
  name: kibana-prod
  namespace: elastic-system
spec:
  version: 8.2.0
  count: 1
  elasticsearchRef:
    name: elasticsearch-prod
  config:
    xpack.fleet.agents.elasticsearch.hosts: ["https://elasticsearch-prod-es-http.elastic-system.svc:9200"]
    xpack.fleet.agents.fleet_server.hosts: ["https://fleet-server-agent-http.elastic-system.svc:8220"]
    xpack.fleet.packages:
    - name: system
      version: latest
    - name: elastic_agent
      version: latest
    - name: fleet_server
      version: latest
    - name: kubernetes
      version: 1.17.2
    xpack.fleet.agentPolicies:
    - name: Fleet Server on ECK policy
      id: eck-fleet-server
      namespace: default
      monitoring_enabled:
      - logs
      - metrics
      is_default_fleet_server: true
      package_policies:
      - name: fleet_server-1
        id: fleet_server-1
        package:
          name: fleet_server
    - name: Elastic Agent on ECK policy
      id: eck-agent
      namespace: default
      monitoring_enabled:
      - logs
      - metrics
      unenroll_timeout: 900
      is_default: true
      package_policies:
      - package:
          name: system
        name: system-1
      - package:
          name: kubernetes
        name: kubernetes-1

```

---

<div class="post-metadata">

**Author:** ![Kay\_Khan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kay_khan/32/45028_2.png) [@Kay\_Khan](https://discuss.elastic.co/u/Kay_Khan)\
**Post date:** [May 11, 2022, 8:08am UTC](https://discuss.elastic.co/t/kibana-and-fleet-setup-failed-unable-to-authenticate-user/304325/2 "2022-05-11T08:08:06Z")

</div>

I managed to fix this, the github example breaks the authentication for unknown reason

```auto
   - package:
          name: system
        name: system-1
      - package:
          name: kubernetes
        name: kubernetes-1

```

should be

```auto
        package_policies:
          - name: system-1
            id: system-1
            package:
              name: system
          - name: kubernetes-1
            id: kubernetes-1
            package:
              name: kubernetes 

```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 8, 2022, 8:08am UTC](https://discuss.elastic.co/t/kibana-and-fleet-setup-failed-unable-to-authenticate-user/304325/3 "2022-06-08T08:08:25Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
