# Kibana can not login when upgrade elk from 5.1 to 6.0.0

**URL:** <https://discuss.elastic.co/t/kibana-can-not-login-when-upgrade-elk-from-5-1-to-6-0-0/107856>\
**Category:** Kibana\
**Created:** [November 16, 2017, 5:11am UTC](https://discuss.elastic.co/t/kibana-can-not-login-when-upgrade-elk-from-5-1-to-6-0-0/107856 "2017-11-16T05:11:42Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![niulei](https://avatars.discourse-cdn.com/v4/letter/n/9d8465/32.png) [@niulei](https://discuss.elastic.co/u/niulei)\
**Post date:** [November 16, 2017, 5:11am UTC](https://discuss.elastic.co/t/kibana-can-not-login-when-upgrade-elk-from-5-1-to-6-0-0/107856/1 "2017-11-16T05:11:42Z")

</div>

I sucess update elastic (2 node) from 5.1 to 6.0，and install x-pack to elastic6.0 ，elastic6.0 cluster work ok.

then,update kibana to 6,and install x-pack to kibana sucessful .but kibana console can not login with"Login is currently disabled. Administrators should consult the Kibana logs for more details."

detail kibana log show :  
log [01:39:39.111] [info][status][plugin:kibana@6.0.0] Status changed from uninitialized to green - Ready  
log [01:39:39.216] [info][status][plugin:elasticsearch@6.0.0] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
log [01:39:39.227] [info][status][plugin:xpack\_main@6.0.0] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
log [01:39:39.734] [info][status][plugin:graph@6.0.0] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
log [01:39:39.769] [info][status][plugin:monitoring@6.0.0] Status changed from uninitialized to green - Ready  
log [01:39:42.770] [warning][reporting] Generating a random key for xpack.reporting.encryptionKey. To prevent pending reports from failing on restart, please set xpack.reporting.encryptionKey in kibana.yml  
log [01:39:42.780] [info][status][plugin:reporting@6.0.0] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
log [01:39:42.833] [error][status][plugin:xpack\_main@6.0.0] Status changed from yellow to red - Your Kibana index is out of date, reset it or use the X-Pack upgrade assistant.  
log [01:39:42.834] [error][status][plugin:graph@6.0.0] Status changed from yellow to red - Your Kibana index is out of date, reset it or use the X-Pack upgrade assistant.  
log [01:39:42.836] [error][status][plugin:reporting@6.0.0] Status changed from yellow to red - Your Kibana index is out of date, reset it or use the X-Pack upgrade assistant.  
log [01:39:42.837] [error][status][plugin:elasticsearch@6.0.0] Status changed from yellow to red - Your Kibana index is out of date, reset it or use the X-Pack upgrade assistant.  
log [01:39:42.848] [error][status][plugin:security@6.0.0] Status changed from uninitialized to red - Your Kibana index is out of date, reset it or use the X-Pack upgrade assistant.  
log [01:39:42.849] [warning][security] Generating a random key for xpack.security.encryptionKey. To prevent sessions from being invalidated on restart, please set xpack.security.encryptionKey in kibana.yml  
log [01:39:42.861] [warning][security] Session cookies will be transmitted over insecure connections. This is not recommended.  
log [01:39:42.916] [error][status][plugin:searchprofiler@6.0.0] Status changed from uninitialized to red - Your Kibana index is out of date, reset it or use the X-Pack upgrade assistant.  
log [01:39:42.929] [error][status][plugin:ml@6.0.0] Status changed from uninitialized to red - Your Kibana index is out of date, reset it or use the X-Pack upgrade assistant.  
log [01:39:42.995] [info][status][plugin:ml@6.0.0] Status changed from red to yellow - Waiting for Elasticsearch  
log [01:39:43.018] [error][status][plugin:tilemap@6.0.0] Status changed from uninitialized to red - Your Kibana index is out of date, reset it or use the X-Pack upgrade assistant.  
log [01:39:43.025] [info][status][plugin:ml@6.0.0] Status changed from yellow to green - Ready  
log [01:39:43.031] [error][status][plugin:watcher@6.0.0] Status changed from uninitialized to red - Your Kibana index is out of date, reset it or use the X-Pack upgrade assistant.  
log [01:39:43.070] [info][status][plugin:grokdebugger@6.0.0] Status changed from uninitialized to green - Ready  
log [01:39:43.084] [info][status][plugin:dashboard\_mode@6.0.0] Status changed from uninitialized to green - Ready  
log [01:39:43.090] [error][status][plugin:logstash@6.0.0] Status changed from uninitialized to red - Your Kibana index is out of date, reset it or use the X-Pack upgrade assistant.  
log [01:39:43.124] [info][status][plugin:console@6.0.0] Status changed from uninitialized to green - Ready  
log [01:39:43.143] [info][status][plugin:metrics@6.0.0] Status changed from uninitialized to green - Ready  
log [01:39:43.404] [info][status][plugin:timelion@6.0.0] Status changed from uninitialized to green - Ready  
log [01:39:43.411] [info][listening] Server running at [http://10.23.16.196:80](http://10.23.16.196:80)  
log [01:39:43.413] [error][status][ui settings] Status changed from uninitialized to red - Elasticsearch plugin is red

my kibana.yml was alredy add elastic's credential .

how reset Kibana index or use the X-Pack upgrade assistant ?

thanks ！

---

<div class="post-metadata">

**Author:** ![niulei](https://avatars.discourse-cdn.com/v4/letter/n/9d8465/32.png) [@niulei](https://discuss.elastic.co/u/niulei)\
**Post date:** [November 16, 2017, 5:23am UTC](https://discuss.elastic.co/t/kibana-can-not-login-when-upgrade-elk-from-5-1-to-6-0-0/107856/2 "2017-11-16T05:23:01Z")

</div>

i solved this issue by add "kibana.index: ".kibana6"" in kibana.yml .

thanks .

---

<div class="post-metadata">

**Author:** ![Court](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/court/32/6640_2.png) [@Court](https://discuss.elastic.co/u/Court)\
**Post date:** [November 20, 2017, 4:31pm UTC](https://discuss.elastic.co/t/kibana-can-not-login-when-upgrade-elk-from-5-1-to-6-0-0/107856/3 "2017-11-20T16:31:16Z")

</div>

I'm glad you were able to find a solution for this, and thanks for posting an update in case others find themselves in a similar situation.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 23, 2017, 2:24pm UTC](https://discuss.elastic.co/t/kibana-can-not-login-when-upgrade-elk-from-5-1-to-6-0-0/107856/5 "2017-12-23T14:24:45Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
