# Kibana Canvas is throwing unusual weird error

**URL:** <https://discuss.elastic.co/t/kibana-canvas-is-throwing-unusual-weird-error/137632>\
**Category:** Kibana\
**Created:** [June 27, 2018, 1:49pm UTC](https://discuss.elastic.co/t/kibana-canvas-is-throwing-unusual-weird-error/137632 "2018-06-27T13:49:27Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![yash\_mangla](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yash_mangla/32/25889_2.png) [@yash\_mangla](https://discuss.elastic.co/u/yash_mangla)\
**Post date:** [June 27, 2018, 1:49pm UTC](https://discuss.elastic.co/t/kibana-canvas-is-throwing-unusual-weird-error/137632/1 "2018-06-27T13:49:27Z")

</div>

Hello Team,

I'm facing following error when i trying to install canvas plugin into kibana

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/4/6/467e1d4d7643079b6d72e459592bd01b55a29f08.png)

even i have installed all version correctly in machine.

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/e/4/e49d3c43aea15ac79c354804a2aef3b53f64eae2.png)

Please provide me a appropriate solution regarding such issue.

Regards,  
Yash M.

---

<div class="post-metadata">

**Author:** ![Joe\_Fleming](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/joe_fleming/32/3561_2.png) [@Joe\_Fleming](https://discuss.elastic.co/u/Joe_Fleming)\
**Post date:** [June 27, 2018, 4:26pm UTC](https://discuss.elastic.co/t/kibana-canvas-is-throwing-unusual-weird-error/137632/2 "2018-06-27T16:26:16Z")

</div>

This is a cryptic Kibana error, what it's trying to say is that you are running Kibana version 6.2.4, but the plugin you're trying to install expects you to be running 6.3.0. You'll need to upgrade your stack to 6.3.0 to run the latest version of Canvas. As stated in the [installation instructions](http://canvas.elastic.co/stories/installing.html):

> During the technology preview period, Canvas will be published as a separate plugin to allow us to iterate quickly based on user feedback. **It will require the latest GA versions of Elasticsearch, Kibana, and X-Pack** , and should be installed outside of your production environment on a dev/test system.

You can grab the latest release [from the downloads page](https://www.elastic.co/downloads). Alternatively, you may opt to use an older release that was built to work with 6.2.4 if you can't upgrade. The last version that worked before the 6.3.0 release was `kibana-canvas-0.1.1985.zip`.

---

<div class="post-metadata">

**Author:** ![yash\_mangla](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yash_mangla/32/25889_2.png) [@yash\_mangla](https://discuss.elastic.co/u/yash_mangla)\
**Post date:** [June 28, 2018, 10:00am UTC](https://discuss.elastic.co/t/kibana-canvas-is-throwing-unusual-weird-error/137632/3 "2018-06-28T10:00:12Z")

</div>

Hi @Joe_Fleming,

As you said in following line:

> [@Joe\_Fleming](#):
>
> The last version that worked before the 6.3.0 release was `kibana-canvas-0.1.1985.zip`

Installation was successful but not able to start kibana service. and in `/var/log/elasticsearch/elasticsearch.log` there is not any error is showing regarding this. Could you tell me what might be all possible reason behind this error.

Regards,  
Yash M.

---

<div class="post-metadata">

**Author:** ![Joe\_Fleming](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/joe_fleming/32/3561_2.png) [@Joe\_Fleming](https://discuss.elastic.co/u/Joe_Fleming)\
**Post date:** [July 2, 2018, 6:48pm UTC](https://discuss.elastic.co/t/kibana-canvas-is-throwing-unusual-weird-error/137632/4 "2018-07-02T18:48:23Z")

</div>

> in /var/log/elasticsearch/elasticsearch.log there is not any error

There wouldn't be, if something is wrong it's probably the Kibana instance. Can you check for error messages in `/var/log/elasticsearch/kibana.log` (I think that's the right path anyway...)?

---

<div class="post-metadata">

**Author:** ![yash\_mangla](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yash_mangla/32/25889_2.png) [@yash\_mangla](https://discuss.elastic.co/u/yash_mangla)\
**Post date:** [July 6, 2018, 8:17am UTC](https://discuss.elastic.co/t/kibana-canvas-is-throwing-unusual-weird-error/137632/5 "2018-07-06T08:17:44Z")

</div>

I didn't think that file will be there because kibana bydefault is not creating any log files and i didn't defined any path in kibana to store kibana logs.

---

<div class="post-metadata">

**Author:** ![Joe\_Fleming](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/joe_fleming/32/3561_2.png) [@Joe\_Fleming](https://discuss.elastic.co/u/Joe_Fleming)\
**Post date:** [July 6, 2018, 4:28pm UTC](https://discuss.elastic.co/t/kibana-canvas-is-throwing-unusual-weird-error/137632/6 "2018-07-06T16:28:08Z")

</div>

> by default is not creating any log files

Huh, I wasn't aware of that. You might have some output in your system logs then, or you can enable the log output. Either way, Kibana should give you some kind of output explaining why it won't start.

---

<div class="post-metadata">

**Author:** ![yash\_mangla](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yash_mangla/32/25889_2.png) [@yash\_mangla](https://discuss.elastic.co/u/yash_mangla)\
**Post date:** [July 9, 2018, 5:09pm UTC](https://discuss.elastic.co/t/kibana-canvas-is-throwing-unusual-weird-error/137632/7 "2018-07-09T17:09:39Z")

</div>

> [@Joe\_Fleming](#):
>
> Either way, Kibana should give you some kind of output explaining why it won't start.

Not sure, because i'm using kibana on centos platform and it's run as a daemon service. i don't think i will get any log regarding that. So, now i guess i only option remains to enable kibana logging in kibana.yml file.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 6, 2018, 5:09pm UTC](https://discuss.elastic.co/t/kibana-canvas-is-throwing-unusual-weird-error/137632/8 "2018-08-06T17:09:45Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
