# Kibana chkconfig startup error

**URL:** <https://discuss.elastic.co/t/kibana-chkconfig-startup-error/75892>\
**Category:** Kibana\
**Created:** [February 21, 2017, 1:54pm UTC](https://discuss.elastic.co/t/kibana-chkconfig-startup-error/75892 "2017-02-21T13:54:08Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![deepunaren](https://avatars.discourse-cdn.com/v4/letter/d/e495f1/32.png) [@deepunaren](https://discuss.elastic.co/u/deepunaren)\
**Post date:** [February 21, 2017, 1:54pm UTC](https://discuss.elastic.co/t/kibana-chkconfig-startup-error/75892/1 "2017-02-21T13:54:08Z")

</div>

kibana-5.2.1-linux-x86\_64]# chkconfig --add kibana  
kibana-5.2.1-linux-x86\_64]# service kibana start  
which: no node in (/sbin:/usr/sbin:/bin:/usr/bin)  
unable to find usable node.js executable.

if I run ./kibana it runs perfectly. I am just trying to add it to service so that I can stay in background.

please anyone can assist on this.

---

<div class="post-metadata">

**Author:** ![thomasneirynck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/thomasneirynck/32/23313_2.png) [@thomasneirynck](https://discuss.elastic.co/u/thomasneirynck)\
**Post date:** [February 21, 2017, 3:37pm UTC](https://discuss.elastic.co/t/kibana-chkconfig-startup-error/75892/2 "2017-02-21T15:37:48Z")

</div>

hi @deepunaren,

to run as a service, it is probably easy to start with the debian package. Here's a step-by-step [Running kibana as a service on Linux](https://discuss.elastic.co/t/running-kibana-as-a-service-on-linux/72021/2). That will take care of the hoisting the node-runtime for you.

thanks,

---

<div class="post-metadata">

**Author:** ![deepunaren](https://avatars.discourse-cdn.com/v4/letter/d/e495f1/32.png) [@deepunaren](https://discuss.elastic.co/u/deepunaren)\
**Post date:** [February 22, 2017, 8:34am UTC](https://discuss.elastic.co/t/kibana-chkconfig-startup-error/75892/3 "2017-02-22T08:34:51Z")

</div>

HI,

Thanks for the Reply, I try using rpm which you suggested. but I still facing same issue.

Loaded plugins: security  
Setting up Install Process  
Examining kibana-5.2.1-x86\_64.rpm: kibana-5.2.1-1.x86\_64  
Marking kibana-5.2.1-x86\_64.rpm to be installed  
VMwareTools5-5 | 951 B 00:00  
ol6\_custom\_x86\_64 | 951 B 00:00  
ol6\_radia | 951 B 00:00  
ol6u7\_base | 3.7 kB 00:00  
ol6u7\_updates | 951 B 00:00  
Resolving Dependencies  
--\> Running transaction check  
---\> Package kibana.x86\_64 0:5.2.1-1 will be installed  
--\> Finished Dependency Resolution

Dependencies Resolved

# ================================================================================ Package Arch Version Repository Size

Installing:  
kibana x86\_64 5.2.1-1 /kibana-5.2.1-x86\_64 141 M

# Transaction Summary

Install 1 Package(s)

Total size: 141 M  
Installed size: 141 M  
Downloading Packages:  
Running rpm\_check\_debug  
Running Transaction Test  
Transaction Test Succeeded  
Running Transaction  
Warning: RPMDB altered outside of yum.  
which: no node in (/sbin:/usr/sbin:/bin:/usr/bin)  
unable to find usable node.js executable.  
error: %pre(kibana-5.2.1-1.x86\_64) scriptlet failed, exit status 1  
Error in PREIN scriptlet in rpm package kibana-5.2.1-1.x86\_64  
error: install: %pre scriptlet failed (2), skipping kibana-5.2.1-1  
Verifying : kibana-5.2.1-1.x86\_64 1/1

Failed:  
kibana.x86\_64 0:5.2.1-1

---

<div class="post-metadata">

**Author:** ![thomasneirynck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/thomasneirynck/32/23313_2.png) [@thomasneirynck](https://discuss.elastic.co/u/thomasneirynck)\
**Post date:** [February 28, 2017, 5:04pm UTC](https://discuss.elastic.co/t/kibana-chkconfig-startup-error/75892/4 "2017-02-28T17:04:19Z")

</div>

@deepunaren

hmm, I'm not sure what's what.

- Did you modify the install scripts ('pre\_install.sh') at all?
- what OS are you on? I tried on Ubuntu 16, which is fine.
- How does your /usr/bin folder look like? Is there a node executable there?

thx,

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 28, 2017, 5:04pm UTC](https://discuss.elastic.co/t/kibana-chkconfig-startup-error/75892/5 "2017-03-28T17:04:32Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
